[ADVANCE FEATURES OF EXCEL]
ADVANCE FEATURES OF EXCEL

CHAPTER-03

Introduction

It can be difficult to interpret Excel workbooks that contain a lot of
data. Charts allow you to illustrate your workbook data graphically, which makes it
easy to visualize comparisons and trends.

Optional: Download our practice workbook.

Watch the video below to learn more about charts.

Understanding charts

Excel has several different types of charts, allowing you to choose the one that
best fits your data. In order to use charts effectively, you'll need to understand how
different charts are used.
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https://media.gcflearnfree.org/content/563ba214ca7fac0d9c7b3f7d_11_05_2015/excel2016_charts_practice.xlsx

Click the arrows in the slideshow below to learn more about the types of charts in
Excel.

arrow_back_ios

Types of Charts
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Excel has a variety of chart types, each with its own
advantages. Click the arrows to see some of the different
types of charts available in Excel.
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Column charts use vertical bars to represent data. They can
work with many different types of data, but they're most
frequently used for comparing information.

Line charts are ideal for showing trends. The data points are
connected with lines, making it easy to see whether values
are increasing or decreasing over time.

Pie charts make it easy to compare proportions. Each value
is shown as a slice of the pie, so it's easy to see which
values make up the percentage of a whole.
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Bar charts work just like column charts,
but they use horizontal rather than
vertical bars.
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Area charts are similar to line charts,

except the areas under the lines are
filled in.
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Surface charts allow you to display data
across a 3D landscape. They work best
with large data sets, allowing you to see

a variety of information at the same
time.

In addition to chart types, you'll need to understand how to read a chart. Charts
contain several different elements, or parts, that can help you interpret the data.

Click the buttons in the interactive below to learn about the different parts of a
chart.
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To insert a chart:

1. Select the cells you want to chart, including
the column titles and row labels. These
cells will be the source data for the chart.
In our example, we'll select cells A1:F6.

2. From the Insert tab, click the
A B C D E F G

B anuary Bl rebruary B march B April B may
$78,970 $82,262 $48,640 $49,985

Sci-Fi & Fantasy $16,730 $19,730 $12,109 $11,355

desired Chart command. In our example,
we'll select Column.
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3. Choose the desired chart type from the
drop-down menu.
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4. The Selected chart will be inserted into the
worksheet.
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A B C D E F G H

Mcere  Bianuary  KdFebruary Rdvarch  Bdlapri  Rdvay
2 Classics $18,580 $49,225 $16,326 $10,017 $26,134
3 Mystery $78,970 $82,262 $48,640 $49,985 $73,428
4 Romance $24,236 $131,390 $79,022 $71,009 $81,474
5 Sci-Fi & Fantasy $16,730 $19,730 $12,109 $11,355 $17,686
6 Young Adult | $35,358 $42,685 $20,893 $16,065 521,388,
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If you're not sure which type of chart to use, the Recommended Charts command
will suggest several different charts based on the source data.

Insert Page Layout Formulas Data Review View Q Tell me

=r it - -
ya Store
D lag 2 1R -

ided Table Pictures Online ’ - Recommended A
- P My Add-ins ~ v e ke -
es Pictures a : E Charts % v, L

Illustrations Add-ins Charts

Chart and layout style

After inserting a chart, there are several things you may want to change about the
way your data is displayed. It's easy to edit a chart's layout and style from
the Design tab.

« Excel allows you to add chart elements—
such as chart titles, legends, and data
labels—to make your chart easier to read.
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To add a chart element, click the Add Chart
Element command on the Design tab, then
choose the desired element from the drop-
down menu.
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To edit a chart element, like a chart title,
simply double-click the placeholder and

begin typing.
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If you don't want to add chart elements
individually, you can use one of Excel's
predefined layouts. Simply click the Quick
Layout command, then choose the desired
layout from the drop-down menu.
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o Excel also includes several chart styles,

which allow you to quickly modify the look
and feel of your chart. To change the chart
style, select the desired style from

the Chart styles group. You can also click
the drop-down arrow on the right to see
more styles.

Bookstore Sales - Excel Chart Tools
Insert Page Layout Formulas Data Review View Design Format Q Tell me what you want to do... YOU
o e
o can
change | s ol Mo | it I 2 s olilell e Jlml |||| atae =l also
Colors v/=s B
Chart Styles use the
Style 8
fx e chart
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formatting shortcut buttons to quickly add chart elements, change the chart style,
and filter the chart data.
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Other chart options

There are many other ways to customize and organize your charts. For example,
Excel allows you to rearrange a chart's data, change the chart type, and
even move the chart to a different location in a workbook.

To switch row and column data:

Sometimes you may want to change the way charts group your data. For example,
in the chart below Book Sales data is grouped by genre, with columns for each
month. However, we could switch the rows and columns so the chart will group
the data by month, with columns for each genre. In both cases, the chart contains
the same data—it's just organized differently.
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1. Select the chart you want to modify.

2. From the Design tab, select the Switch
Row/Column command.

Chart Tools

Format Q Tell me what you want to do...

1w N
_ Switch Row/ Select Change
%Column Data Chart Type
les Data Type

3. The rows and columns will be switched. In
our example, the data is now grouped by
month, with columns for each genre.
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To change the chart type:

If you find that your data isn't well suited to a certain chart, it's easy to switch to a
new chart type. In our example, we'll change our chart from a column chart to a
line chart.

1. From the Design tab, click the Change
Chart Type command.

Chart Tools

Format Q Tell me what you want to do...

2 = e o)

— Switch Row/ Select = Change Move
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2. The Change Chart Type dialog box will
appear. Select a new chart type and layout,
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then click OK. In our example, we'll choose
a Line chart.

Change Chart Type

kv Recent
Templates
Column
Line

Pie

Bar

Area

XY (Scatter)
Stock
Surface
Radar

Treemap

X WE SN e R

Sunburst
Histogram

Box & Whisker
Waterfall

Combo

FEEFE

Recommended Charts All Charts

? X
. // / A < ‘ /- » J,.’ //'\\::‘ 7
~ L v / o RS
Line
Book Sales Book Sales
$140,000 $140,000
5120,000 $120,000
5100,000 $100,000
580,000 580,000
560,000 560,000
540,000 540,000
$20,000 520,000
s0 50
Classics Mystery Romance  SciFiG Fantssy  Young Aduk Janusry Fehruary March April May
—lanuary FEDIUSTY e MEMCH e APT| e MaY ——Classics MYSIErY e ROMANCE e S0-Fi & FANASY e YOUNE AUl
0K % Cancel

To move a chart:

3.

The selected chart type will appear. In our
example, the line chart makes it easier to
see trends in sales data over time.
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Whenever you insert a new chart, it will appear as an object on the same
worksheet that contains its source data. Alternatively, you can move the chart to
a new worksheet to help keep your data organized.

1. Select the chart you want to move.

2. Click the Design tab, then select the Move
Chart command.

Chart Tools

Format  Q Tell me what you want to do..

L e : Em II

%\;\4 — Switch Row/ Select Change Move
Column Data Chart Type Char‘tl}
les Data Type Location

3. The Move Chart dialog box will appear.
Select the desired location for the chart. In
our example, we'll choose to move it to
a New sheet, which will create a new
worksheet.

4. Click OK.

Move Chart ? X

Choose where you want the chart to be placed:

|_|J JJ © New sheet: Chart1

|_IJ I O Object in: Fiction Book Sales v
L

OK i Cancel
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5. The chart will appear in the selected
location. In our example, the chart now
appears on a new worksheet.

Chart Title

Chart1 | Fiction Book Sales | (@ p

Keeping charts up to date

By default, when you add more data to your spreadsheet, the chart may not
include the new data. To fix this, you can adjust the data range. Simply click the
chart, and it will highlight the data range in your spreadsheet. You can then click
and drag the handle in the lower-right corner to change the data range.

B . i . D . E . F
_.January February March April IMay

518,580 549,225 516,326 $10,017 526,134

$78,970 582,262 548,640 549,985 573,428

$24,236 $131,390 $79,022 §71,009 581,474

$16,730 $19,730 $12,109 $11,355 517,686
i $35,358 542,685 520,893 Slﬁ,[}ﬁSﬁ 521,388
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If you frequently add more data to your spreadsheet, it may become tedious to
update the data range. Luckily, there is an easier way. Simply format your source
data as a table, then create a chart based on that table. When you add more data
below the table, it will automatically be included in both the table and the chart,
keeping everything consistent and up to date.

Watch the video below to learn how to use tables to keep charts up to date.

To group rows or columns:

1. Select the rows or columns you want to group. In this example,
we'll select columns B, C, and D.

A B C D E
B Homeroom # (First Name Last Name Payment Method
2 105 Melissa White Debit Card Small
3 105 Esther Yaron Pending Small
4 135 Anisa Naser Check Bounced |Small
5 220-A Brigid Ellison Cash Small
6 220-A Christopher Peyton-Gomez Check Small
7 220-B Michael Lazar Cash Small
8 220-B Malik Reynolds Cash Small
9 220-B Wendy Shaw Cash Small
10 105 Nathan Albee Check Medium

Ai]

the Group command.
rﬂ-up v
ngroup
What-If Forecast SreEp

u|
2 &2
E
Analysis~  Sheet EE Subtotal

2. Select the Data tab on the Ribbon, then click
Forecast Cutline P

rﬂ1 TE'I

010G

3. The selected rows or columns will be grouped. In our example,
columns B, C, and D are grouped.
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A B C D E
0 Homeroom # [First Name Last Name Payment Method [T-Shit Size
2 105 Melissa White Debit Card Small
3 105 Esther Yaron Pending Small
4 135 Anisa Naser Check Bounced |Small
5 220-A Brigid Ellison Cash Small
6 220-A Christopher Peyton-Gomez Check Small
7 220-B Michael Lazar Cash Small
8 220-B Malik Reynolds Cash Small
9 220-B Wendy Shaw Cash Small
10 105 Nathan Albee Check Medium

To ungroup data, select the grouped rows or columns, then click
the Ungroup command.

0 5E Group - +
3 [F Boow
’ & Ungroup -
What-If Forecast =
Analysis - Sheet Ei subtotal

Forecast Cutline P

To hide and show groups:

1. To hide a group, click the minus sign, also known as the Hide
Detail button.
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&
A B C D E

0 Homeroom # [First Name Last Name Payment Method [T-Shit Size

2 105 Melissa White Debit Card Small

3 105 Esther Yaron Pending Small

4 135 Anisa Naser Check Bounced |Small

5 220-A Brigid Ellison Cash Small

6 220-A Christopher Peyton-Gomez Check Small

7 220-B Michael Lazar Cash Small

8 220-B Malik Reynolds Cash Small

9 220-B Wendy Shaw Cash Small

10 105 Nathan Albee Check Medium

2. The group will be hidden. To show a hidden group, click the
plus sign, also known as the Show Detail button.

1 +

oy
A E F | G |

0 Homeroom # | -Shir Size.

2 105 Small

3 105 Small

4 135 Small

5 220-A Small

6 220-A Small

7 220-B Small

8 220-B Small

9 220-B Small

10 105 Medium

Creating subtotals

The Subtotal command allows you to automatically create groups and use
common functions like SUM, COUNT, and AVERAGE to help summarize your data.
For example, the Subtotal command could help to calculate the cost of office
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supplies by type from a large inventory order. It will create a hierarchy of groups,
known as an outline, to help organize your worksheet.

Your data must be correctly sorted before using the Subtotal command, so you
may want to review our lesson on Sorting Data to learn more.

To create a subtotal:

In our example, we'll use the Subtotal command with a T-shirt order form to
determine how many T-shirts were ordered in each size (Small, Medium, Large,
and X-Large). This will create an outline for our worksheet with a group for each T-
shirt size and then count the total number of shirts in each group.

1. First, sort your worksheet by the data you want to subtotal. In
this example, we'll create a subtotal for each T-shirt size, so our
worksheet has been sorted by T-shirt size from smallest to
largest.

|l Homeroom # First Name Last Name Payment Method T-Shirt Size
2 105 Melissa White Debit Card

3 105 Esther Yaron Pending Small

4 135 Anisa Naser Check Bounced Small

5 220-A Brigid Ellison Cash Small

6 220-A Christopher Peyton-Gomez Check Small
7 220-B Michael Lazar Cash Small

8 | 220-B Malik Reynolds Cash Small

9 | 220-B Wendy Shaw Cash Small
10 105 Nathan Albee Check Medium
1 105 Christiana  Chen Check Bounced Medium
12 105 Sidney Kelly Check Medium
13 110 Matt Benson Money Order Medium
14 110 Gabriel Del Toro Cash Medium

2. Select the Data tab, then click the Subtotal command.
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What-If Forecast
Analysis = Sheet
Forecast

&E Group -
@E Ungroup ~
El subtotal

Cutline P

3. The Subtotal dialog box will appear. Click the drop-down arrow
for the At each change in: field to select the column you want
to subtotal. In our example, we'll select T-Shirt Size.

4. Click the drop-down arrow for the Use function: field to select
the function you want to use. In our example, we'll
select COUNT to count the number of shirts ordered in each

size.

Subtotal

At each change in:
T-5hirt 5Size
Use function:

Count

Sum

_P'rcuduct

5. In the Add subtotal to: field, select the column where you want
the calculated subtotal to appear. In our example, we'll
select T-Shirt Size. When you're satisfied with your selections,

click OK.
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Subtotal ? x>

At each change in:
T-5hirt Size w

Use function:

v
Add subtotal to:

|:| Homeroom #
|:| First Mame

[ ]Last Mame

|:| Payment Method

Replace current subtotals
|:| Page break between groups
Summary below data

Remove All Cancel

6. The worksheet will be outlined into groups, and
the subtotal will be listed below each group. In our example,
the data is now grouped by T-shirt size, and the number of
shirts ordered in that size appears below each group.
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