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First Generation Computer 

COMPUTER LANGUAGES 

High-level Language 

Fourth-generation Language 

LEARNING IN  THIS CHAPTER   H 
r  Program and Programming Concepts 

r  Machine Language 

r  Assembly Language 

Language is a medium to express our views and feelings. To communicate with a computer, we need a language that 

it understands. For every action, a computer has to be given instructions accordingly. 

A Program is a set of instructions that tells the computerwhat to do. 

The process of writing specific instructions in a computer language is called Programming. Each programming 

language has its own specific rules. The programming languages have developed considerably, due to the ease 

and ability of the programmers to write powerful application programs. 

The development of computer languages has been classified into the following categories: 

Computer Languages 

     

High-level 
Language 

V 

Fourth-generation 
Language 

Machine 
Language 

 

Assembly 
Language 

 

      

MACHINE LANGUAGE (FIRST GENERATION) 

It is the only language that a computer understands. It is expressed in binary 

form, i.e., '0' and '1' where 0 means 'Off' state and 1 means 'On' state. 

Machine language has the advantage of having very high speed and low 

memory utilisation. 

But understanding and learning machine language is a tough and 

time-consuming process. It is very difficult to write and debug programs 

written in machine language. The programs written in machine language are 

machine-dependent. That is why Machine language is also regarded as a 

Low-level Language (LLL). A machine language program written for one 

computer may or may not run on another computer. Because of this, very few 

people opt for specialisation in machine language. 

ASSEMBLY LANGUAGE (SECOND GENERATION) 

This language uses mnemonic codes or symbols in place of 0 and 1. For example, if the operation code for add is 0010 

in the binary language, it can be directly written as 'ADD' in assembly language, as Assembly language uses symbolic 

codes. Hence, it is easierto work with Assemblylanguagethan binary language. 

Since a computer can only understand machine language, so assembly language programs have to be converted 
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Fact File 

Figure 1.2:  Second 
Generation Computer 

Figure 1.3:  Third 
Generation Computer 

Fact File 

into machine language. Translator programs known as 

Assemblers were developed to convert the assembly 

language program into machine language. 

A program written in assembly language is called the 

Source program, whereas, the program converted 

into machine language by the assembler is called the 

Object program or Object code. 

Like machine language, assembly language is also 

machine-dependent and programming in this language 

is quite time-consuming. Thus, it is also regarded as a Low-level Language (LLL). 

HIGH-LEVEL LANGUAGE (THIRD GENERATION) 

The restrictions in the usage of machine and assembly languages prompted people to 

develop a language with the followingfeatures: 

> Simple and userfriendly language 

> Languagethatismachine-independent 

Owing to the above mentioned features, it became 

easy to learn and use the computer languages. A 

large number of people started writing computer 

programs using these languages. It is also known as 

High-level Language (HLL). High-level language is 

quite similar to the English language. Basic, C, C++, 

Java, etc., are some of the very popular examples of 

high-level languages. 

High-level language programs need to be translated into machine language by using the 

Translator programs. There are two types of translator programs, which are as follows: 

INTERPRETER 

This translator program is used to convert a high-level language program into machine 

language. An interpreter translates a program written in high-level language into a 

low-level language program line by line. It executes the instructions and then repeats the 

procedure for the remaining instructions. If any errors are found, they are to be removed 

immediately. As the converted form is not stored anywhere, so it has to be generated at 

the time of the execution of a program. The interpreter programs are preferred for 

beginners and slow in their execution speed. 

Imagine that the French President visits India on an official tour. So, in order to 

understand each other, both the French President and the Indian Prime Minister 

would require an interpreter to translate the French language into the English 
Example  language and vice versa. Similarly, in computers, interpreters are required to 

convert high-level language programs to machine-level language programs. 

Lady Ada Lovelace, a 
mathematician, is regarded 

as the first computer 
programmer. She was the 

daughter of famous English 
poet, Lord Byron. 

The term Software was first 

used by John W. Tukey in 

1957. 

Let's Know More 

If there are several pieces 
of source code in a 

program, they can be 
linked together into one 

program with the use of a 
program called Linker. 
The linker runs on the 

machine code generated 
by the compiler to 

generate a final program. 
This final program is what 

the user runs and the 
original source code is not 

needed. 

Let's Know More 

Syntax are the rules 

governing the formation of 

statements in a 

programming language. 

Learning 
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COMPILER 

Compiler isa translator program, which is used to convert a high-level language program 

into machine language. It translates the whole program at once, i.e., it generates the 

object code forthe program along with the list of errors. The execution speed of a compiler 

isfasteras compared to an interpreter. 

E' FOURTH GENERATION LANGUAGE (4GL) 

Fourth generation languages are more similar to human 

languages than their previous versions. They are a 

combination of many languages with the following 

features: 

> Highly user-friendly and independent of any 
Figure 1.4: 

Fourth Generation Computer 

Very high speed of execution. Designed to reduce the level of programming efforts. 

Minimum efforts from the userto obtain any information. 

Designed to reduce the overall time it takes to develop software and the cost of 

software development. In 4GL, the user has to specify only the required output they 

want, while the computer determines the sequence of instructions that will 

accomplish those results. 

Let's Know More 

FORTRAN is one of the 
earliest computer 

languages. It was designed 
for scientists and 

engineers. 
COBOL was designed for 

business users. 

Let's  Know More 

I 

Spacewar was the first 
interactive computer 

game. 

Let's Know More 

In software development, 
beta release refers to a 

product or technology, that 
is still in development, but 

is released only for testing 
and evaluation purpose. 

operating system. 

LANGUAGE FEATU R ES 

 

MACHINE 

ASSEMBLY 

HIGH-LEVEL 

4GL 

> Uses binary codes to depict operators and data 
)' Machine-dependent 
> The only language directly understood by a computer 

> Uses mnemonic codes or symbols instead of binary numbers 

) Machine-dependent 
) Has to be converted into machine language by translator programs (Assemblers) 

> Uses English words and Mathematical operators 
> Machine-independent 
> Has to be converted into machine language bytranslator programs (Interpreters and Compilers) 

> Machine-independent; minimal user skills required to obtain results 
> Application development tool 

) Programming is the process of writing specific instructions in a computer language. 

> Machine language is the only language that a computer understands. 

> Syntax are the rules governing the formation of statements in a programming language. 

> An interpretertranslates line byline, whereas a compilertranslates the whole program at once. 

> An Assembler is a program used to convert the mnemonic codes into their machine language equivalents. 
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SECTION - A 

A. Fill in the blanks. 

1. A isa set of instructions, which tells the computer what to do. 

2. The development of computer languages can be classified into categories. 

3. The language consists of binary numbers, i.e., 0 and 1. 

4. convert the assembly language program into machine language. 

5. language uses simple English words and Mathematical operators. 

6. language uses mnemonic codes or symbols. 

7. are the rules governing the formation of statements in a programming language. 

8. lnbinarylanguage,omeans andi means state. 

 

Machine 

High Level 

Syntax 

.On 

Assembly 

-'Off 

Assemblers Four .  Program 
HINTS 

B. State True or False. 

1. Machine language is the only language that a computer understands. 

2. Assembly language is regarded as the first generation language. 

3. Each programming language has its own specific rules. 

4. ACompilerconverts a high level language program into machine language, line byline. 

5. High-level language program has to be converted into machine language by translator programs. 

6. FORTRAN language was designed for business users. 

7. Programming is the process of writing specific instructions in a computer language. 

8. Machine language uses mnemonic codes. 

C. Application-based questions. 

1. Kapil's aunt was a computer programmer during the third generation of computer language. Which type of 

language did she use backthen? 

2. Sumit is trying his hand at Java programming, but he does not know which type of language it is. Help him 

understand the type of language Java is. 
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SECTION - B 

A. Multiple-choice questions. 

1. A program written in the assembly language is called  

a. Assembler b. Source Program c Object Program 

2. An converts a high-level language program into machine language, line byline. 

a. Assembler b. Compiler c. Interpreter 

3. The program converted into machine language by the translator is called  

a. Source Program b. Object Program 

4. The term software was first used by  

a. John McCarthy b. John W. Tukey 

B. Answer the following questions. 

1. What do you mean by Machine language? 

c. Assembler 

c.John von Neumann 

2. How is Assembly language different from Machine language? 

3. What are the features of a high-level language? 

4. Differentiate between an interpreter and a compiler. 

5. List any three characteristics of fourth-generation languages. 



Perfection Through Practice LAB SESSION 

> Open Word 2016. Set Page Margins 1.25" from all slides, Line spacingto Double. Type the given text. 

CHARACTER 

Character is the sum total of a person's values, beliefs, and personality. It is reflected in our behaviour 
and actions. It needs to be preserved more than the richest jewel in the world. To be a winner, you need 

to develop the right character. - 

One's character is a combination of integrity, selflessness, understanding, courage, loyalty, and respect. 

> Apply Heading 1 style to the Title-CHARACTER. Set the font colourto red. 

> Select the paragraphs and apply border to them. Make change in the line style, colour, and width. 

> Set the text font size to 14. Apply WordArt style on the first word 'Character'. Insert an online picture and save 

the file. Observe the effects. 

Conduct a group discussion on the topic: Development of Computer Languages. 

The term Artificial Intelligence (Al) has become a buzzword in the field of computer science. 

Search more about Al with the help of the internet, newspaper, and computer magazines. Make a 

PowerPoint presentation on the topic: Development of Artificial Intelligence. 

Looking For More 

To know briefly about the generation of computer languages, visit the website: 

http://www.slideshare.net/hashgeneration/cornputer-Ianguagesppt  

GROUP DISCUSSION 

 

For Concept Clarity 

   

PROJECT WORK Using Creativity 
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Figure 2.1:  Accessing Tablet Mode 

Figure 2.2: Tablet Mode 

MORE PERSONAL 

You can enjoy Windows 10 like a personal digital assistant. It is the 

best Windows as yet for gaming and providing features that 

enable your device and phone to remain in synchronisation. 

CONTINUUM 

MORE ON WINDOWS 

LEARNING IN THIS CHAPTER 

     

     

t  New features of Windows 10 

r  Creating a new Desktop 

     

Utilities of Windows 10 

r  Working with the Control Panel 

       

       

Windows 10 is the latest and most secured version of Windows, introduced by Microsoft with advanced and much 

improved features. It is easy-to-use and provides user-friendly environment. You get more security features and 

ongoing updates in Windows 10, to help safeguard against current and future threats. Due to its amazing features, it 

is gaining popularity, day by day. In the previous class, you learnt about some of its unique features like, Cortana-the 

Search tool, Snap assist, the Windows store a bundle of Universal apps, etc. In this chapter, you will be introduced 

with some more innovative tools that help to get things done fast. 

) NEW FEATURES OF WINDOWS 10 

Windows 10 is loaded with multi-tasking tools: A custom start menu, live tiles, snap assist, task view, and virtual 

desktops to keep you organised, focused, and readyforanything. Afew distinctivefeatures are as follows: 

The new feature Continuum in Windows 10 helps the operating 

system to work better with devices that support both mouse and 

keyboard, and touch input. For convertible devices, there are two 

modes: Tablet and desktop. When you wish to use Tablet mode: 

> Click on the Notification icon present on the Notification 

area ofthetaskbar. 

) This will open the 'Action Center Pane' on the right side of the 

desktop. 

) Click on the Tablet Mode button  E  placed at the bottom of 

the Action Center Pane. 

In Tablet mode, the Start menu opens in full screen alongwith the 

currently active window, if any. Apart from that, Tablet Mode maximises all the apps, removes your taskbar icons, 

and leaves only essential notification tray items. The taskbar in 'Tablet Mode' displays only the Start button, back 

arrow, Search icon, and the Task View button. Windows 10 automatically changes to this mode, if it detects that 

there is no keyboard attached. 

Learning 
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Windows 10 
Anniversary Editon 

The 'All apps' option has 

been omitted in the 

Windows 10 Anniversary 

Edition. Now, you can 

look for various 

applications directly by 

clicking the Start button. 

TASK VIEW 

Task View is another interesting feature of Windows 10 that enables you to organise the 

applications running on your computer. You can create multiple desktops and view all of 

them together by clicking on the Task View button  10  located on the taskbar. When all 

the desktops are in view, you can also drag-and-drop an app from one desktop to 

another. 

Figure 2.3: Task View Pane 

SEARCHING MADE EASIER 

Windows 10 has the most enhanced and 

powerful search tool 'Cortana', which answers all 

the questions that you ask, either in text or 

verbally but, for that you need a microphone to 

talk. Here are certain things that Cortana does for 

you. it can play music, games, set alarms and 

reminders, take notes, send emails, create and 

manage lists, and find files, places, and 

information, open any app on your system, and 

browse the web to respond to your query. 

To turn Cortana on:
Figure 2.4:  Activating Cortana 

> Click on the Search Box on the taskbar, followed by another click on the Gear 

icon ' on the left side of the displayed menu. A Settings menu will appear in the right 

pane. 

>' Turn Cortana On by moving the slider to the right in the Settings menu. Cortana 

will start gathering information about you. 

> Once activated, it becomes visible on the taskbar as can be seen in the as shown in 

Figure 2.5. 

> You can also activate Cortana by giving a voice command 'Hey Cortana', if you have a 

microphone attached to your computer. 

U. 

Figure 2.5: Cortana Activated 

Quick  View 

To create a new blank 

desktop, ress 

Windows Key + Ctrl + D 

hortcut key combination. 

Let's Know More 

cortana can also be 

activated by clicking on the 

search box followed by a 

click on the small 

Cortana circle 0 

displayed on the lower-left 

side of the menu. 

Quick View 

In Task View pane, you can 

close the current desktop 

by pressing 

Windows Key+ Ctrl + 

F4 shortcut key 

combination. 

Let's Know More 

Sticky Notes is a powerful 

reminder tool that helps 

you in making and 

displaying notes on your 

desktop screen. 

You can find it in the Start 

menu. To delete the note, 

click on the Delete Note 

button . or use the 

keyboard shortcut, 

Ctrl + D. 
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Where to next' 

My 

Figure 2.6: Microsoft Edge Browser 

EDGE
C) 

The Windows 10 browser, 'Edge', enables you to conduct a safe and quick 

search on the internet. It also provides a reading mode that opens a web 

page, displaying only the text and hiding all other distractions, such as 

graphics, images, etc. You can also save your articles and annotate the 

web page directly through Edge. 

ACTION CENTER 

The New Notification Center of Windows 10, displays alerts for your device and all 

the apps in a slide-out pane on the right side of the desktop. The upper part of the 

pane displays Tips and App notifications, whereas, the lower part displays a series 

of Quick Action buttons. These buttons enable you to perform actions, such as 

adjusting the screen brightness, turning bluetooth on or off, and switching to 

Tablet mode. Along with the notifications, security tips, alarms, reminders, etc. are 

also displayed in the Action Center. 

Figure  2.7:  Action Center 

 

Quick Actions are a set of tiles that gives access to frequently-used settings and tasks. 

 

Hello 

WINDOWS HELLO 

Windows Hello is Microsoft's new built-in biometric security system for Windows 10. It allows you 

to sign in to your system using data, like fingerprint, face, or iris recognition. Biometric logins are 

secure, fast, and easy to create. Windows Hello requires appropriate hardware devices to be 

connected to the system for its proper working. 

Figure 2.8: 
Windows Hello 

 

P' CREATING A NEW DESKTOP 

In Windows 10, you can create multiple desktops for organising different sets of applications. To create a new 

desktop, follow the given steps: 

Click on the Task View button 10cated on the taskbar. The Task View Pane opens and displays the preview of 

allthe open windows. 

) Click on the New desktop button placed at the bottom-right corner of the Task View Pane. A new desktop 

thumbnail named 'Desktop 2' appears. 

) Click on the thumbnail to view the newly created desktop. It is a replica of Desktop 1 but doesn't display the 

applications opened in Desktop 1. You can open the apps that you want to use on this desktop. You can group 

Learning 
Computers with  IPS 

ACTION CFNTER 

HL.V 

t.bit e.vt 'c 

yr..- .oca 



Figure 2.9: Creating a New Desktop 
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the desktop windows by opening similar kind of apps in one desktop. 

) Click on the Task View button again to switch between desktops. 

MOVING APPS BETWEEN DESKTOPS 

Follow the given steps to move an app from one desktop to another. 

Open the Task View pane by clicking on the Task View button . Place the mouse pointer over the desktop 

thumbnail. 

):> It will display the thumbnails of all the opened 

apps. Right-click on the app that is to be moved 

and select the Move to option. 

This will display the Desktop list that you have 

created. Choose the desktop to which you want 

to move the app. 

You can also drag and drop an application 
window from one desktop to another. 

CLOSING A DESKTOP 

To close a desktop, open the Task View pane and place the mouse pointer on the desktop you want to close. Click on 

the Close button present in the upper-right corner of the desktop thumbnail to close the desktop. 

UTILITIES OF WINDOWS 10 

Windows 10 provides many utility programs for day-to-day applications and entertainment. For example, 

Windows Media Player, Disk Cleanup, Steps Recorder, Character Map, Notepad, Shape Collector, Math Input 

Panel, etc. 

 

— 0 X 

WINDOWS MEDIA PLAYER 

Windows media player runs and organises the 

digital media files (both audio and video) available in 

the computer memory. You can listen to the radio 

stations from all over the world if the internet 

connection is available. This software allows you to 

play, copy and create CDs/DVDs, and copy music and 

video to portable devices. 

 

RIP(Copy) CD to Your Computer
Figure 2.10: Windows Media Player 

You can copy songs from your favourite music CDs/DVDs onto your computers with Windows Media Player. When 

you rip music, you are actually copying songs from a CD to computer. After the songs have been copied on to your 

computer, you can use Windows Media Player to play and organise the songs, create play lists, and copy music to a 

portable device. 
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Click on the Start button and then choose Windows Media Player from the list. 

Insert an audio CD/DVD in the CD/DVD drive. You will see a list of songs stored on the CD/DVD in the Windows 

Media Player. 

Uncheck the check box next to any song that you do not want to rip. You can use the check box at the top of the 

list eitherto select or clear check boxes at once. 

When you are done with the selection process, c 

—. c___ On-., 
click on the Rip CD button. 

The ripping process will start and you can see the 

Rip status of individual songs. To stop the ripping 

process at any point, click on the Stop rip button. 

> Click on the Rip settings button if you want to 

change the format, audio quality of ripped music 

files, or you can keep the default Windows Media 

format settings. 
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> ThesongsarerippedtotheMusicfold . .
.

Figure 2.11: Ripping anAudio CD 
ercontained in This PC folder. 

> After the songs have been ripped, go to the Music Folder to play them. 

You can also burn a CD/DVD using software, like 

Nero, Express Burn, etc. 

Copying Data to CD/DVD (Burning a CD/DVD) 

Saving important information on a CD/DVD is as easy as saving on hard disk. 

You can create your own CD/DVD by selecting a folder of software or media 

files and dragging it to CD/DVD icon in This PC folder. 

> Insert a blank CD/DVD in the CD/DVD drive of your computer. 

> The Burn a Disc dialog box appears. Mention the CD/DVD name in Disc 

title: text box, select the option With a CD/DVD Player and click on Next. 

> An empty disk folder opens. Drag the files that you want to burn into 

this folder. 

Bum a Disc 

How do you want to use this disc? 

Disc title _______ 

0 LIke a USB flash drive 
Save. edit, and delete files on the disc anytime. 'The disc will 
wotk on consputers runrong Windows XP or late,. (tive File 
System) 

® W)th a CDIDVD player 
Burn files in group-s and indrvrduil files cant be edited or 
rensoued after bum:rsg. The disc will also work on most 
computers. (Mastered) 

Which one should I choose? 

Nt Cancel 

Figure 2.12: Burn a Disc Dialog Box 

> Click on the Finish burningoption underthe Manage tab. 

) Again, a Burn to disc dialog box appears. Click on the Next 

button. 

> Windows Media Player will open. Click on the Start burn button 

placed underthe Burn tab. 

Thesongswillgetburnedtothedisc. 

Figure 2.13: Finish burning Option 
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Figure 2.14: Selecting Open File Option 

> Select the Media tab and click on Open 

File. The Select one or more files to open 

dialog box appears. Select the audio/video 

file(s) that you want to play and click on 

the Open button. 
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Figure 2.17: Adding Files to Playlist 

Know the Fact 

MPEG-H is a group of 
standards developed by 

the Moving Picture 
Experts Group (MPEG) for 

a digital container 

standard, audio and video 
compression standards. 

Let's Know More 

Steps Recorder is a tool 
that helps in 

troubleshooting a problem 

occurring on Windows 10. 
It creates a file that 

contains screenshot of 

every action that is 

performed on the system, 
description of the action in 

plain English, and the exact 

date and time of action 
that helps in solving 

the problem. 

Let's Know More 

VLC media player provides 
a very attractive feature 
that enables you to take 
screenshots of a video 

while playing it. To capture 
a snapshot go to 

'0 

Video > Snapshot. 

PLAYING A MOVIE USING VLC MEDIA PLAYER 

VLC Media Player is an easy-to-use application. 

It is used to play almost all types of audio and 

video files. To play music using VLC, follow the 

given steps: 

> Click on Start> scroll down to VideoLAN> 

VLC media player. The VLC media player 

window appears. It displays various 

commands that control VLC. 
X  Quit Ctrl+Q 

Figure 2.15: Selecting a File 

> With VLC player, you can also create a 

playlist that is basically a list of all your 

favourite songs or videos. To do so, 

click on Tools > Playlist. The Playlist 

dialog box appears. Click on the Add to 

Playlist button 4 followed by Add file 

option. The Open dialog box appears. 

Browse the files and click on the 

Enqueue option. In this way, you can add the desired files to the playlist. 

> After arranging the list, close the 

Playlist dialog box and click on the 

Play button. You can also rearrange 

or repeat the songs in the playlist 

by clicking on the appropriate 

options. 

)  Simply right-click on the file and 

select Open With option and then 

selecting VLC media player from 

the sub-list. 
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DISK CLEANUP 

If you want to remove some unnecessaryfilesfrom your hard disk to free up the disk space and help your computer 

run faster, you can use Disk Cleanup feature. It empties the Recycle bin, removes the temporary internet files, 

downloaded program files, offline webpages, and other items that are not being used for a long time. 

USING DISK CLEANUP 

> Click on Start> scroll down to Windows Administrative tools> Disk Cleanup. Or 

>- Type Disk cleanup in the Search box and press Enter. 

) The Disk Cleanup: Drive Selection dialog box will open, asking you to select the 

drive. 

) Now, click on the drop-down arrow and selectthe drive that you want to cleanup. 

Click OK. 

)° This function will search and display the unnecessary files, which can be safely 

deleted. 

) Select the file(s) that you want to remove, and click OK. 

WORKING WITH THE CONTROL PANEL 

Control Panel is a system folder, using which we can make changes in the appearance and current settings of the 

Windows. These may include: 

) Appearance and Persona lisation of the desktop 

)' Hardware and Software Setup and Configuration 

> System and Security 

> Networking and the internet 

) UserAccounts and Family Safety 

> Setting Clock, Language, and Region 
a  Cceaec,f 

These settings control nearly everything regarding  4- -P -t •  Co.*cfP.nd 

Adjust your computers settings 

system and Security 
Review your computers status 

Save backup copies of your f dcc with 
Ide History 

Bactup and Restore (W,ndow, 1) 

find and lv. problems 

Network and Internet 
View network stitch and last, 

Choose homegroup and sharing 
opt,orrs 

Hardware and Sound 
View devices sod printers 

Add a devwe 

Programs 
finrerstatl a ptvgranr 

Windows appearance, internal settings, and 

personalisation. They allow you to customise 

Windows, the way you want. 

You can open Control Panel in the following way: 

) Click on the Start > scroll down to Windows 

System. Select Control Panel from the 

displayed sub-list. 

Or 

Type 'Control Panel' in the Search box and press 

Enter. Figure 2.18: VIew of Control Panel 
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CHANGING DATE AND TIME Dat.ndTmr 

A4dt., Ods it 

To change a computer's date and time: 

> Click on the Date and Time option in Control Panel. The Date and Time 

dialog box will appear. 

) BydefaulttheDateandTimetabis selected. 

To Change  Date 

> Click on the Change date and time button. The Date and Time Settings 

dialog box will appear. 

) Select the current day in the displayed calendar. You can change the 

month using the forward/backward arrow buttons present on the 

calendar. 

To Change Time 

> To change the hour, select the hour in the text box located below the OateundTmeSettns 

clock. Sthedateandtaie 

Dice 

Different styles of writing characters/text in a specific size are known as 

Fonts. Some of the popular fonts are Anal, Calibri, Verdana, Times New 

Roman, etc. Font settings are used to change the display of text on the 

FONTS 

) Click on the spin arrows to increase or decrease the hours as desired. 

Similarly, you can change the minutes and seconds. Click OK. The Date 

and Time settings of the system will change accordingly. 

Oil screen, as well as on paper, while printing. You can use Control Panel to view Cancel 

fonts, add new fonts, or delete existing fonts. Figure  2.20:  Date and Time Settings 

Let us see an example here: 

> Click on the Fonts option in Control Panel. The Fonts window appears. 

>- To view the sample of a font, double-click on any given font. 

To add new font(s) to the font list, follow the given procedure: 

> Open This PC folder by double-clicking its icon on the 

desktop. 

> Select the appropriate drive and then open the folder that 

contains the new fonts. 

)° Select the font that you want to add and drag it to the 

Fonts window. The new font will be added in the list of 

existing fonts. You can also Copy and Paste the desired 

font in the Fonts window. 
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Figure 2.24: Mouse Properties Dialog Box 

OK 

You can also delete the existing font. To do so: 

> Select the font that you wantto delete. 

> Click on the Delete button present above the font 

thumbnails. 

CHANGING THE MOUSE SETTINGS 

You can customise the mouse settings in various ways, 

such as changing the appearance of mouse pointer, 

changing the functions of the mouse buttons, or altering 

the scroll speed of the mouse wheel. 

> Select the Mouse option in the Control Panel. The 

Mouse Properties dialog box will appear. 

> The Buttons tab is selected by default. It provides 

options to change the settings of mouse buttons like 

swapping the functionality of the left and right 

button, increasing or decreasing the double click 

speed, etc. 

> Under Button configuration section, select the 

checkbox to make use of the right button for primary 

functions, like selecting and dragging. 

> To change the double-click speed of your mouse, drag 

the slider towards left to make it slow and towards 

right to make it fast under the Double-click speed 

section. To test the speed, double-click the folder 

given on the right side. If the folder does not open or 

close, try using a slower setting. 
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Figure 2.22: Inserting/Deleting Font in Fonts Window 
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Figure 2.23: Selecting Mouse Option 

Mail (Microsoft Outlook 

2016) 

Network and Sharing 

center 

Phone and Modem 

Programs and Features 

x > To change the appearance of your mouse pointer, click on the 

Pointers tab. Here you can change the size, colour, and shape of your 

mouse pointers. 

) To change the pointer image, click the Scheme drop-down list and 

choose any mouse pointer scheme. You can also change pointer 

images for particular functions like Normal Select, Busy, etc. To do 

so, click the pointer function in the Customize section and then click 

on the Browse button. Double-click on anyfile name and observe the 

change. 

> Click on the Apply button to incorporate the change or click on Use 

Default button to return to the default setting. 

> You can also adjust the speed of your mouse pointer by clicking on 

the Pointer Options tab and dragging the speed slider present in the 

Motion section. 
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> Drag the sliderfrom slow to fast under the Motion section. 

> Click on theApply button and then dickOK. 

REPLACING DOUBLE CLICK WITH SINGLE CLICK 
File Elocer Options x 

Windows has a feature to replace double-click setting of a mouse with 

single-click to open any file/program. Follow these simple steps and 

forget the practice of double-clicking the mouse forever. 

) Click on the File Explorer Options in the Control panel. The File 

Explorer Options dialog box appears as shown in Figure 2.25. Turn on 

the Single-click to open an item option present under Click items as 

follows section. 

) From the Single-click sub-options, prefer to turn on 'Underline icon 

titles only when I point at them' option. 

) Click on Apply and then click OK. 

Enjoy the experience of working with single-click now. Remember, to 

select any item from a list, you just have to place the mouse-pointer there. 

The item would be highlighted. To open any program/document, just click 

on it. 

POWER SAVING MODES 

Sleep Mode 

Sleep is a power saving state wherein a computer Posmn Options 

does not turn off completely. In this state, monitor 

and hard disk are turned off, all the open documents 

and applications are put in RAM, and system draws a 

small amount of power. It allows a computer to 

quickly resume full-power operation when you start 

working again. Sleep mode is useful if you want to 

stop working for short time. 

Follow these steps to put your computer in Sleep 

mode: 
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Figure 2.25: File Explorer Options 

Dialog Box 
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Figure 2.26: Power Options Properties 
> Click on the Power Options in Control Panel. 

> Click on the Change plan settings option next to the Power saver radio button. 

> Choose the duration of two minutes from the drop-down list of the Put the computer to sleep option. Click on 

the Save Changes button. 

Hibernate Mode 

Hibernation is a state in which a computer shuts down to save power but it first saves all the open documents and 

running applications in the memory on hard disk. When you restart the computer, your desktop is restored exactly 

as you left it. 
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Enabling Hibernation 

Right-click on the Start button or Press the Windows key + X. A 'Power User' 

menu appears. Select Command Prompt (Admin) and click on the Yes button in the 

User Account Control dialog box. 

> On the command prompt, type the command: powercfg/h on and press Enter key. 

> Now, type exit and then press Enter to close this window. 

Now, open Control Panel by clicking on the Start > scroll down to Windows System> 

Control Panel. 

Click on Power Options. A Power Options dialog box appears. 

- Mnut,irjtr Cnwsaed Prompt 

Figure 2.28:  Enabling Hibernate option 

in Command Prompt 

Power User Windows 

0 X Click on the Choose what the power 

buttons do option present on the left 

side and then click on Change settings 

that are currently unavailable option. 

Now, under Shutdown settings, click on the Hibernate 

checkbox and then click on the Save Changes tab. 

Figure 2.29: Changing the Power button setting 
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Now, you will have Hibernate 

option as a part of the Power 

button in the Start menu. 

-0 

Figure 2.30: Enabling Hibernate Option Figure 2.31: The Hibernate option 

     

Click on the Start button and then click on the Power button. Select the desired option from the displayed list, 

ii such as Restart, Sleep, Hibernate, Shutdown, etc., to putthe computer into the selected mode. 
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JRECAP 
> Windows lOis the latest and most secured version of Windows. It was introduced by Microsoft with advanced and 

much improved features. 

> Te new feature Continuum in Windows 10 helps the operating system work better with devices that suppo both 

mouse and keyboard and touch input. 

) The Windows 10 browser, Edge, enables you to conduct a safe and quick search on the internet. 

> Utilities are additional programs of Windows. 

> Microsoft Windows Media Player runs and organises digital media files. 

> Ripping means copying data from a CD to computer. 

> Disk Cleanup empties the Recycle bin, removes the temporary internet files, downloades program files, offline 

webpages, and other items that are not being used for a long time. 

                         

            

BRAIN 

            

                        

                        

                         

                         

                         

                         

                         

                          

SECTION  - A 

A. Fill in the blanks. 

1. Microsoft Windows Media Player is used to run and digital media files on a computer. 

2. Ripping refers to  songs from a CD/DVD to a computer. 

3. Different styles of writing characters/text in a specific size are known as  

4. is used to remove the unnecessary files from a computer hard disk. 

5. allows you to change Windows 10 into a touch-friendly interface called 'Tablet Mode'. 

HINTS Disk Cleanup Continuum Copying Fonts Organize 

B. State True or False. 

1. You can drag and drop an app from one desktop to another in the Task View pane. 

2. Windows 10 automatically changes to Tablet mode if it detects that there is no keyboard attached. 

3. The reading mode of Microsoft Edge opens a web page with only the pictures displayed. 

4. Windows Hello enables you to perform quick actions such as adjusting the screen brightness. 

5. Burning a CD and ripping a CD are two entirely different operations. 

Learning 
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C. Application-based questions. 

1. Sia wantsto burn herfavorite songs on a CD/DVD. Which utility program should she use? 

2. Kriti wants to make her system more secure through biometric login. Which feature of Windows 10 can help 

herso? 

SECTION  -  B 

A. Multiple-choice questions. 

1. You can customise the mouse settings by selecting the option in the Control Panel. 

a. File Explorer b. Mouse c. Devices and Printers 

2. The displays alerts for your device and all the apps in a slide-out pane on the right side 

of the desktop. 

a.Tablet Mode b. Action Center c. Task View 

3. is a new feature in Windows 10, which enables you to organise the applications 

running on your computer. 

a. Task View b. Action Center c. Cortana 

B. Answer the following questions. 

1. What do you understand by Windows Media Player? 

2. Differentiate between ripping and burningfeatures. 

3. What is the utility of Windows Hello? 

4. How will you create a new desktop? 

5. How is Disk Cleanup useful? 
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PROJECT WORK Using Creativity 

Collect information about any five Utilities of Windows 10 and create a presentation 

by showing your creativity. 

MY ACTIVITY Learning While Playing 

A. COPY AN AUDIO CD/DVD TO YOUR COMPUTER 

> Select Start> scroll down to Windows Media Player. 

) nsert an audio CD/DVD into the CD/DVD drive. 

) In Windows Media Player, you will see a list of songs present on your CD. 

> Clearthe check boxes next to the song that you do not want to copy. 

> Afterthis,clickontheRipCD/DVDbutton. 

> Click on the Rip Settings button to make changes in the audio quality, format, etc. 

B. CREATING A NEW DESKTOP 

) Click on the Task View button located on the taskbar. 

In the Task View pane, click on the New desktop button located on the bottom-right corner. A new desktop 

icon named Desktop 2 will appear on the bottom. 

) Click on the Desktop 2 icon to open it. Open the applications Word 2016 and PowerPoint 2016 in Desktop 2. 

> Move the PowerPoint window from Desktop 2to Desktop 1. 

UP DISCUSSION 

Divide the students in two groups and conduct a group discussion on the topic: 

Impactof Windows lOontheWindows Ecosystem 

For Concept Clarity 

To know more about the features of Windows 10, visit the following sites: 

> https://www.rnicrosoft.com/en-in/windows/features  

ttps://support.microsoft.com/en-us/products/windows?os=windows-1  0 

ONLINE LINKS Looking For More 
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ENHANCING A PRESENTATION 

• Using Action Buttons 

• Importing data from Word 

*  Sharing presentation online 

LEARNING IN THIS CHAPTER 
Applying Animation effects 

Adding Transition effects 

Inserting sound and video clips 

PowerPoint 2016 provides various tools and features to enhance the appearance of a presentation. These special 

effects assist you in making your presentation attractive, effective, engaging, and professional. The use of special 

effects creates a greater impact on the audience. 

APPLYING ANIMATION EFFECTS 

The ability to move objects, like text, graphics, charts, logos, etc. on the slide is called 

Animation. 

  

-.,t..M.. 

   

Animation is quite beneficial when you wish to focus on important points. It also 

controls the sequence of the flow of information and helps in making information 

more impressive. Besides giving visual effects to your presentation, you can also 

sizzle up your slide objects—the text, pictures, shapes, tables, SmartArt graphics, etc. 

by applying sound effects. 

Follow the given steps to apply animation effects to the slide objects: 

Open any presentation. Select the object that you want to animate. 

Click on the Animations tab and select the Add Animation button present in the 

Advanced Animation group. A drop-down menu will appear with four different 
+ * 
Wç. 

categories of animation effects, which are as follows: 

an object enters into a slide during the slide show. These effects make an object 

1. ENTRANCE: As the name suggests, these effects decide the manner in which
0 

fade gradually into focus, fly onto the slide from an edge, bounce into view and 

soon. 

2. EMPHASIS: These effects determine how the objects on the slide draw 

attention to themselves during the slide show. These effects make an object Figure 31:  Animation 

shrink or grow in size, change colour, or spin on its center, etc. Task Pane 

3. EXIT: These effects control the manner in which the object exits from the slide during the slide show. Some of 

these effects are: Disappear, Fade, Fly out, Float out, Split, etc. 

4. MOTION PATHS:  You can use these effects to make an object move up or down, left or right, or in a star or 

circular pattern, etc. These effects enable objects to move from one position to another on a slide and on the 

specified path during the slide show. 

To view more animation effects of each category, select the desired option available at the bottom of the Add 
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A slide show enforces the 
ideas, comments, 

solutions, or suggestions 

present in a slide. 

To remove an item from 
the Animation Pane list, 

select it, click on the drop-

down arrow next to it, and 
select Remove. 

Let's Know More 

In the Animation Pane 
>  A number (0, 1, 2) 

indicates the animation 

order. 
) Star symbolI indicates 

the type of effect used 

for text and objects in a 

slide. 

Animation drop-down menu. You can also click the More drop-down arrow in the 

Animations group to select an object's animation effect. 

You can add more than one animation effects to the same object or can apply the same 

animation effect to multiple objects by using the options in Animation group. 

> Choose the desired animation effect from the displayed menu. After applying an 

animation effect to an object or a text, you will notice that a numbered tag appears 

adjacent to the object on a slide pane. 

You can also specify when an animation should be played by clicking on the drop 

down button of the Start box in the Timing group and selecting any one of the 

displayed options: 

> On Click -To start the animation after a mouse click 

) With Previous - To start the animation at the same time as the previous 

animation effect in the list 

)' After Previous - To start the animation effect immediately after the previous 

effect in the listfinishes 

)' To specify or set the timing of the effects, use Duration box available in the Timing 

group. It helps you to change and control the speed of animation effect. 

Likewise, you can set the delay time before the animation begins by using the Delay 

box. 

You can also use Reorder Animation buttons to change the order in which the 

anmation effects appear. 

Click on the Preview button in the Preview group to view the effects applied on the 

current slide. 

ADDING TRANSITION EFFECTS 

Transition effects appear when one slide changes to other during Slide Show view. You 

can apply transition effects to a single slide as well as to all the slides. Follow these steps 

to add transition effects: 

Select the slide on which you wantto apply a transition. Click on the Transitions tab. 

Transition to This Slide group appears on the Ribbon displaying multiple transition 

effects. 

Click on the More drop-down arrow to display all the transition effects. Select any 

transition effect from the displayed choices. The current slide will display a preview of 

the selected effect. 

Select the Effect Options in the Transitions to This Slide group to choose any effect 

from the displayed list. For some transitions like Curtains, Prestige, this option 

remains deactivated. 

Let's Know More 

The Effect Options button 
in the Animation group 
gives different direction 

options to each transition. 
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Fiqure 3.2: Adding Transition 

Click on the drop-down arrow of the Sound option in the Timing group and select any sound effect of your 

choice. Click on the Preview button and observe its effect. 

> Specify the transition timing by entering the number of seconds or minutes in the Duration box in the Timing 

group. Select the On Mouse Click checkbox if you want to advance the slide by clicking the mouse. 

> Click on the After checkbox if you want the slide to advance automatically to the next one after a certain period 

of time. You can specify the slide advance timings in the spin box. 

) Click on the Apply To All button to apply the selected effects on all the slides, otherwise, those effects will be 

applied on the current slide only. 

) Open the Slide Show tab, and click on the From Beginning button. The presentation will startfrom the beginning 

along with all the applied transition effects. 

INSERTING SOUND CLIPS 

Music or sound effects can add a completely new dimension to any presentation. You can add sound in the form of 

background music or special effects to give importance to specific content. 

Sound files can be added from the files stored on your computer or on a CD/DVD. You can even record your own 

narration or comment and then edit the audio to customise it for your presentation. 

ADDING SOUND FROM A FILE 

) Selecttheslidetoaddsound. 

fiecord Audio.. 

x 
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Figure 3.3: Insert Audio Dialog Box 

30 Computers with  

> Select the Insert tab and click on the Audio drop-down arrow 

in the Media group. C oose the Audio on My PC option from 

the menu. 

> The Insert Audio dialog box will appear. 

> Locate the audio folder on your computer and select the 

required file. Click on the Insert button. 

> The audio file will be added to the slide indicated by a 



Audio Screen 
Recordin9 

4)) Audio on My EC... 

INSERTIN 
SOUND 

[Lets Know More 

The recorded sound files 

have the extension .WAV. 

Quick View 

To make a duplicate of the 

current slide, press Ctrl+D 

key combination. 

Figure 3.5: Slide Show Playing the 

Recorded Sound 
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Speaker icon on the slide. Two additional tabs namely, Format and Playback, Let's Know More 

appear under the Audio Tools tab on the Ribbon. 

> On the Playback tab, in the Audio Options group, select either Automatically or On 

Click option f rom the drop-down list of the Start f ield. 

> The Automatically option will start the sound automatically as soon as the slide 

appears in Slide Show view. Whereas, the On Click option will play the sound only 

when you click the left mouse button. 

> To play sound, click on the Speaker icon. The Play/Pause tab appears right below the 

speaker icon. 

i To continuously play a sound clip, select the Loop until Stopped checkbox in the 

Audio Options group on the Playback tab. 

RECORD AUDIO NARRATION 

To add your own audio to the slide, first you will have to record it. While recording your 

sound, it is essential to connect a microphone that is compatible with your computer. Let 

us do it practically. 

The Animation Painter 

option in the Advanced 

Animation group copies 

the animation from one 

object and applies it to 

an other. 

To get started: 

Select the object with 

the animation you like. 

> click on the Animation 

painter. 

> Select the target object 

on which the animation 

is to be applied. 

> You can also apply the 

animation effects to 

multiple objects by 

double-clicking on the 

Animation Painter. 

If you want to remove the 

animation effects, click on 

the object and select None 

option in the Animations 

group. 

) Selecttheslidetoinserttherecordedsound. 

> Click on the Audio drop-down arrow in the Media group 

on the Insert tab. 

) Choose the Record Audio option from the drop-down 

menu. 

Record Sound x 

-  Know the Fact 

When you insert any 

sound, a Speaker icon 

appears in the middle 

of the slide. You can resize 

this icon and move it to the 

other part of the slide. 

> The Record Sound dialog box appears. Type a 

name for the audio recording if you want. 

!ame: Recorded Sound 

Total sound length: 0 

Cancel 

Figure 3.4: Record Sound Dialog Box 

> Click on the Record button to start 

recording. When you have finished 

recording, click on the Stop button. 

You can use the Play button to listen to 

the recorded sound. 

) When you are done, click OK. The 

Audioclipicon appearsontheslide 

denoting that the audio file has been 

embedded in the slide. 



Video Audio Screen 
Recording 

Qniine Video... 

r Videoonh4yEC... 

Observe that, on selecting the Audio clip icon , the Audio Tools tab, which includes the Format and Playback 

tabs; appears on the ribbon. You can also see the audio playback controls displayed on the slide. 

INSERTING VIDEO CLIPS 

Video clips add liveliness to the presentation. PowerPoint allows you to insert a video onto a slide and play it during 

your presentation. This is a wonderful feature to make your presentation more engaging for the audience. 

Select the Insert tab. Click on the Video drop-down arrow in the Media group and 

select the Video on My PC option. 

The Insert Video dialog box appears on the screen. Locate and select the desired video 

file, then click on the Insert option. 

The Format and Playback tabs appear under the Video Tools tab on the ribbon. You 

can format the inserted video by clicking on the Format tab and selecting various 

formatting options from it. 

Click on the Play button present either below the Video clip or at the extreme left of the ribbon. The video will 

start playing. The timeline next to the Play button will begin to advance. Click anywhere on the timeline to jump 

to any part of the video. 

Figure 3.6: Inserting Video Clip 

USING ACTION BUTIONS 

> In PowerPoint 2016, you can also 

embed videos from websites, like 

www.youtube.com  into your 

presentation. 

> You can resize a video by clicking 

and dragging the corner sizing 

handles until the video is of the 

desired size. 

> To delete a video, select it and 

then press either the Backspace 

or Delete key. 

In PowerPoint, you have the facility to link to a web page, email address, file, slide in the same presentation or in a 

different presentation. This can be done by using Hyperlinks and Action buttons. 

Action buttons are built-in shapes, which you can add to a presentation and set a link to another slide, play a sound, 

or perform some other action. You can also assign actions to Clip Art, Pictures, or the text in SmartArt graphic. When 

one clicks or hovers the mouse pointer on the button, the selected action will occur. 

Open an existing presentation. Select the Insert tab and click on the Shapes command in the Illustrations group. 

Select the desired action button from the Action Buttons category, present at the bottom of the displayed list in 

Learning 
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Figure 3.7:  Selecting Action Buttons 

To print a slide with the 

default settings, click on 

the Print option in the 

File tab menu. 

Know the Fact 

 j 

r-- 
Let's Know More 

Action buttons should not 

be inserted on master 
slides. You can insert an 

action button on a slide, if 
required. 

? X 
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Figure 3.8:  Action Settings Dialog Box 
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the drop-down menu. 

> For example, click the Action Button: Go to End option. The mouse pointer will 

change into '+' shape. 

> Click and drag the mouse diagonally. As soon as the mouse button is released, the 

Action Settings dialog box will appear containing two tabs namely Mouse Click and 

Mouse Over. 

)' By default, Mouse Click tab is activated. The Mouse Click tab makes the action button 

perform its action only when it is clicked, whereas, the Mouse Over tab will make the 

action button perform its action when you move the mouse over it. 

Quick View 

The shortcut to open 

Microsoft PowerPoint is: 

> Windows keyD+ R key. 

) The Run box appears. 

Type in powerpnt and 

press the Enter key. 

Let's Know More 

A Hyperlink is a 

connection from one slide 

to another presentation or 

any other file or any 

website/web page. It can 

be applied on text or 

objects, such as pictures, 

shapes, etc. 

Let's Discuss 

Transition 
vs 

Animation 

> In the Action on click section of the Mouse 

Click tab, select Hyperlink to: radio button, 

then click the drop-down arrow and choose 

any option from the menu. For example, _______ 
Previous slide, First Slide, or Last Slide, etc. To 

link to a file created in another program click 

on Other File from the Hyperlinkto: list. 

> Select the Play sound checkbox if you want a 

sound to play when an action button is clicked. 

Choose any sound, either from the drop-down 

menu or select Other Sound option, to use a 

sound file present on your computer. Click OK. 

> Now, press F5 to view the slide show. Click on 

the Action Button duringthe slide show and observe the action. 
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Figure 3.11 Importing Data from Microsoft Word to Microsoft PowerPoint 
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IMPORTING DATA FROM WORD 

PowerPoint provides the facility to import data from other 

applications like Word, Excel, etc., and use it in the 

presentation. Importing data saves your time and efforts. 

Follow the given steps to import data from Word file: 

Click on the Start> scroll down to > Word 2016. 

Create a new document. Select the View tab, then click 

on the Outline button in the Views group. 

Type the text as shown in the Figure 3.9. Now click on 

Close Outline View button to return to the Print Layout 

View. 

 

TM0 

  

Figure 3.9:  Importing Data from Word 

Select "Types of Software" and apply Heading 1 from Styles group 

on the Home tab. 

> Select"MicrosoftWord"zndchooseHeading2. 

> Select "Microsoft Excel" and apply Heading 3. 

> Similarly, apply Heading 1 on "Corel Draw" and Heading 2 on "Corel 

Photo-Paint", "Flash" and "Adobe Photoshop". 

Save the file with the name "Types of software" and exit from 

Microsoft Word. 

SUCCISS Ll.ii 

lhs.e.dl 

 

 

 

 [ois 
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Figure 3.10:  Insert Outline Dialog Box 

> Start PowerPoint and open any existing presentation. Click on the Viewtab and select the Slide Sorter button. 

) Now, click on the New Slide drop-down menu on the Home tab. Select the Slides from Outline option. 

) The Insert Outline dialog box will appear. Browse the location of the Word file—"Types of software". 

)'  SelectthefileandclickontheOpenbutton. 

) Observe thattwo new slides willget inserted and displaythetext in a style, which you have applied. 



PowerPoint 2013 

Save As 

4 vPO Today 

• OiWOqlvo 

Figure 3.13:  Selecting the Locatlon-OneDrive-Personal 

Invite people 

Canedit 

Reading lips for Student 

In PowerPoint 2013, you can apply transition effects and animation using the TRANSITIONS and ANIMATIONS tab in 
the same way as you do in PowerPoint 2016. 

S ARING A PRESENTATION ONLINE 
Share x 

)  Open a presentation that you want to share, and click on the Share 

bitton P+ Share  present on the top-right corner of the ribbon. 

POwerPoint will prompt the option Save to Cloud if you have not saved 

your presentation yet. Choose the location OneDrive - Personal 4 to 

save your presentation. 

To collaborate with others, please save a 
copy of your file to an online location and 

change the file type to .pptx. 

Save to cloud 

r ii i- +6YoE3 

Figure 3.12: Saving a file on Cloud 

Once your presentation is saved to the shared location, click 

on the Share with People option from the Share window. 

The Share task pane will appear in the presentation 

window. In the text field under Invite people, enter the 

email address of the person you would like to share with or 

select the email address from the Address book if the 

contact is already saved. 

Share x 

) Select the option Can edit if you want the other person to work on the 

presentation simultaneously, otherwise select Can view option, below 

the Invite people list. Now, click on the Share button. H 
Sh3 

Figure 3.14: Inviting People 

RECAPI 

   

   

> The abilityto move objects, like text, graphics, charts, logos etc., on the slide is called Animation. 

) Transition effects appear when one slide changes to other during Slide Show view. 

) Music or sound effects can add a completely new dimension to any presentation. You can add sound in the form of 
background music or special effects to give importance to specific content. 

) Video clips add liveliness to the presentation. PowerPoint allows you to insert a video onto a slide and play it during 
presentation. 

) Action buttons are built-in button shapes that can be added to a presentation and set to link to another slide, play a 
Sound, orperform some otheraction, 

)  PowerPoint has the facility to import data from other applications, like Word, Excel, etc., and use it in the 
resentation. 

Learning 
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SECTION - A 

A. Fill in the blanks. 

1. are the special effects that you see when one slide changes to another in Slide 

Show View. 

2. Animation effects can be applied on both and on a slide. 

3. is a ready-made button for defining hyperlink on a slide. 

4. It is essential to connect a to the computerwhile recordingyoursound. 

5. button is present on the Start Slide Show group. 

6. checkbox is used to continuously play a sound clip. 

-  Action Button 
HINTS 

'.  Transitions 

Objects -  Microphone 

Loop until Stopped From Beginning 

Text 

B. State True or False. 

1. Action Buttons can be used to link any otherapplication to the current slide. 

2. You can add sound to text or graphics in a presentation. 

3. Video clips can be added to a slide by selecting the Home tab. 

4. You cannot add more than one animation to the same object. 

5. Animation Painter option copies the animation from one object and applies it to another. 

6. Audio command is present on the View tab. 

7. The speaker icon on a slide cannot be moved orresized. 

C. Application-based questions. 

1. Kabir's teacher has asked him to create a presentation, in which every slide is linked to its succeeding slide. 

Which feature should he use to accomplish the task? 

2. Priya has made a presentation on 'Child Labour—A Curse' with twenty slides in it. She wants to import some 

data from a Microsoft Word file. How can she dolt? 

Learning 
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SECTION - B 

A. 4ultipIe-choice questions. 

1. Which shortcut key is used to make a duplicate of the slide? 

a. Ctrl + D b. Ctrl + M 

2. effects can be added to objects on a slide. 

a. Animation b. Transition 

3. The recorded sound files are saved with extension  

c. Ctrl + G 

c. Sound 

a. .midi b. .wma c. .wav 

4. Which symbol indicates the type of effect used for text and objects in a slide? 

a. b. (%) c. (?) 

B. Answerthefollowingquestions. 

1. What do you understand by Animation? How is it helpful in a presentation? 

2. What do you mean by Transition? 

3. How will you insert your own sound in a presentation? 

4. What is an Action Button? Why is it used it in a slide? 
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) Open PowerPoint 2016 application. 

) Prepare your slide as shown in the Figure 1. 

> Insert a new slide, i.e., 'Title and Content' slide. 

> Type the text as shown in the Figure 2. 

) Save your presentation with the name, 'Keys To Success'. 

Move to the first slide by using the Page Up key. 

> Apply the required design by choosing Theme from the 

Design tab. 

> Applythe formatting effects, like Font, Font Size, Font Color, etc., to the text. 

Click on the Transitions tab and go to the Transition to This 

Slide group. Choose the Peel Off effect from the displayed 

choices. 

> In the Timing group, deselect the On Mouse Click 

checkbox. Click on the After checkbox and specify 

"00.05.00" seconds in the box. 

> Move to the next slide using the Page Down key. Apply 

Dissolve effect and set its time duration for "00.05.00" 

seconds. 

Click on the Animations tab> Add Animation option. 

Select the More Emphasis Effects option from the drop-down list. 

The Add Emphasis Effect dialog box appears. In the 

Moderate section, select Color Pulse option. Click OK. 

Now click the Preview button in the Preview group on the 

Animations tab to view the effect. 

Open Word 2016 and type the data given in the Outline 

view. 

Follow the heading styles according to the steps given in the 

chapter under the heading, "Importing Data From Word". 

Save the file by specifyingthe name 'Employee Details' and 

exit from the Word application. 

KEY 

Figure 1 

KEYS ARE 

• Live We key. P.kA Foolrhy 

• Honesty and Patience 

• H.iewig Tenaoes and Woniec 

Do at a J. and Love what do 

Figure 2 

-  .4- 

S •. • _ 

Navigation Employee Detail 
P € Name: Karan Gupta 

Employee Nurn: 109876 
s- 

till-- 
.- - Salary: 10000 
- Q Residential Address 

. a a- 

Figure 3 



) Start the PowerPoint 2016 application and open the presentation, 'Keys To Success'. 

> Insert a new Title Slide by clicking on the New Slide button. Type the contents as shown in the given image. 

> Select the word, 'GOALS' and change the Font to 

CooperBlack, FontSize-60and FontColor-Red. 

) Similarly, change the formatting effects of the 

paragraph. 

> Select the desired animation from the Animations 

tab. 

> Now, insert an Action Button on the slide and link it 

with the Previous Slide. 

      

      

 

GOALS 

    

      

V' To achieve happiness, we should make certain 
that we are never without an important goal. 

  

  

      

b'  The world makes way for the man who knows 
where he is going. 

 

      

   

Ralph Emerson 

 

      

> Insert sound clip from a file into your slide by 

selecting the Insert> Audio> Audio on My PC. 

) Select the required sound from the Insert Audio dialog box and click on Insert. Click on the Play/Pause button 

to listen to the audio clip. 

> Now, insert a new blank slide in your presentation and insert a video clip on the slide. 

> Save the presentation and press F5 to run the presentation. 

Switch back to PowerPoint and open the existing presentation. Click on the View> Slide Sorter button. Click 

nthe New Slide drop-down menu. 

3rowse the Word file and click on Insert. The new slides get inserted and display the text in a style which is 

)eing applied. 

Save the presentation once again. View the presentation in Slide Show mode and observe the effects. 

Learning While Playing 

Make a presentation of twenty slides on the topic: Diversity in India. This presentation should 

depict the history, culture, festivals, food, languages, etc., of our country. Apply all the formatting 

effects you have learnt. Apply beautiful themes to your slides. Add different transition and 

animation effects to your presentation. Make use of Action Buttons wherever possible. 
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GROUP DISCUSSION 

 

For Concept Clarity 

  

   

Conduct a group discussion on the topic: 

Difference between Animation and Transition Effects 

PROJECT WORK Using Creativity 

 



To Select 

A row/column 

Action 

Click the row/column heading 

Entire worksheet Press Ctrl+A or click the SelectAll button located on the top of the first row heading 

Select the first row/column, then hold down the Shift keywhile you select the last row/column Adjacent rows/ 
columns 

Non adjacent rows! 
columns 

Click the row/column, then hold down the Ctrl key while you select the other rows/columns 
for selection. 

Category 

General 
UumbCr 
CwrenCy 

l u1 
T,mi 
Percentage 
F,ct,on 

Tet 
- Spec,,l 
Custon, 

Sample 

12/26/2026 
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'Wednesday, March14, 2012 
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344/12 
03/1442 
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Figure 4.1: Format Cells Dialog Box 
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MICROSOFT EXCEL 2016 

 

LEARNING IN THIS CHAPTER 

  

   

Selecting cells 
' Entering numbers as Text/Date and Time 

I Changing cell contents, Using Undo and Redo features 

r  Inserting and deleting cells, columns/rows 
r  Copying and moving data 
o  Using Auto Fill and Flash Fill feature 

In the previous class, you were introduced to one of the most popular spreadsheet software, i.e., Excel 2016. It is 

widely used to process complicated mathematical calculations and also allows you to store, organise, and analyse 

the data. You also learnt about its basic features, like how to enter data, perform calculations, save the workbook, 

etc. 

In this chapter, we will discuss the various ways to select and enter data, modify the cell contents, insert or delete 

cells/columns/rows usingAuto Fill and Flash Fifi feature in MS Excel 2016. 

We often need to select a group of cells to perform various operations, such as copying, moving, inserting, or 

deleting. Selection can be made in any of the following ways: 

ENTERING NUMBERS AS TEXT Ilumbe, Alignment Pont Seeder flU Protedi*n
- 

If a number is entered in the format, such as 01481, Excel will 

drop the leading '0'. To preserve the leading 0, required in case of 

telephone area codes, roll number, etc, type an apostrophe 

before the number, like this: '01481. 

The data is now treated as text and displayed in the same format 

as it has been entered. 

Typically, formulae will treat the entry as a 0 and functions will 

ignore it. 

Date formats disptsy do rand time scrial numbers as dote values. Date formats that begtfl w,th 
an agents, respond to changes in regional dote and time settIngs that are specified for the 
operating system. Formats without an asterisk are not affected by operating system settsngs. 

OK Cancel 

A 

V 
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REPORT 

R.No. Name Total Per 
101 Kabir 82 

102 Rid hinia 79 

103 Ankur 56 

104 Manan 96 

105 Ranji 59 

9 106 Ankita 94 

10 107 Tanvi 63 

11 108 Amit 86 

12 109 Deepka 91 

Figure 4.2: Replacing the Cell Contents 
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it 

A I C o a 

r

Quick View 

Press Ctrl+5h1ft+7 to apply 

the outline border around 

the selected cell or a 

range of cells. 
06 

6 

ENTERING DATE AND TIME 

Select the cell and type the date and time. You can separate the date elements with a 

slash (/) or a hypen (-) or use a format, such as 11 October 2019. Excel recognises and 

supports a variety of date formats. 

To display the entered date in a different format, select the cell containing the date. CTick 

on the Format drop-down button in the Cells group on the Home tab and select the 

Format Cells option. In the Format Cells dialog box, choose any desired format of date 

by c'icking on the Date option in the Category list on the Number tab. Similarly, you can 

choose different time format by clicking on the Time option in the Category list. 

CHANGING CELL CONTENTS 

The characters and numbers typed in a worksheet can be seen both in a cell as well as on 

the Formula Bar. Enter the contents and press 

either the Enter key or Enter button on the 

Formula Barto accept the entry. 

When you type in the new data in the cell, the 

two buttons Cancel 1i  and Enter '/ present 

on the left of the Formula Bar become active. 

Cell contents can be modified in two ways: 

Replacingcellcontents 

> UsingEditmode 

REPLACING CELL CONTENTS 

) You can edit the cell contents directly and 

replace them with a new entry. 

Open a new worksheet and type in the 

data as shown in Figure 4.2. 

> Select the cell for example D6, whose 

content has to be changed. 

) Now, type 65 in that cell and press the 

Enter key. 

> Note that the previous value 56 is replaced 

with 65. 
S 

) Similarly, try to change the contents of the 

other cells. 

USING EDIT MODE 

> Selectthe cell D6. Double-click on the cell. 

) The insertion point will blink within the cell. 

REPORT 

R.No. Name Total Per 

101 Kabir 82 

102 Ridhinia 79 

103 Ankur 651 
104 Manas 96 
105 Ranji 59 

106 Ankita 94 

107 Tanvi 63 

Mode  
1109 

Amit 86 

Deepika 91 

    

Let Us Recall 

A range is a group of 

contiguous cells, which 

form the shape of a 

rectangle. When you 

select a range, the 

selection becomes dark 

with a border around it. 

Know the Fact 

When you open Excel 2016 

for the first time, the Excel 

Start Screen will appear. 

From here, you can create 

a new worksheet, choose 

a template, and access 

your recently edited 

workbooks. 

Quick View 

To repeat most commands 

or actions, press F4 key. 

Quick  View 

To enter data in multiple 

lines in the same cell, use 

Alt + Enter key 

combination. - 

Figure 4.3: Editing the Cell Contents 
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FIgure 4.4:  Using Undo Button 
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Figure 4.5: Using Redo Button 

Note that the Edit mode is indicated on the left side of the Status bar. Position the pointer at the desired place 

and change the contents. 

Press the Enter key. The changes will be entered in the current cell. 

Note that the Edit mode indicator changes to Ready mode. 

We can also edit the cell contents in the following ways: 

Select the cell and then click on the Formula Bar. Move the pointer to the position where you want to insert 

characters. Now, make the required modifications in the Formula Bar. 

Turn on the Overtype mode by double-clicking the cell. When Overtype mode is turned on, the cursor changes to 

a blinking bar and the character to the right of the blinking bar gets highlighted. Press the Insert key from the 

keyboard. Start typing in the cell. The existing characters will get replaced with the new characters you type in. 

iiXJ 
You can change the cell contents by pressing F2 key after selecting the cell. The cursorwill blink at the end of 

the cell content. 

USING UNDO AND REDO FEATURE 

After makirg modifications in a cell, you may wish to cancel the changes and retrie\'e the previous data. To undo 

the last action(s) performed, use the Undo button on the QuickAccess Toolbar. 

The Redo command is used to quickly repeat the last action(s) that you have undone using Undo command. To 

do so, click on the Redo button on the QuickAccess Toolbar. 
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Insert Delete Format 

  

'V 

  

There are two ways to insert blank cells. 

Select the range of cells where you want to insert 

the blank cells. You should select the same number 

of cells as you want to insert in the spreadsheet. 

Insert 

Insert 

C)  Shift ceUs right 

Shift (€115 doWflj 

E Entire row 

0 Entire column 

Shift cells right: Moves the selected cell(s) towards right, 

Shift cells down: Movesthe selected cell(s) down by one row, 

Entire row: Moves the complete row down by one row, 

tntire column: Moves the entirecolumn towards right. 

OK Cancel 

x 

Insert Sheet Rows 

ul'u insert Sheet columns 

lnert Sheet 

Figure 4.6:  Selecting 
Insert Cells option 

Figure 4.7:  insert Dialog Box 

4 
) You can use the shortcut keys Ctrl+Zfor Undo and Ctrl+Yfor Redo actions. 

> Some actions cannot be undone, such as clicking any command on the File tab 

menu. If the command or the action cannot be undone, the Undo button 

changes into Can't Undo. 

> Some actions, such as using a function in a cell cannot be repeated. If the 

command or action cannot be repeated, the Redo button changes into Can't 

Repeat. 

INSERTING CELLS, COLUMNS AND ROWS 

At times, while entering data, you may miss out certain enteries. In such situations, you 

may have to insert some cells, columns, or rows in the worksheet to accommodate the 

new data. 

Let's Know More 

To clear the contents of 

the cell, select the cell. 

click on the Clear 

button in the Editing 

group on the Home tab. 

Select Clear Contents 

option. 

)' You can also clear the 

contents of the cells by 

selecting the content 

and then pressing the 

Delete key. 

Quick View 

The key combination 

Ctrl + — displays the 

Delete dialog box to 

delete the selected cells. 

You can minimise a 

workbook window to an 

icon by pressing Ctrl + F9 

key combination. 

Ctrl + F1O maximises or 

restores the selected 

workbook window. 

Now, right-click on the range and select the Insert option. Or 

Select the Insert button in the Cells group on the Home tab. Click on the Insert Cells 

option from the drop-down list. 

In both the cases, you will get the Insert dialog box. There are four different options 

to choose within the dialog box as displayed in Figure 4.7. Select the desired option 

and click on OK. 

INSRTING A COLUMN/ROW 

) elect the column or cell to the left of which a new column is to be inserted. Here, we 

have selected column 'E'. 

Let's Know More 

To insert a blank 

column/row, right click on 

the cell and select the 

Insert option from the 

pop-up menu and select 

the desired option from 

the Insert dialog box. 
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— - — You can delete a row in the same way as you 

delete a column, i.e., by clicking on the row header 

and choosing Delete Sheet Rows from the options of 

Delete drop-down button. Or 

Right-click on the row header and choose the Delete 

option. 

N OTE 

Click on the drop-down arrow of the Insert button in the Cells group on the Home tab and choose the insert 

Sheet Columns option. Excel inserts a blank column to the left of column 'E' and shifts the entries of column 

'E' to 'F'. 

• Conat aEomatlng lnwI  £ I 

B I II A A j: s • ?fo,mtMTae • J 
I • Sl FOn,,4t $ 

4 A5. 4 

El - 

A B C 0 E, ' ' I 
New Column Inserted 

REPORT 
R.No. Name Total Per 
101 Kablr 82 
102 Ridhirna 79 
103 Ankur 65 

Figure 4.8:  inserting a Column 
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REPORT 
R.No. Name Total 

New Row Inserted 
101 Kabir 82 

102 Ridhlma 79 

Figure 4.9: Inserting a Row 

2 

3 

4 

S 

6 

You can insert a row in the same way as you insert a column. Select the row or a cell above which a new row is 

to be inserted and choose Insert Sheet Rows from the options of Insert drop-down menu. 

DELETING CELLS, COLUMNS, AND ROWS 

DELETING CELLS 

> Selecttherangeofcellstobedeleted. 

> On the Home tab, click on the drop-down arrow of the 

Delete button and selectthe Delete Cells option. 

> The Delete dialog box appears displaying four options. 

Choose the appropriate option and observe the change. 

DELETING COLUMNS! ROWS 

> Select the column to be deleted by clicking on its 

header. 

> Click on the Delete drop-down menu in the Cells group  
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A B C 0 

Delete Cell 
L I- 

REPORT 
R.No. Name Total 
101 Kabir 82 

102 Rid hima 79 
103 Ankur 65 
104 Manas 96 
105 Ranji 59 

Figure 4.10: Deleting Cells 
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 Selected Row 

S c. c 

6 b ma 79 
7 pst Opdo, 65 
8 35 96 

P leo. 59 
10 :a 94 

63 flfl'fnn!fld.   

Figure 4.11:  Selecting Row to be Deleted 
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on the Home tab and select the Delete Sheet Columns 

option. Or 

Right-click on the header of the selected column and 

choose Delete option. 
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Figure 4.12; Changing Row Height and Column Width 

> To insert multiple columns/rows/cells, select the same number of columns/rows/cells that you want to insert. 

) To insert non-adjacent columns, hold down the Ctrl key while you select non-adjacent columns. 

CHANGING ROW HEIGHTAND COLUMN WIDTH 

In Excel, you can ad just the row height and column width of the worksheet as per the requirement. The default value 

for row height and column width is 15 points and 8.43 points, respectively. 

TO CHANGE THE ROW HEIGHT 

> Selectthe row. 

) Click on the drop-down arrow of the Format button in 

the Cells group on the Home tab. 

> Click on the Row Height option. 

The Row Height dialog box appears. Enter the desired 

value and click OK. 

> The change will be reflected on the selected row. 

TO CHANGETHE COLUMN WIDTH 

> Selectthe column. 
Column Width ? 

> On the Home tab, click on the drop-down arrow of the Format button. From 

the displayed list of options, click on Column Width. Column width: 7.571 

> The Column Width dialog box appears. Enter the desired value and click OK. OK 

Observe the change on the selected column. 

X 

1 
Cancell 

COPYING AND MOVING DATA 

Copying refers to duplicating data, i.e., text, numbers, formulae, either in the same worksheet or a different one. 

Moving refers to changing the position of the data either in the same worksheet or different one. The moved or 

copied data is stored temporarily in a location in computer memory called Clipboard. To move or copy data, use the 

Cut, Copy, and Paste commands. 

COPYING AND PASTING DATA t'aste 

) Select the cell or a range of cells that you want to 

copy. Let us say B4:D4. 

> Click on the Copy button in the Clipboard group. The 

Ho 

r. 

Copy - 
O 0 0'0.1101 

ii A o
99 C•7li1.l 

k1 $ 96 
• .O9 4i.'3 

I. 1100011 

1. 101 

C D E 

Cflpb7103 

76 

Toni 

B 

> 

dashed line will appeararound the selected cells. 

Select the destination cell, let us say F6 and click on the 

Paste button in the Clipboard group. The text will be 

copied to the new location. 

4 

5 

61 
7 

REPORT 

R.No.  

101  
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Kabir 

Ridhima 

Total Per 

82  

79 

103 Ankur 65 

104 Manas 96 

Figure 4.13:  Copying the Range of Cells 

Learning 
Computers with  Kips 

.ond,600.IFo,,o4999 th• fl  

11700n99007.bI. ° 2NIo. 

[C.HSsy$n- 

5301,, (0.l 

F G Fl 

101 Kabir 82 



Ficjuio 4. Using Auto Fill Feature 
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If you want to paste the same data repeatedly, you need to click on the Paste button in different cells. 

To remove the border around the selected cells afteryou finish copying, press the Esc key. 

 

MOVING DATAAROUND 

Sometimes, you find that the placement of data is not kmn. 1CM-il $'_ujr I  iytiii IijioiIas I)ila IIivjoyi View :t141 

appropriate. You need not delete or retype it. Excel allows Ct 

. B I 
1!-CC 

A A 

Co4itioaI Fniattiflg- 

tDu 

you to move data around the worksheet. 
•"' 

--A- çCUSi1es Fom 

Using Drag and Drop Method f. s 

Arib•l . (1 

B C LI E G 
>  Select a cell or range of cells. Position the mouse ' 

pointer at the edge of the selected cells. 

>  Notice that the pointer changes from a white cross 

symboltoamovepointersymbol ± 

>  Drag the selected cell or a range of cells to a new 

destination and release the mouse button. The data will 

be moved to a new location. 

REPORT 

Figure 4.14: Using Drag and Drop Method 

3 R.No. Name Total Move Tool 
4 101 Kabir 82 

S 102 Rldhima 79 - 
103 Ankur 65 
104 Manas 96 

8 105 Ranji 59 
106 Anklta 94 

> We can also move the data by using the Shortcut menu. Right-click on the cell to open Shortcut menu and 

select the Cut command. Now, select the destination cell, right-click on it and choose Paste option. 

> The shortcut keys to perform Cut, Copy, and Paste operations are Ctrl+X, Ctrl+C, and Ctrl+V, respectively. 

> You can also move the data by selecting the Cut and Paste button in the Clipboard group. 

USING AUTO FILL AND FLASH FILL FEATURE 

Excel provides two wonderful features, Auto Fill and Flash Fill, to enter data quickly in a worksheet, instead of 

entering it manually. 

AUTO FILL 

The Auto Fill is the easiest method to fill data automatically 

in the worksheet cells. 

Type 'January' in cell Bi. 

Position the pointer at the lower right corner of the cell. 

The mouse pointer changes into a black "~" cross 

symbol. 

Hold down the left mouse button and drag the fill 

handle up to cell B5. Release the button. 

The months February to May would appear in the cells 

B2toB5. 
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) If the source cell contains text, a number, formula, day, or month, the Auto Fill feature copies the data from 

the source cell to the destination cells. 

In case of numbers, type two consecutive numbers to fill the series, while using the Auto Fill feature. 

FLAStI FILL 

Flash Fill, introduced in Excel 2013, is a time-saving feature, which identifies the data fill pattern that you use 

frequently in a worksheet and then fills the remaining series, accordingly. Let us try it practically. 

> Make two columns, NAMES and INITIALS in the Excel sheet. 

Fillthe data in NAMES column as given infigure4.16. 

The INITIALS column should have data that is a combination of the first characters of the First name and 

Last name, e.g., RK for Ravi Kumar. 

Type RK in the INITIALS column and press Enter key. 

Click on the Fill drop-down arrow present on the Home tab in the Editing group and select the Flash Fill option. 

You can also use the shortcut key Ctrl + E. 

The initials of rest of the entries will be automatically added in the remaining cells of the INITIALS column. 

infokips pkl 

AutoSum - j4 
Fill
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Qown - 

E ght 

enes... 

.ustify 

flash Fill 

Fill (Ctrt#E) 

Automatically fill in values. Enter a 
couple ol examples you want as 
output and keep the active cell in 
the column you want filled in. 
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) To make the entry of digits as text, you have to begin the entry with an apostrophe ('). 

) The appearance of Date and Time on a worksheet depends on the date format applied to the cell. 

> You can edit the cell contents directly and replace them with a new entry. 

> The Overtype mode can be turned on by double-clickingthe cell and pressing the Insert key. 

> The cell contents can also be modified by using F2 key. 

> The shortcut keys to perform Cut, Copy, and Paste operations are Ctrl + X, Ctrl+C, and Ctrl + V, respectively. 

> Auto Fill is the easiest method to fill data in cells automatically. 

> Flash Fill is a time-saving feature, which identifies the data fill pattern that you use frequently in a worksheet and 

then fills the remaining series accordingly. 

BRAIN  -   

SECTION - A 

A. Fill in the blanks. 

1. The appearance of Date and Time on a worksheet depends on the applied to the cell. 

2. To repeat mostof the commands oractions, pressthe ...... function key. 

3. You can minimise the worksheet by pressing the  ..  key combination. 

4. The and buttonsarepresentontheFormulaBar. 

5. When you use F2 key for modification, the insertion point appears at the of the cell content. 

6. To copy the data, the key combination can be used. 

7. The default value for column width and row height in a worksheet are  and 

points, respectively. 

HINTS
Enter Ctrl + C 15 F4 

Ctrl + F9 8.43 End Cancel 

Format 

B. StateTrueorFalse. 

1. Copying refers to placing data from one place to another. 

2. Ctrl + A key combination is used to select a row. 

3. Auto Fill is a feature to copy data simply by draggingthe fill handle to the cells to be filled in. 
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4. To turn on Overtype mode, press the Insert key from the keyboard. 

5. Copy, Cut, and Paste buttons are present in the Font group. 

6. To insert a new column in Excel sheet, select Add button on the Insert tab. 

7. The shortcut key for Flash Fill is Shift +E. 

C. Application-based questions. 

1. Ritu has created progress reports of the students of her class in Excel 2016. But she has forgot to add an 

important column in the table. Suggest the option that will help her insert a new column without disturbing the 

existing table settings. 

2. Surabhi was assigned the task to write a series of numbers from 1.10 without using keyboard. Help her 

complete the assignment. 

SECTION - B 

A. Multiple-choice questions. 

1. The function key is used to change the cell contents of a selected cell. 

a.F5 b.F4 c.F2 

2. Ctrl+ V key combination is used to the cell contents. 

a.Undo b.Paste c.Cut 

3. When you finish editing within a cell, the Excel returnsto mode. 

a. Edit b. Finish c. Ready 

4. To select a range, hold down the key and click on adjacent cells. 

a.Shift b.Ctrl c.Alt 

5. is the shortcut key to undo the last action. 

a.Ctrl+Z b.Ctrl+Y c.Ctrl~X 

6. The key combination can be used to apply outline border around the selected cell. 

a. Ctrl + Shift + F9 b. Ctrl + Shift + 7 c. Ctrl + G 

7. The key combination is used to select an entire worksheet. 

a.Ctrl+A b.Ctrl+C c. Shift + A 

Learning 
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B. Answer the following questions. 

1. How will you make modification in the cell contents using Edit mode? 

2. Explain the two methods to insert a column in a worksheet. 

3. What isthefunction of Undo and Redo commands? 

4. How will you select a range of non-adjacent cells in a worksheet? 

5. How will you move data in a worksheet using the dragging method? 

6. Explain anytwo methods for copying data. 

7. What isAuto Fillfeature? How can it be applied? 



8. How can you change the row height and column width in a worksheet? 

9. What is Flash Fill? Explain with the help of an example. 

C.	 You have been asked to plan a friend's birthday party. Create a spreadsheet to make an estimate of 
the expenditure. 

A B C D 

1 PARTY EXPENSE 

2 

3 

4 

Number of guests 75 

Unit 

75 

Cost 

120 

Item Total Cost 

Buffet 

5 Hall decoration 500 

6 Return gifts 69 20 

7 Disco stage 1000 

8 Hall charges 1 5000 

9 Total Expense 

State the formula that would be used in the following cells: 

D4 

D6 

D9 

2. Write down the address of the cell that contains the Total number of guests. 

3. Write down the cell address that contains the cost of the Hal! charges. 

Which mode is displayed on the Status barwhen you make changes in a cell? 
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Perfection Through Practice LAB SESSION 

> Open Microsoft Excel. Enter the given data in a worksheet. 

A B C D 

Employees information 

2 

3  Name Designation Department Salary 

4 Asna Manager Marketing 25000 

5 Arshia Sales Executive Marketing 15000 

6 Kiran Store Keeper Production 10000 

7 Sonali Worker Marketing 8000 

8 Mithu Asst. Manager Marketing 18000 

9 Rachel Worker Production 8000 

10 Chandan Typist Computer 9000 

11 Jai Comp. Operator Computer 9000 

12 Arica Sales Executive Marketing 12000 

13 Payal Sales Executive Marketing 12000 

> Save the assignment using the Save button on the Quick Access Toolbar. Specify a file name for it. 

> Insert a row after row 12 and enter the following data: Karan, Managing Director, Marketing, and 50000 in 

the newly inserted row. 

> Insert a column before the 'Salary' field and enter the heading - 'Phone No'. Enter the phone numbers of the 

employees in this newly added column. 

) Activate the cell A6 and change its content to 'Rohit'. 

> Change the cell contentto 'Production' in cell C7 by using Edit mode. 

> Copy the contents of cell Bi 1 and paste it in cell B8 using Ctrl+C and Ctrl+V key combinations, respectively. 

> Inserta column before column A.Type the heading'Sr. No' in cellA3. 

> Type 1 and 2 in cell A4 and AS. Fill the rest of the entries using the Auto Fill feature. 

> Save the file using Ctrl + S key combination. 

GROUP DISCUSSION 

Conduct group discussions on the given topics: 

> Various ways of Selecting Cells 

) Different ways of Inserting and Deleting Columns and Rows 

For Concept Clarity 

Learning 
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PROJECT WORK 
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Using Creativity 

You are a member of the cultural club of your school. Next week there is an Inter-House Declamation Conte 

which has been categorised in two groups. Each house should have two participants in each group. T 

teacher has asked you to create the evaluation sheets for judges with the following fields: 

A B C D E F G H I J K 

1 

2 

3 

INTER HOUSE DECLAMATION CONTEST 

NAME 
4 

S Aman R.n, 

INITIALS 

AR 

HOUSE 

Lotus 

INTRODUCTION 

(5) 

CONTENTS 

(5) 

PRONUNCIATION 

(5) 

PAUSES 

(5) 

CONFIDENCE 

(5) 

MODULATION 

(5) 

CLOSING 

(5) 
TOTAL 

6 Pre.t Dogra PD Rose 

7 Anu Ktul A( L'y 

8 RohtMahaJan PM Jasmine 

9 SonalGupta SG Rose 

10 Sh..tal Sharma SS Jasmine 

11 Rtt.ah V.rm. RV Lotus 

12 MohitChawla Mc LJy 

Sheeti 

— I + t 

by applying the required formatting effects as shown in the image. 

'Body Language', between 'Pauses' and 'Confidence'. 

field 'Body Language'. 

and row height to 15 points and 30 points, respectively. 

by adding up the marks of all thefields.(Use Quick Analysis Tool) 

Fill to fill up the 'Initials' column. 

) Prepare the sheet 

> Insert one more field, 

> Assign 5 marks forthe 

> Set the column width 

> Calculate the 'Total' 

) Make use of Flash 

ONLINE LINKS Looking For More 

To know more about Microsoft Excel, visit the site: 

www.gcflearnfree.org/exceI201  6/1 



LEARNING IN THIS CHAPTER 

' Working with Formulas • Cell Reference of another Worksheet 
r Using Basic and Compound Formula • Renaming and Changing Colour of a Sheet Tab 

Using a Range in Formula • Functions and Function Library 
r Using Formula on Text • The Insert Function 
' Types of Cell References a Formula Errors 

I 

Equal to Symbol 

Constant 

USING A BASIC FORMULA 

)' Click on the cell B4. A dashed border called marquee will appear around it. Its address will appear in the cell Bi 1 
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FORMULAS AND FUNCTIONS 

One of the important attributes of Excel is its ability to perform calculations using either formula or function. In this 

chapter, you will learn the basics of formulas and functions and how can they be used in different scenarios. 

Formulas are the user-defined instructions to perform calculations, whereas, functions are the pre-defined or 

in-builtformulas that come with Excel. 

S WORKING WITH FORMULAS 

Formulas are used to perform calculations involving addition, subtraction, division, and multiplication. A formula 

establishes a relationship between two or more cells. It is an expression that can include cell addresses, numbers, 

arithmetic operators, and parenthesis. Using it, you can perform simple as well as complex calculations. 

Formula must begin with equal to (=) symbol, followed by cell references and operators. it may contain a few or all 

the below-mentioned elements. 

References 

Operators 

Constants 

Functions 

A cell or range of cells that you want to include in your calculation 

Symbols (+,,*,1\,%,$,#,  etc.)that specify the operation to be performed 

Numbers or text values that do not change 

Predefined formulas in Excel 

ELEMENTS OF FORMULAS IN EXCEL 

    

Cell Address 

4, I 4, 4, 
=A2 + B2*5SU(E3:E5)4 Range 

t I - Function 
Mathematical operatorsj 

Basic formula involves only one type of operator in it. Let us use it to calculate the sum of the numbers in B4, B5, ... B9 

and display the result in Bi 1. 

Follow the steps: 

Click on the cell Bi 1 (where you want to display the result) and type sign. 



,, 1. 

CJ 

1 

2 Painclpal I 4500J 

3 Rate 5  
4 lime (in year) 31  
5 
6 ]Simpie Interest k2183*B4/loe  

Figure 5.2: Using Compound Formula 

Quick View 

To enter or modify a 

formula in a cell, you can 

also press F2 after 

selecting the cell. Any 

change that you make in 

data will be reflected in 

the Formula result. 

55 >4 
Figure 5.3:  Using Range in Formula 
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Let Us Recall 

A 

ii 
2 

.4 

:s 
.6 

Month 

Jan 
Feb 

Mar 

., . 

e C 0 6   

How can we define 
formulas in Microsoft 

Excel? Incentive 

Sales 

Charity 

Percentage 

Amount 

lncent'ee Actual 
Expenses 

amount Expense 

200 

300 

300 

1000 
2000 

15000 
7 Apr 
S May 

3000 
1900 

250 
175 Quick View 

r 9 Jun 0o0 175 

10 To copy a formu'a from 
11 Total the above cell, press 

Ctrl +' (apostrophe). 
Sr 

arid Formula bar. This method of clicking on the 

cell to add its reference to a formula is caUed 

Pointing. The Status bar will display the status of 

Point. 

Now, type the + symbol. 

Repeat the above steps till B9 or type: 

=B4+B5+B6+B7+B8+B9 in Bil. Observe the 

different colour borders that appear around 

these cells. 

, ., Know the Fact 
.4* 8 C 0 € F 

2 

Incentive Percentage 

CharIty Amount 
A range spans a group of 

cells adjacent to each 

Mpnth 

.3 
4 Jan 

incentIve 
Sales Expenses 

amount 
Actu 

Expense 
other on a worksheet. The 

range can be used in 
formulas E 

5 Feb 
Mar 

l200 
l 

Apr 
SMay 

Jun 
10 
uj 

Press the Enter key. Cell Bi 1 will display the
Figure 5.1: Using Basic Formula 

total of all the valuesfrom B4to B9. 

Compound formula is used when more than one operator is required to perform 

calcuiation. Let us use itto calculate the Simple Interest by using the formula 

* R T/100'. Enter the data as shown in Figure 5.2. Follow the given steps: 

Clickonthecell B6andtype=. 

Click on the cell B2. The cell address of B2 appears in the cell B6. 

Again type the symbol * and click on the cell B3. 

Type the symbol * in B6 and click on the cell B4. 

Now, type the symbol 'I' followed by 100 in the 

cell B6 and press the Enter key. The cell B6 

displays the calculated Simple Interest. 

Note that the result appears in the cell, but the 

actual formula is visible on the Formula bar. 

> USING A RANGE IN FORMULA 

You can assign multiple cells to a formula by creating 

a range. By using range you can save a lot of time. For 

example, if you want to calculate the sum of multiple 

columns or rows, it is always better to define a 

range. 

> Type the data as shown in Figure 5.3. Click on the 

cell Bil and type the formula =SUM (34:B9). 

Here, SUM is a built-in function of Excel that 

helps in adding up the numbers. 
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Figure 5.4: Using Formula on Text 

cii 

A A 

f SUM(C4C9) 

B C 0  E 

1 

2 

Incentive Percentage 

Charity Amount 

Incentive Actual 
Month Sales Expenses 

amount Expense 
3 
4 Jan 1000 200 

5 Feb 2000 100 

6 Mar 15000 300 
7 Apr 3000 250 
8 May 1900 175 
9 Jun 2000 275 

10 
11 Totai  24900 13001 
12 

Sheeti .' 

Select deltenatlon and patse (Hits a, cftoo,e PMtc 

Figure 5.5: Using Relative Reference 

> Press the Enter key. The sum value will be displayed in the cell Bil. 

> Similarly, you can calculate the sum in the cell Cli by using the above-mentioned steps. 

S USING FORMULA ON TEXT 

You can also perform addition on character and string data type. Except for addition, other operations, like 

subtraction, multiplication, division, etc., are not allowed on the string data type. The ampersand symbol (&) is used 

to perform addition. Addition of two or more text values is called Concatenation. Let us understand this with the 

help of an example: 

> Enter any string type value in cells Al and Bl, say Kips in Al and 

India in Bi. 

> Enterthe formula = "Kips"&"India" in cell Cl and press the Enter key. 

> It will display Kipslndia in cell Cl. 

In the Formula bar, type the text within double quotes in order to create a text value. If you want to leave a blank 

space after each word, then leave a space before closing the double inverted commas. 

For example: I "&" Love "&" Computer" 

I Love Computer 

S TYPES OF CELL REFERENCES 

The cell address in a formula is known as the cell reference. With the help of references, you can find the values or 

data in a worksheet that you want to use in formula. There are three types of cell references: 

RELATIVE REFERENCE 

When you create a formula, references to a cell or ranges are usually based 

on the position relative to the cell. When you copy the formula to the other 

cells, the reference cell automatically gets changed. For example, if the 

formula in A3 is =Al~A2 and you copy the formula from A3 to B3, Excel 

automatically changes the reference to match the location of cells, i.e., 

=Bl+B2. Let us learn it practically. 

> Select the cell Bil, in which formula =SUM(B4:B9) is written. Click on 

the Copy button present in the Clipboard group on the Home tab. 

> Now, select Cli and click on the Paste button 

)' Observe that the cell reference in Cli changes automatically from 

B4:B9toC4:C9. 

You can also calculate the sum of the range by using the Auto Fill handle '+'. Select the cell Bi 1 and using the Auto Fill 

handle drag itto Cli. The sum of the range C4: C9will be reflected in the cell Cli. 



A 

Month 

B 

tharity 

Sales 

E 

perxetago 10% 

Amount 

Incentive Actual 
Expenses 

amount Expense 

1 10001 2001 °'sks1 
5 Feb 2020 100 

6 Mar 15000 300 

7 Apr 3000 250 

8 May 1900 175 

9 ian 2000 275 

11 Total 24900 1300 

12 

13 

Figure 5.6:  Using Absolute Reference 

Quick View 

To get the total of 

adjacent cells, press Alt + 

(Equal) key combination, 

instead of clicking the 

AutoSum button X 

ABSOLUTE REFERENCE Let!s  Know More 

  

Absolute reference is used when we do not want to change the address of the cell while 

copying the formula to another cell. To use absolute reference in a formula, you need to 

add dollar($) sign before the column and row number. 

For example =$A$1+$A$2 

Let us calculate the incentive amount at the rate of 10% on monthly sales. 

Type 10% in cell Dl. 

Now click on the cell D4. 

Type =B4*$D$1  and press the Enter key. 

The easiest way to define 

names for cells is to click 

on the Name Box at the 

left end of the Formula 

Bar. Type a name for the 

range and press the Enter 

key. 

Thecell D4displaysthevalue 100.Thefirst 

cell address B4 has no dollar sign, so it is 

relative reference and the second cell 

address is fully absolute. Therefore, when 

the data of the cell is copied, the first cell 

reference changes accordingly in the new 

location, but the second one remains the 

same i.e., $D$1. 

> Now, copy the formula by dragging the 

mouse pointerto the rest of the cells. 

MIXED REFERENCE 

A B 

Incentive Percentage 

C 0 

10% 

2 Charity Amount 50 

Incentive Actual 
Month Sales Expenses 

amount Expense 

ian 10001 2001 100 uSC4.054 

5 Feb 7000 100 200 

6 Mar 15000 300 1500 

Apr 3000 250 300 

8 May 1900 175 190 

9 Jan 2000 275 200 

10 

11 Total 24900 1300 

12 

13 

Shnrtl 

Figure 5.7:  Using Mixed Reference 
Lets Know More 

If you want to calculate 

the sum of multiple cells 

that are not in a range, 

separate each cell address 
SUM >r ,/ f, uAj+A73 

by a comma. 
A B C 0 

E.g.,=SUM (C4, C6, D8) 
1 25! 
2 [=A1+A2*3 

Figure 5.8: Using Circular Reference 

Learning 
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It is a combination of Relative and Absolute 

reference. In this type of reference, either the 

row or column has to remain fixed. $A1 + A$2  is 

an example of Mixed Reference. Let us use 

this method to calculate the Actual Expenses: 

Type 50 in cell D2. Click on the cell E4. 

Type=$C4-D$2. Press the Enter key. 

You can further calculate the Actual 

Expenses for the other cells by dragging 

the mouse pointer to the desired range 

when it changes to the cross (+) symbol. 

S CIRCULAR REFERENCE 

A circular reference occurs when a formula in a 

cell refers to its own cell value directly or 

indirectly. 

For example, if you enter the formula =Al +A2*3 



B 

25 

01  

ShnctX 

(licuLs,  Pctt;c,n(fv A 

eli 

A B C 0 E 

3 Month 5r 

4 Jan 20000 

5 Feb 35000 

6 Mar 25000 

7 Apr 27000 

8 May 46000 

9 Jun 32000 
-- 

10 

11 Total 1850001 -- 

12 

13 
o Sheeti Shcut2 Sbeet; 

Figure 5.9: Using Copy and Paste Option 

in cell A2, you are making the formula to refer to its own cell value, which is not possible. A 

warning, as shown in the figure given below, will be displayed in such a case. As soon as you click 

on the OK button of the warning dialog box, 0 will be returned in the cell containing formula. The 

Status bar will also notify you that circular reference is found in the workbook and the address of 

that cell will be displayed on it. 
hc,osoftExciI 

A Thif, .11 OflO Of Of cXoio, OferOnc,, who,o IfO,.gto tOftr to own (Ii lIMo Od Of iNs gN cowl tilt. 10 cWsMtellcootedb. 

1570000*5900 øiOsgiisg thest ttfownce o, .osusg SM Iot.ulss to dlferent Colt. 

CELL REFERENCE OF ANOTHER WORKSHEET 

You can use the cell reference of one worksheet in another worksheet. This can be done in two ways. 

USING COPY-PASTE OPTION 

) Click on the New sheet button present to the right of the Sheeti tab 

at the bottom of the screen. A new worksheet with the name 5heet2 

will be added. Now, enterthe data as shown in Figure 5.9. 

Click on the Sheeti tab. Now, click on cell Bil where the 'SUM' 

function is used. 

> Copytheformula using Ctrl+C. 

> Click on the Sheet2 tab. Click on the cell Bi 1. Now, paste the formula 

using Ctrl+V. The cell will display the result of the formula, i.e., the 

summation of the cell values. 

USING SHEET REFERENCE 

In this method, we use sheet number, exclamation mark, and cell address to refer to a cell of a particular worksheet. 

For example, by writing Sheeti! D4, you are referring to the cell D4 of Sheeti. Now, try to use this method to 

calculate the total salary. 

slj.,  

8 C 0 E F 

Click on the cell C4 of Sheet2. 

3 Month 
- I' 

Selory Type =B4+Sheetl!D4 in it and press Enter. This will add the 
I l000ol=04~sbeetllo4 

5 Feb 'Incentive Amount' present in the cell D4 of Sheeti with the 35000 

6 Mar 
7 Apr 

25000 
27000 

'Salary' present in cell B4ofSheet2. 
8 Moy 46000 

9 Jun 32000 You can further calculate the total salary for the other cells by 
10 
11 Total dragging the mouse pointer to the rest of the cells when it 

£00 

1 Sceut O-.lt3 Sh.o4 
fl - 

changes to the cross symbol. S 

Figure 5.10: Using Sheet Reference 

RENAMING A WORKSHEET 

By default, the worksheets in a workbook are named as Sheeti, Sheet2, and so on. You can rename a worksheet in 

order to make it more relevant for the users/readers. Usually, a worksheet is named based on the type of data it is 

holding. For example, if a worksheet contains daily attendance, you can name it as Attendance. Let us do it 

practically. 

Learning 
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Inseft... 

Qelete 

Rename 

Move or Copy 

iew Code 

rotect Sheet... 

lob Color 

etect All Sheets 

Theme Colors 

• 

Standard Colors 
.. ••.••• 
LI  tic Color 

• More Colors... 

> Right-click on the 'Sheet2' tab in the worksheet. 

> A shortcut menu will appear. Click on the 

Rename option. 

The Sheet tab gets highlighted. Assign a new 

name for the sheet by typing on it, say, 'KIPS' and 

press Enter. 

) Note that the name of the 5heet2 gets changed 

to 'KIPS'. 
Ready 

Figure 5.11:  Renaming a Sheet Tab 

CHANGING COLOUR OFASHEETTAB 

> Right-click on any Sheet tab and select Tab Color 

option from the shortcut menu. 

Select any colour from the displayed choices and 

observe the change. 

Figure 5.12: Changing Sheet Colour 

FUNCTIONS 

Functions are the pre-designed formulas in Excel to perform both simple and complex 

calculations. Functions save time and eliminate the chance to write wrong formulas. 

They acceptArguments and return Values. 

Arguments contain the information that you want to 

B C D F calculate.Theyaretheinputvaluestofunctions.The 

values are given within parenthesis. Arguments can 

be numbers, text, etc., and are enclosed within 

parenthesis. 

Functions begin with the equal to (=) sign followed 

by the function name and then the list of arguments 

separated by comma within the parenthesis. 

For example, =Function name(argumentl, 

argument2...) 

RULES TO ENTER A FUNCTION 

> All Excel functions must begin with = sign. 

) Function name must be a valid Excel name. For example, SUM, AVERAGE. 

> Function name must be followed by an opening and closing parenthesis. 

> Arguments are enclosed in the parenthesis. For example, =SUM (Al :AS). 

Relative vs Absolute Cell 

reference. 

Learning 
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Ben. nc 

Or 

E Brotect Sheet... 

lab Color 

kde 

deRt All Sheets 
SheetS 5heet2  

A B c 
Know the Fact 

The common functions, 

like Sum, Average, Count 

Numbers, Max, Mm, can 

be used by using the drop- 

down arrow of AutoSum 

button. To use other 

functions, click on the 

More Functions option. 

ii j -.----J + 

Figure 5.13: Applying Tab Color 

EU 

15 
16 
17 

18 
19 

20 

21 

22 

23 

rips 

nse,t.. 

Qelete 

Rename 

Move or Copy.. 

,1h1u1.h 
[.bColor 

1l, lolore 

a 

Stasd.id Cotoes 

NoCotee 

Moe. Coloes_. 

Quick View 

To copy the formula to alt 

cells in the selected range, 

press F2 and then press 

Ctrl + Enter key. 



,/ j.n SUM(C606) 

I 

Student Progress Report 

Marks 
Ora1IO0) Wrltt.n(100) Total Av.r. . 

1  Mwj 80 75 oSUM(C6O6) 
2 Atshli 97 93 SUM nbrrL fl0b. 

3 N.v..n 65 70 
4 KahltlJ 90 85 
S Sanishl 73 65 
6  Apft 77 89 

COMMON FUNCTIONS 

AUTOSUM 

The AutoSum option, besides being the common and the fastest way to find out the total of the given numbers in a 

range, can also be used to carry out different functions, like Average, Count, Max, Mm, etc. You can find this option 

at two places. 

In the Editing group on the Home tab 

> In the Function Library group on the Formula tab 

Let us use this feature to calculate the total marks obtained by 'Anuj'. 

Click on the cell E6where you wantto place the total marks. 

Click on the AutoSum option present in the Editing group on the 

Home tab. 

A dashed border appears around (6 through D6 and Excel 

automatically enters the formula (that uses the SUM function) in 

the cell E6. Now, press Enter. The cell E6 will display the result. 

IJ 100 

The Average function returns the average of the range values. The
Figure 5.14: Using Sum Function 

arguments can be a range of cells, simply numbers, or numbers along with cell reference(s). Using the worksheet 

shown in Figure 5.15, let us calculate the average of marks obtained by 'Anuj'. 

6 

.AV(RAGE(C6:D6) 

C 0 I F 

Student Progress Report 

Marks 
Oral(100) Wrtttan(100)  

75 

Total Av.rag. 

1 Anuj 80 155 

AVERAGE( 2 Arshla 97 93 195 

3 Nivean 65 70 135 

4 kshltij 90 85 175 

S Sarushi 73 65 138 

6 Arpit 77 $9 166 
7 Muskin 40 60 100 

) Click on the cell where you want to place the average of values, let 

us say F6. 

> Type the equal to sign (=)followed by the name of the function, i.e, 

AVERAGE. 

> Put the opening parenthesis symbol '('. Select the cell C6 through 

D6 to define the range of the cells. 

> Put the closing parenthesis symbol ')' and press the Enter key. The 

cell F6 will display the average of marks obtained by 'Anuj'. 

Sh.1 

Va., ~ 1..MJ554(4) 

0 8 

Figure 5.15: Using Average Function 

MAX() 
- A B C _______ 

Max function is used to find the largest value in the given range. Incentive Penent.g. 10% 

2 (ha yAn.o.ni  SO 

Click on the cell F4 and type =MAX(B4:E4) and press the Enter key. Month Sal.. (ap.ns 
IflCOfltI0 ActO*I 

.1 lan j 1000 200 100 1S0j.MAX(1$ 4) 

The maximum value in the range B4:E4 will be displayed in the cell S Feb 2000 too 200 50 
6 Mar 35000 300 1500  a50 

F4. / Apr 3000 250 3o0 zool.MINIS/ 
8 May 1900 175 190 125 

Similarly, Min() and Count() function can be applied to a range of cells. 
9 
10 

Ian 2000 275 200 225 

11 101.1 24900 1300 

Figure 5.16: Using Max and Mm Function 
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We can also carry out the above functions using the AutoSum feature. To do so, select the AutoSurn A. 

cell wherein you want to display the output of the functions. Click on the drop-down arrow 

of the AutoSum option and choose the desired function from the displayed list.
average 

count Numbers 
Another amazing way to perform quick calculation is by using the Quick Analysis Tool. It 

helps you to implementfunctions, such as Sum, Average, Count, etc. To use this tool: 

Select the range of cells on which you want to apply the MorEunct,cn... 

function. 

> Click the Quick Analysis button present at the bottom-right corner of the 

selection. 
c'" > Select Totals from the displayed list of tools and choose the desired 

function. lj 

TODAY  0 
The Today function is used to display the current date. 

> Type =TODAY() in the cell and press the Enter key. 

) The TODAYQ function will display the current date in the selected cell. 

  

Excel 2013 

 

The above mentioned functions 

are also available in Excel 2013. 

Similarly, you can insert the current day, month, and year in a cell. 

To displaythe values in numberform: 

> Formonth: =MONTH(TODAYQ) > Foryear:=YEAR(TODAYO) ) Forday:=DAY(TODAYQ) 

To display the values in text form: 

> Formonth: =TEXT(TODAYO,"MMMM") 

For day: =TEXT(TODAYO,"DDDD") 

> For year: =TEXT(TODAYQ,"YYYY") 

S.No. Functions Purpose 

1.  SUM(range) Gives the sum of a range 

2.  AVERAGE(range) Finds the average of a range 

3.  ODD(number) Returns the number rounded up to the nearest odd integer 

4.  I NT(number) Rounds a number to the nearest integer 

5.  Product(range): Multiplies the values in a range of cells 

6.  ROUND(number, num_digit) Rounds a number to the specified digits 

7.  EXP(number) Returns (natural logarithm) raised to the power of a number 

8.  SQRT(number) Returns a square root 

9.  POWER(number, power) Returns the result of a number raised to some power 

10.  MOD(number, divisor) Returns the remainder after a number is divided by the divisor 

FUNCTION LIBRARY 

There are many functions defined in Excel and it is beyond the capacity of a person to remember the name and 

functionality of each one of them. To overcome it, Excel has clubbed all the functions in the Function Library group of 

Learning 
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Figure 5.19:  Calculating GCD of Three Numbers 
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HiCL1 5:i7:  Using Math & Trig Function 
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Formulas Onto Ronmw Ye., 0 tori mesohtyoo Fin Fiurnn snort Pu9n L,yout 

Formulas tab. Here, the worksheet functions are categorised 

by their functionality, like Math and Trig, Text, Date & Time, 

etc. You can click a category to browse its functions. 

Let us discuss two common functions in the Math & Trig 

category: LCM and GCD. 

LCMO 

The LCM function returns the least common multiple of 

integers. The least common multiple is the smallest positive 

integer that is a multiple of all the numbers supplied as 

arguments. Let us use this function: 

> Open a new worksheet. 

> Enterthree integers in cells Al, A2, and A3. 

> Now, select the cell A4where the LCM of these numbers will be displayed. 

35 

1053 

Returns the inert common multiple. 

Numbec3 numbe,1numbei2... ore 150255 voluer for os-hillS jOu vc053 the 01St 
common moitpie, 

Formuto COcOS • 1050 

I I Concet J HItp Ott thu foflctbOfl 

Fonction Argumtnto 

1CM 

Figure 5.18: Calculating LCM of Three Numbers 

GCD() 

The GCD function calculates the greatest common divisor or highest common factor of two or more integers. The 

greatest common divisor is the largest positive integer that divides the numbers without a remainder. Let us 

calculate the GCD of three numbers. 

x Click on the Math & Trig drop-down button in the Function 

Library on the Formulas tab and choose LCM from the 

displayed list of options. 

The Function Arguments dialog box appears. Type the cell 

addresses in the respective text boxes, i.e., Al, A2, A3 in the 

Numberl, Number2, and Number3 text boxes, respectively. 

Note that the result of the formula appears nearthe bottom 

of the dialog box. 

> Click OK. The output will appear in the cellA4. 

Enterthree integers in cells Al, A2, and A3. 

Now, select the cell A4 where the GCD of these numbers 

will be displayed. 

Click on the Math & Trig drop-down button in the Function 

Library on the Formulas tab and choose GCD from the 

displayed list of options. 

> The Function Arguments dialog box appears. Type Al, A2, 

and A3 in Numberl, Number2, and Number3 text boxes, 

respectively. Observe that the result of the formula 

appears near the bottom of the dialog box. 



A2 100000 

A A B C 

( 
It occurs if the formula 
is used incorrectly. 

A4 1 / j SU(A1:A3) 

#NAME? Error 

A A  
1 4 

2 

3 3 
4 f#NAME" 

C D 

It occurs if the formula contains 
an invalid argument. 

> Click OK. The output will appear in the cellA4. 

E TIE INSERT FUNCTION 

The Insert Function is one of the options in the Function Library group that helps us in creating a formula. Let us 

explore this option. 

> Click on the cell in which you want to enter a formula. 

) Click the Insert Function button present on the Formulas tab. Or 

) Click on the Insert Function (fx) button present on the Formula bar. 

> Eitherofthesewilllaunch the Insert Function dialog box and an equal to sign (=)will be placed in the cell. 

> In the Insert Function dialog box, you can search for a function by typing a brief description of what you want to 

do in the Search for a function text box, in case you do not rememberthe name of the function. 

For example, "add numbers" returns Sum function. 

> In the Or select a category text box, you can select the category of the function, like Math & Trig for GCD 

function. If you are not familiar with the categories, you can select 'All', which will display an alphabetic list of all 

the functions in the Select a function list box. 

> Select the desired function from the displayed list and then click OK. 

) This will open the Function Arguments dialog box, wherein you will enter the cell references or values and then 

click OK to get the result of the selected function. 

FORMULA ERRORS 

In Microsoft Excel, if any formula is entered incorrectly, then Excel displays an error message rather than the proper 

value. It also assists you in identifying and fixing the problem. Some of the common errors along with their possible 

reasons are listed as follows: 

,- 
This error occurs if the column 
does not have enough space to 
accommodate the value. 

AA I 

A B 

=A-A?+A1 

C 0 

#VALUE Error 
4 #DIV/o! Error 

2 5 

3 Hi 

Figure 5.20: Some Common Errors in Excel Sheet 

A3 f. =A1/A2 

A B C 
1 4 

2 

3 

This error occurs if the number 
is divided by a zero or an 

empty cell. 

Learning 
Computers with  KIPS  <.  



2. In Absolute Referencing, the relative position of rows and columns changes where you copy a formula. 

Learning 
Computers with 

) Formulas are used to perform calculations involving addition, subtraction, division, and multiplication. It is an 

expression that can include cell addresses, numbers, arithmetic operators, and parenthesis. 

> The cell address in the formula is known as cell reference. There are three types of cell references: Relative, 

Absolute, and Mixed. 

> Circular reference occurs when a formula in a cell, refers to its own cell, directly or indirectly. 

> You can assign multiple cells to a formula by creating a reference or range. 

> Functions are pre-designed formulas in Excel to perform both simple and complex calculations. 

> The Insert Function is one of the options in the Function Library group, which helps us in creating a formula. 

> In Microsoft Excel, if any formula is entered incorrectly, then Excel displays an error message instead of the 

value and assists you in identifying and fixing the problem. 

SECTION -  A 

A. Fill in the blanks. 

1. Formulasareusedtoperform  

2. A formula always begins with an sign. 

3. The cell address in a formula is also called  

4. The cell address in a formula that does not change on copying, is considered as  

5. The addition of two or more text values is called  

6. are input to functions, which accept values as number ortext. 

7. Afunction must be followed by opening and closing  

8. The character is used for concentration of strings. 

Concatenation Parenthesis 

Calculations Arguments 

Equal to (=) Cell reference 

Absolute reference & 

1 Formulas must begin with a question mark(?). 



b. SUMO c. COUNTNUMBERSQ 
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3. A combined Reference is a type of cell reference. 

4. In Absolute Referencing, '$' sign is used before the cell co-ordinates. 

5. A range can be used in a formula. 

6. A Sheet tab cannot be renamed. 

7. The SUM function is used to find sum of values. 

8. The error#VALUE occurs if the number is divided bya zero. 

C. Application-based questions. 

1. A Sports teacher has measured the height of the students in a class. Saumya has been given the assignment 

to find the maximum and minimum height from the collected data. Suggest the function that she should 

use to accomplish the task. 

2. Ms Priya and her friends got a raise of 10% in their salaries. Find the total amount if their present salary is 

15,000. Calculate the salary by using the formula. 

SECTION  -  B 

A. Multiple-choice questions. 

1. To use the Sheet reference, which address is appropriate out of the following options? 

a. D4! Sheeti b. Sheetl, D4 c. Sheeti! D4 

2. Which key combination is used to get the sum of the values of the adjacent cells? 

a. Shift + S b.Ctrl+' c.AIt+= 

3. Which function finds the largest number in a range? 

a. Average () b. Count 0 c. Max () 

4. Which function returns the remainder after a number is divided by the divisor? 

a. MOD b. POWER 

5. Which of the given cell references can be used in a relative reference? 

c. SUM 

a. $D6 b.A3 c.A$1 

6. Which function is used to count the number of numeric values in a range? 

a. Count() 



B. Answerthefollowingquestions. 

1. What is a Formula? Explain with the help of an example. 

2. What is Cell Reference? Mention its types. 

3. Mention the two ways of entering a cell reference in a formula. Explain the difference between them. 

4. What do you know about Absolute Reference? Explain with the help of an example. 

5. Explain the utility of Function Library. 

6. Explain Circular Reference with the help of an example. 

7. What do you mean by Function? Name some of the Functions. 

8. What are the rules to enter a Function? 
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Perfection Through Practice 

For Concept Clarity GROUP DISCUSSION 

Using Creativity PROJECT WORK 

Using Formulae and Functions 

> Open Microsoft Excel. Type the contents in Excel worksheet as 

given in the image. 

A 

SALES IN FORMATION 
2 

> Save the worksheet using the Save option. Now, click on the cell 4 MW1Ih (32 (33 (34 Total 
5 

B7 and type theformula =B6*$B$17  and pressthe Enter key. 6 unitlod 3.592 _____ 4.390 3,192 4,789 

[7 Sales Revenue ________ 

> Click on the cell C7. Type the formula =C6*$B$17  and press 8 Costollales 

9 Gross Margin 

Enter. Similarly, calculate 'Sales Revenue' for Q3 and Q4. 10 salesforce Expense 9,000 6.000 9,000 10,000 
11 Advertising Expense 10.000 10,000 10,000 10,000 

> Click on the cell B8 and type the formula =B6*$B$18.  Press 
12 Overhead Expense 
i 

21,552 26,310 19,1.52 26,734 

Enter. Copy this formula in (8, D8, and E8. 
14 
s leo&ct c'ront 

16 

) Select the cell B9 and type the formula =B7 - B8. Press Enter. 40.00 
18 Product Cost 25.00 

Copy the formula to the cells C9, D9 and E9. 

> Select the cell B13, type =SUM (Bi O:B12) and press Enter. Similarly, calculate the 'Total Expenses' for Q2, Q3, 
andQ4. 

> To calculatethe profit, click on the cell B15 and type theformula =B9 - B13. Press Enter. Similarly, calculate the 

formula forQ2, Q3, and Q4. 

> Click on the cell F6 and type the formula =SUM (B6:E6). Press Enter. Copy the formula to rest of the cells, i.e., 

F7 to Fl 5. Save the file once again and close the application. 

Conduct a group discussion on the topic: Function and Formula 

Create a worksheet in which you would maintain your  Monthly Expenses on Stationery.  It must 

have the following headings: S.No., Commodity, Price, Quantity. Find the total for each heading by 

using the formulas learnt in this chapter. 

ONLINE LINKS Looking For More 

To know more about the Formulas and Functions in Excel 2016: 

https://support.office.com/en-us/article/Overview-of-formulas-in-Excel-201  6-for- 

Windbws-90703 1 ci -81 c4-4356-ae34-e774f85b9b2d 

I 



WORKSHEET 
Chapters 1-5 

A. Fill in the blanks. 

1. was the first interactive computer game. 

2. allows you to change Windows 10 into a touch-friendly interface called 'Tablet Mode'. 

3. is a ready-made button for defining hyperlink on a slide. 

4. extension is assigned to a recorded file. 

5. reference occurs when a formula in a cell refers to its own cell value directly or indirectly. 

IflIJ 
 - 

 Circular Action button Spacewar Continuum .wav 

B. StateTrue or False. 

1. You can drag and drop an app from one desktop to another in the Task View pane. 

2. Video clips can be added to a slide by selecting the Home tab. 

3. To enterormodify a formula in a cell, you can also press F2 key. 

4. In Absolute Reference, the hash(#) sign is added before the cell address. 

5. Today() is used to display the current date. 

C. Complete the following shortcut commands in Excel 2016. 

To select the entire worksheet Ctrl +   

To apply outline border around the selected cell 

 

Ctrl+ +7 

   

      

     

+ Enter 

 

To enter data in multiple lines in the same cell 

   

     

To get the total of the adjacent cells
-

Alt ~  

D. Identify and name the Animation category. 

1. Effects that decide the manner in which an object enters into a slide during the slide show. 

2. Effects that control the mannerin which an object exitsfrom the slide duringthe slide show. 

3. Effects that determine how the objects on the slide draw attention to themselves during the slide show. 

4. Effects that enable the objects to move from one position to another on a slide and on the specified path 

during the slide show. 

Learning 
Computers with  KIPS 



Learning 
Computers with  KIPS 

       

 

WORKSHEET 

   

    

    

    

  

Chapters 1-5 

    

      

A. Choose the best answer: 

1. The term software was first used by  

a. John McCarthy b. John W. Tukey c. John von Newmann 

2. The recorded sound files are saved with the extension  

a. .midi b. .wma c. .wav 

3. To remove the animation effect, click on the object and select in theAnimations group. 

a. None b. No Image c. Audio Tool 

4. Which function returns the remainder after a number is divided by the divisor? 

a. MOD b. POWER c. SUM 

B. Answer in one word. 

1. Name the translator program that converts a high level language program into 

machine language, line by line. 

2. Name the biometric security system for WindowlO that uses fingerprint, face, or iris 

recognition to sign-in to the system. 

3. What is the process of copying data from a CD/DVD to a computer known as? 

4. Which rule does Excel follow to evaluate the mathematical expressions? 

C. Answer the following questions. 

1. How is Assembly Language different from Machine Language? 

2. What is the utility of Windows Hello? 

3. What do you understand by Animation? How is it helpful in a presentation? 

4. What is Circular Reference? Give an example. 



I,t  r.w Cane, 

A,101.I 

Figure 6.1 The Opening Screen of Animate 

LOG ON TO ANIMATE CC 

LEARNING IN THIS CHAPTER 
' What is Animate? 

How to start Animate? 
E  The Animate Workspace 

v  Using the Tools Panel 

Frame by Frame Technique 

WHAT IS ANIMATE? 

Animate is a software package that allows the users to create interactive animations. Using Animate, one can combine 

images, audio, video, and other effects to create animations. Originally, it was designed to create animations to be 

displayed on web pages. Animate is now commonly used to create games, cartoons, websites, photo galleries, and 

much more. The animations and graphics created in Animate can be scaled to any size without compromising on the 

clarity or quality. 

HOWTO START? 

To start Animate, follow these steps: 

Click on the Start button> Adobe Animate CC. 

I. III 

Start Button Adobe Animate CC. 

The Adobe Animate ((welcome screen appears. 

The screen displays four panes: Open Recent Item, Create 

New, Introduction, and Learn. 

All the common tasks like creating a new document, opening 

recently used files, and using pre-built templates can be done 

usingthis screen. 

Under the Create New section, select Action Script 3.0. 

A new blank file will open in Animate window. 

THE ANIMATE WORKSPACE 

Opt. *b,*ul IU.rn •n'.i.. N.'* 0 kdz&,tulkw, 

oI_... 

MENU BAR:  The Menu bar contains controls for common functions and commands, such as opening, editing, and 

saving files, etc. 

THE STAGE:  This is the rectangular workspace area where you place your contents and create your drawings or 

movies. By default, the Stage size in Animate is 550 x 400 pixels. 
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Figure 6.2:  The Animate Workspace 

T1MELINE: The Timeline is a window atthe bottom of the Stage. It is divided into frames. 

It is the area where one controls the sequencing and timings of graphics and the other 

elements of a movie. 

You can also change the 

various properties of the 

Stage like Stage size, 

background colour, etc., 

by selecting the Modify> 

Document option. 

Ci...: 

FPS: 
Stage   

Câ 
1LY... 4. 

3S 4Q . 

P. Edt /,.. Mof T..t Connd. C.b Window H.p 

Tools Panel 
fe 

Sr:pt; CrQr;.---  -  

Q X 

c. 
T 

/ . 

0, 

Pubh 

- 

Properties 
Panel 

- 

Quick View 

The Ctrl + F3 shortcut key 
combination is used to 
enable the Properties 

panel. 

      

      

THE TOOLS PANEL:  It contains a set of tools to draw, paint, select, and modify objects 

in the workspace. 

THE PROPERTIES PANEL:  The Properties panel displays various properties of the 

selected object (text, symbol, image, or shape). It is generally used for changing the 

settings like Stage size, ruler unit, background colour of the Stage, and frame rate. It is 

also named as Property inspector. 

If the Properties panel is not visible, then you can select the Window > Properties 

option. 

    

Adobe 
Adobe Animate is a 

multimedia authoring 

and computer animation 

program developed by 

Adobe Systems. 

 

    

The Tools panel consists of many tools that help in drawing, colouring, and modifying an 

object. With the help of tools, we can create shapes like rectangle, circle, line, or any other 

object. Most of the Animate tools work similarto the tools present in Microsoft Paint. 

View section] 

  

x 
Tooh 0 

k :2$T .._/../ 
( Colors 

Section 

 

   

Option Section 
Tools Section 

Let's Know More 

To save the file, click on 

File > Save. Specify the 
file name and click on the 

Save button. The file will 

be saved with .fla 

extension. 

FigUre 6.3: The Tools Panel 
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THE DRAWING TOOLS $ T / E 0 0 ' -/ / . . 

Rectangle Tool Drawing Tools 

This tool is used to create square and rectangular shapes. This tool has an option that can be set to draw a rounded 

rectangle. 

> Select the Rectangle Tool . 

> Select the Stroke color, Fill color, 

Stroke size, Style, and Scale from the 

Property inspector. 

> Hold and drag the mouse pointer on 

the Stage. As the rectangular shape is 

created, release the left mouse 

button. 

)  To draw a rounded rectangle, specify 

the corner radius under the Rectangle 

Options section in the Properties 

panel. You can either specify the 

numeric value or use the Corner radius 

control slider to change the value for 

all the corners. 

   

Properties Panell 

Figure 6.4: Using the Rectangle Tool 

 

) Now, click and draw a rectangle on the Stage. You will get a rounded rectangle with the specified corner settings. 

NOTE 

If the chain symbolD, placed left to the Corner radius control slider is connected, you can lock the corner radius 
controls to one control, i.e., by setting the radius in one box, you can set the same radius for all the corners. If you want 
to specify different radius for each corner, unlock the chain symbol and enter a different numeric value in each box. 

> You can also draw other shapes like oval, polystar, etc., on the Stage by choosing the desired tool from the 

Tool box. 

> After drawing the rounded rectangle shape, you cannot modify the radius. However, Animate CC provides you 

with the Rectangle Primitive Tool to solve this problem. Likewise, using the Oval Primitive Tool you can 

modify the start angle, end angle, and inner radius on the oval. 

PolyStar Tool 

This tool is used to draw polygons or stars. 

> Select the PolyStar Tool  0 from the Toolbox. 

> In the Property Inspector, click on the Options button under the Tool Settings option. You will get the Tool 

Settings dialog box. Click on the drop-down list of Style option and select the Star style. 

) Enterthe value that rangesfrom 3 to 32 in the Number of Sidestext box. 

Learning 
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Figure 6.6: Property Inspector 

Figure 6.7: Drawing a Curve 

For the Star point size, 

enter the number 

between 0 and ito specify 

the depth of the star 

points. A number closer to 

0 creates deeper points. 

For drawing a polygon, 

you do not need to change 

these settings. 

) Click OK to close the Tool 

Settings dialog box. 

Let's Know More 

 

You can also select the 
Stroke Color and Fill Color 
from the Color section of 
the Tools panel. 

LTI e shortcut of the Oval 

Let's Know More 

TooI isO. 

 

 

Figure 6.5: Drawing a Star Using PolyStar Tool 

  

    

> Click and dragthe pointeron the Stage to draw a star. 

) Similarly, you can draw a polygon by selecting Polygon option in the Style text box. 

Line Tool 

The Line Tool works exactly the same way as the Line tool in any graphics software. 

We can use the Line tool to draw straight lines. 

> ClickontheLineTool •. 

> In the Property inspector, select the stroke color, line thickness, line style, or width 

profile as needed. 

) Move the pointer to the 

Stage. 

> Click and drag it in the 

direction where you want 

to draw a line. 

> Release the mouse 

button. You will get a line 

on the Stage. 

Curving 

You can turn a straight line 

into a curve with the Selection 

Tool . 

) After drawing a line, click 

on the Selection Tool . 

(Make sure the line is not 

selected). 

> Move the pointer on the 

line. When the pointer 

changes to arrow with 

Let's Know More 

You can also play your 

movie in a browser by 

clicking on the Control> 

Test Movie> In Browser. 

Quick View 

The shortcut for the Line 

Tool is N and Rectangle 

ToolRisR. 

You can view the Stage on 

the entire screen or a 

particular area of your 

drawing at high 

magnification. To do so, 

select the Zoom Tool 

from the Tools panel and 

click on the object. To 

switch between the Zoom 

in or Zoom out option, 

use the Enlarge•or 

Reduce modifiers 

displayed in bottom of 

the Tools Panel. 
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e Paint Fills 
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Paint Behind Allows you to paint blank area of the Stage leaving lines and fills 
unaffected 

Paint Normal Allows you to paint over lines and fills 

Allows you to fill an empty area leaving lines unaffected U 

Figure 6.8:  Using the Pen Tool 

       

U  S Smooth 

     

    

Straighten 

    

1 Ink 

 

         

          

               

            

            

 

Straighten 

  

Smooth 

   

Ink 

 

               

curve symbol ,click and dragthe line to draw a curve. 

> Release the mouse button when the curve is made. 

Pen Tool 

Although the tool symbol looks like an ordinary pen, it works in quite a bit different 

manner. This tool is used to draw precise paths in the form of straight lines or 

smooth flowing curves. You can also adjust the angle and length of the straight 

segments, and the slope of curved segments afterwards. 

)' Select the Pen Tool . 

> ClickontheStagetodefinetheanchorpointA. 

> Click to create the second anchor point B at a distance. 

(a) To complete an open path, double-click the last point. 

(b) To close a path, keep the Pen Tool over the first anchor point. A 

small circle appears next to the pen tip when it is placed correctly. 

Click to close the path. Animate automatically fills the path once it 

becomes a closed outline. 

Pencil Tool 

It is a freehand drawing tool. You can draw freeform lines and shapes in the same way as you would use a real pencil 

to draw any figure on the canvas. This tool has three different 

modifiers: Straighten, Smooth, and Ink. 

(a) Straighten: The default modifier is Straighten. It 

automatically straightens the line drawn by the Pencil Tool. 

(b) Smooth' Selectthis option to draw smooth, curved lines. 

(c) Ink: This option helps to draw freehand lines with no Figure 6.11:Three Modes of Pencil Tool 

modification. 

> Select the Pencil Tool and choose the desired option. 

> Select the stroke color, stroke height (thickness), style, and width profile from the Property inspector and draw 

the line. 

Brush Tool 

It can be used just like a brush on a canvas. You can paint any shape with the desired colour usingthe Brush Tool 

You can specify the brush mode, brush size, and brush shape modifiers that appear at the bottom of the toolbox 

when you select the Brush Tool. Using the Brush Mode modifier, you can choose to specify different areas to be 

painted using the Brush Tool. The various options available with Brush Tool are as follows: 

LJ 
Figure 6.9: Open Path Figure 6.10: To Close 

a Path 



Applies a new fill colour only to the selected filled areas - 

Allows you to paint only the fill areas and never allows 
to paint outside the lines - 

        

Paint Selection 

Paint Inside 

Kips Learning Pvt. Ltd 

 

Kips 
Learning 
Pvt. Ltd 

Quick View 

The shortcut for the 

Selection Tool us V. 
I 

Pt Li -J \L• 

Selection Tools 

Quick View 

While using Pencil Tool, 
press the Shift key 
to draw a straight 

horizontal or vertical line. 

Text Tool 

This tool is used to insert text on the Stage. You can set various text attributes like font 

family, style, and size when text is inserted. 

> Select the TextTool II. 
> Change the Font Family, Style, Size, and Colour, etc., from the Properties panel. 

) Move the mouse pointer on the Stage and start typing. 

) You can also create a fixed width text box for horizontal text. To do so, simply drag 

the Text tool to draw a rectangular area. As you type, the words are wrapped 

according to the width of the text box. 

Quick View 

The shortcut key to preview 

the animation is Ctrl + 

Enter. 

Figure 6.12:  Using Text Tool 

THE SELECTION TOOLS 

The four important tools used for making selection in Animate 

are Selection Tool, Lasso Tool, Polygon Tool, and Magic Wand. 

Selection Tool 

The Selection Tool is used to select a single or multiple objects on the Stage. There are 

different ways to select different portions of an object. 

> To select a stroke, fill, text block, or group, select the Selection Tool Q and click on 

the object. 

) To select a filled shape and its stroked outline, double-click the fill. 

You can also select the filled shape(s) and its outline(s) by dragging to enclose the 

object(s) within a rectangular selection marquee. 

Lasso Tool 

This is a free hand selection tool. We can use this tool to select irregular shaped areas of a 

drawing or part of an object. This tool has three options. 

In order to move the 

Stage to different position 

on the screen, select the 
Hand Tool from the 

Tools Panel and drag the 

Stage to the desired 

position. 

Let's Know More 
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::1 Polygon Tool I 

* Magic Wand L 

k 

Figure 6.14:  Using the Polygon Tool 

> Clickonthe LassoTool . 

> Move the pointeron the Stage area. It changes to Lasso shape. 

> Click and drag the Lasso Tool 

around the object to specify the 

boundary of the selection. End 

the selection approximately from 

where you started. 

) Release the mouse button and 

observe the selection. 

> Drag the selected anchor point 

(or anchor points) to create the 

desired path. 

Polygon Tool Figure 6.13: Using the Lasso Tool 

This tool also helps to make freehand selections, but its contour is made up of straight segments. 

> Click on the Polygon Tool 

> Move the pointer on the Stage and click 

once near the object. Click at the 

position where you want the first 

straight segmentto end. 

> Keep clicking to set the next end points 

of the subsequent segments until you 

reach your selection. 

> Close the selection by clicking near the 

starting point. 

Magic Wand Tool 

It is used to select the adjacent areas 

of a bitmap graphic that contains the 

same colours. 

> Click on the Magic Wand Tool . 

> Click on any part of the image. All 

the adjacent areas of the pixels 

having the same colour will be 

selected as shown in Figure 6.15. 

 

Figure 6.15: Using the Magic Wand Tool 
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Figure 6.18: Modifying the Shape Using Anchor Points 
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Subs election Tool 

This tool is used to select and move points of an 

object or edit paths between the adjacent points. 

> Select the Subselection Tool and click on the 

line or shape outline. This reveals the points and 

paths that form the shape. 

> When an anchor point is selected, it changes 

from a hollow dot to a solid dot. 

TRANSFORMING OBJECTS 
Figure 6.16:  Using the Subselection Tool 

In Animate, the Pen Tool provides different variants that can be used to add 

new anchor points between existing points, remove an anchor point, or 

convert a curve point to a corner point. These options help in transforming 

one shape to another. 

Let us understand it with the help of an example. 

> Select the PolyStar Tool from the Tools panel and draw a star on 

the stage. 

>  Choose the Pen Tool  6  and click on the star outline. It will display the 

various anchor points by which this shape has been formed. Figure 6.17:  Displaying Anchor Points 

> Click on the drop-down arrow present at the lower-right corner of the Pen Tool and select the Add Anchor Point 

Toolfrom the displayed list. A plus sign (+) appears next to the Pen Tool . Click at the position where you want 

to add an anchor point. 

>  Now, select the Subselection Tool and drag the different anchor points to modify the shape as shown in 

Figure 6.18. 

) You can convert a curve anchor point to a corner point with hard angles by selecting the Convert Anchor Point 

Tool from the variants of the Pen Tool and clicking on the desired point. However, if you want to convert a corner 

pointto a curved one, click and dragthe point. 



Don't Close Gaps 

o Close Small Gaps 

o Close Medium Gaps 

U Close Larae Gaps 

Paint Bucket Modifiers 

Figure 6.19:  Using Paint Bucket Tool 

* 

Figure 6.20: 
Using Ink Bottle Tool 

) The Pen Tool automatically turns into a modifier as you hover the mouse pointer over a path or an anchor 

point. 

> To delete an anchor point, select the Delete Anchor Point Tool and click on the point that you want to delete. 

THE COLOURING TOOLS 

Paint Bucket Tool Colouring Tools 

The Paint Bucket Tool is used to fill the enclosed 

areas of an object with colours, in a single click. This 

tool is also used to fill the areas that are not 

completely closed. You can change the colour of 

already painted areas with the help of this tool. It 

also provides modifiers that allow you to close gaps 

in shape outlines. 

To fill colour in an object, follow these steps: 

>  SelectthePaintBucketTool 

> Click on the Fill Color button The Color palette appears. You can also select the Fill Color option from the 

Properties panel. 

> Select any colour of your choice. Click on the drop-down arrow of the Gap Size modifier and choose a gap option 

to close the gap in the shape. 

> Click inside the object to fill it with colour. 

Ink Bottle Tool 

It is used to change the stroke color, width, and style of lines or shape outlines. 

>  SelectthelnkBottleTool. 

> Choose the stroke color, width, and style of line orshape outline in the Properties panel. 

)' Click on the line of the drawn object to apply a different property to the stroke. 

EraserTool 

This tool helps you to erase unwanted lines and fills 

of an object from the Stage. When you click on the 

Eraser tool, it displays three modifiers: Eraser 

Mode, Faucet, and Eraser Shape modifier. 

>  SelecttheEraserTool 

> Click on the Eraser Mode modifier and 

selectthe required eraser. 

> Click and drag it on the object to erase. Figure 6.21:  Using Eraser Tool 
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Figure 6.23: Using width Tool 

• Erase Norma? 

o Erase Fills 

Erase Lines 

.0. Erase Selected Fills 

Erase Inside 

Eraser 
Mode 

Faucet 
Modifier 

LJI 

Stroke Color 

NOTE 

To quickly delete everything from the Stage, just double-click on the Eraser 
Tool. 

The different Eraser Mode modifiers are as follows: 
Figure 6.22: Eraser Mode Modifiers 

0 

Erase Normal 

    

Erases all lines and fills of an object wherever the Eraser Tool is dragged 

  

      

Erase Fills 

    

Erases only the filled areas of an object while the outlines remain unaffected 

 

Erase Lines 

    

Erases only strokes without affecting the files 

        

Erase Selected Fills Helps in erasing fills of the selected part of an object without affecting the strokes 

 

Erase Inside 

    

Erases only the area of fill part of an object without affecting the strokes 

  

                                

                                

Width Tool 

This tool is used to decorate a stroke by adding multiple widths in it. The decorated stroke can be saved as Width 

Profile that can be applied to the other strokes. 

> DrawastrokeusingtheLineTool . 

> Select the Width Tool from the 

Tools Panel. 

> Drag and hover the mouse on the 

stroke. You will notice that the mouse 

pointerchangesto . sign. 

> Now, click on the Width Point that you 

want to move and drag the mouse 

pointer to the outward/inward 

direction. 

) Observe the change in stroke. 

FkI'N 3'( FRAME TECHiQUE 

Animations in Animate are created with the help of frames. 

Frames in Animate can be defined as the little rectangular cells, 

which appear on the Timeline. Frames are used to control and 

organise the content of your movie. Objects in the timeline are 

placed in the order as you want them to appear in the movie. 

Keyframes are the special types of frames where you can define 

change in the object for an animation like position, colour, 

shape, etc. 

Figure 6.24:  Drawing A Star 
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tLe,wt .r, . . I Keyframe Frame 

Quick View 

ANIMATING AN OBJECT 

Let us animate the starthat you have drawn across the stage. 

> Click on the keyframe dot in 

Layer_i. The animation will begin 

from this particularframe. 

> Now, select the second frame in the 

Timeline. 

> Click on the Insert > Timeline > 

Keyframe. This will insert a 

keyframe in Frame 2 with a copy of 

the star. 

> Using the Selection Tool, make a 

slight change in the position of the 

star towards the right side of the 

stage. Change its colour to orange 

using the Fill Color option. Figure 6.26: Inserting a Keyframe in Frame 5 Using F6 

> Click the third frame of the Timeline and press F6 to insert a keyframe in it. 

)' Shift the star slightly to the right side of the stage and change its colourto sky blue. 

> Click the fourth frame of the Timeline and press F6 again. 

> Shift the startowards right and change its colourto yellow. 

> Continue to insert keyframes by repeating the above-mentioned steps till you reach 

Learning 
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the tenth frame. 

In the Frame by Frame animation, you create the image in every frame. Let us add some 

art workforthe document: 

Figure 6.25: Inserting a Keyframe 

It is important to understand that 

each image drawn in Animate 

consists of a stroke (an outline) 

and/ora fill. 

> Selectanycotourchoicefromthe Quick View 

Stroke Color. The shortcut for the Ink 

> Select red colour from the Fill 
Bottle Tool is Sand for 

the Paint Bucket TooI 

Color box. isK. 

> Select the Polystar Tooland 

draw a star as explained 

previously while describing the 

Polystar Tool. 

DRAWING A STAR 

Faucet modifier helps to 

speed up erasing of lines 

and fihl 

Let's Know More 

I 

The shortcut key of the 

Brush Tool is B. 

L.yr 
LeyuFotd.e 

rime 

Btenk Keyf rime 

F5 

TinitIin 

Scene 

N,wSmbol_ Cut.F8 

1,'tn t.,.en 

Ce.te Teee. 

Cute Clssvc Iwein 

Let's Know More 

In order to animate the 

text, or add some special 

effects in it, you can break 

it apart into individual 

letters by clicking on the 

Modify > Break Apart 
option or pressing Ctrl + B 

key combination. 

Know the Fact 

Eyedropper Tool is used 

to copy the fill and stroke 

attributes from an object 

and use them on another 

object. 
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> Preview the animation by clicking on the Control > Test Movie> In Animate. 

4 
Play Enter 

Rewind 

Go To End 

Shdt,, 

Shift.. 

Step Forward One Frame 

Step Backward One Frame 

Step Forward To Ned Knyframe Alt.. 

Step Backward To Previous Kframe 

Test 

Alt., 

Ctd.Ente, 

Test Movie s' InAnimate 

Test Scene Ctd+AltrEnter In Beowstr 

Clear Publish Cache In AIR Debug Launcher (Desktop) 

Clear Publlh Cache and Test Movie 
In AIR Debug Launcher (Mobile) 

On Devicevia USB F 

Trmebne 

mop Playback 

F 

Play AU Scenes 

Enable Simple B*tons 

Mute Sounds Ct,t.AIt.M 

Figure 6.27: Animation Previewing Option 

Adobe Animate CC is a software package that allows the users to create interactive animations. 

The Stage is a rectangular workspace area where you place your contents, create drawings, or movies. 

The Timeline is a window at the bottom of the stage. It is divided into frames. It is the area where one controls 

the sequencing and timings of graphics and the other elements of a movie. 

The Tools Panel consists of many tools that help in drawing, colouring, and modifying an object. 

The Selection Tools are used to select a single or multiple objects on the stage. 

The Pencil Tool isafreehand drawingtool. 

The Ink Bottle Tool is used to change the colour, width, or style of the strokes. 

The Paint Bucket Tool is used to fill the enclosed areas of an object with a single-click. 

The EraserTool helps you to erase unwanted lines and fills of an object from the Stage. 

Frames are the little rectangular cells that appear on the Timeline and help in creating animations in 

Animate CC. 

>. 

>. 



BRAIN   

SECTION  - A 

A. Fill in the blanks. 

1. is the area where you create your drawings. 

2. is the area that is used to control the sequencing and timimg of graphics and the 

other elements of a movie. 

3. The tool is used to draw a star with five sides. 

4. The option can also be used to modify the document settings. 

5. is the default mode of the Pencil Tool when it is selected. 

6. Using tool, you can modifythe start and end angle of an oval. 

HINTS Modify> Document Stage - Timeline Oval Primitive PolyStar Straighten 

B. State True or False. 

1. The PolyStarTool is used to draw polygon and star shapes. 

2. The Text Tool is used to insert text on the Stage. 

3. To change the style of lines, select the Style option in the Properties panel. 

4. The Ink BottleTool is used to change thefill colour. 

5. The Shortcut keyfor Pencil Tool is P. 

6. To quickly delete everythingfrom the Stage, double-click on the EraserTool. 

C. Application-based questions. 

1. Sumit has to make a greeting card. He wants to draw flowers on it. Which tool should he use? 

2. Kartik has drawn a beautiful scenery. He wants to colour it but he does not know how to do it. Suggest the 
right option to do so. 

Computers with  
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SECTION - B 

Multiple-choice questions. 

Which of the following modifier of the Brush Tool allows you to paint the blank area of the stage, leaving lines, 
and fills unaffected? 

a. Paint Normal b. Paint Selection c. Paint Behind 

The function key is used to insert a keyframe. 

a.F5 b.F6 c.F7 

The tool is used to draw precise paths, straight lines, or smooth flowing curves. 

a. Pencil b. Brush c. Pen 

key combination is used to break apart the text into individual letters. 

a.Ctrl+B b.Ctrl+V c.Ctrl+G 

B. Write the function of the following tools briefly. 

1.  

2.  

3.  

C. nswer the following questions. 

1. What is Animate? What are the main parts of Animate working environment? 

2. What is the difference between Paint Bucket and Ink Bottle Tool? 

3. Name the three modes of Pencil Tool. 

4. What are the options of the Eraser Mode modifier? Explain any two briefly. 

A. 

2. 

4 



5. What are Keyframes? 

LAB SESSION Perfection Through Practice 

Follow the instructions to create the given scenery and animate the objects using Frame by Frame 

technique: 

> Select the Rectangle Tool. Choose Sky Blue as the Fill Color from 

the Property inspector and draw a rectangle on the top, depicting 

the sky. 

> Using Pencil Tool and white as the Stroke Color, draw the clouds 

as shown in the figure. Select the Paint Bucket Tool and fill color in 

the clouds. 

> Again select the PencilTooland drawthe hills, river, and the grass. 

Fill colours in them using the Paint Bucket Tool. 

> To draw Hut, Sun, and Boat, use the Drawing Tools. Fill colour in 

these objects using the Paint Bucket Tool. 

> After completing the drawing, click on the second frame in the Timeline and press F6 to insert a keyframe. 

> Select the Sun using the Selection Tool and move it a little to the 

right side. Likewise, select the boat and make a slight change in its 

position. 

> Click the third frame of the Timeline and press F6 again. 

> Shift the Sun and Boat a little more towards the right side of the 

Stage. 

> Repeat the steps and keep on adding new keyframes with slight 

change in the position of both the objects till they reach to the right 

most edge of the Stage. 

> Play the movie by pressing the Ctrl + Enter key combination. 

GROUP DISCUSSION For Concept Clarity 

Discuss the following topics with the students: 

> TypesofSelectionTools 

> Difference between Paint Bucket Tool and Ink Bottle Tool 
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WORKING WITH ANIMATE CC 

     

     

     

L:ARMNG IN THIS CHAPTER 

  

r Symbols and Animation 
How to create a Symbol? 

' Using Animation 
Create a Motion Tween 

 

r Shape Tween 
Motion Guide 

r Classic Motion Guide 
F  How to paint Stylish Strokes on the stage 

     

YMBOLS AND ANIMATION 

A symbol is a reusable object for static images or animation. It is either created in Animate with the help of drawing 

tools or imported from other sources. 

Animate stores symbols in its Library. When you place a symbol on the Stage, you create an instance of that symbol. 

Instance is a copy of the original symbol. The size, colour, shape, and position of an instance can be altered without 

affecting the original symbol. 

Symbols reduce the file size and simplify the editing process of a movie. If you modify the original symbol, it will 

change all the instances. There are mainly three types of symbols available in Animate. 

> Movie Clip > Button 

HOWTO CREATE A SYMBOL? 

To create a symbol, follow these steps: 

) Draw a train on the Stage, as shown in Figure 7.1, 

by usingthe Rectangle TooI ,Oval Tool , 

and PencilTool from theTools panel. 

> Choose the Selection Tool and drag the mouse 

pointer on the Stage to enclose the train within a 

rectangular selection marquee. 

) Choose Modify> Convert to Symbol. 

) Graphic 

Figure 7.1:  Drawing a Train 

You will get a Convert to Symbol dialog box. Choose Graphic from the Type drop-down list. 

)° Specify the symbol's name 

IConve to - 'G-Train' in the Name text 

box and click OK. Your new 

symbol is now added in the 
Mov, Ctip 

Library panel. 
-, 

Converting the Train object into a symbol 



Càk5  

I  Drag to create 
multiple 

instances of Quick View 

Let's Know More 

The Library panel is the 

store house of symbols 

from where these are used 

throughout the movie. 

>  F8 is the shortcut for 

Convert to Symbol 

option. 

) Ctrl+L is the shortcut 

to open the Library 

\ PaneI. 
I 

Let's Know More 

It is not always essential to 

draw an object for 

animation, as you can also 

use external images and 

bitmaps to create an 

animation. 

You can import any image 

into Animate by selecting 

File>lmport>lmport to 

Stage. 

The shortcut key to import 

an image is Ctrl + R. 

You can press Enter or 

select Control > Play 

option to play back or 

preview the animation. 

Select this portion 
and change colour 

Learning 
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Back Button 
Editing symbol 

Figure 7.4: Editing a symbol 

Fie 73: Creating multiple instances of a symbol 

An instance of the symbol appears on the Stage. You can create multiple instances of 

the same symbol by draggingthe symbol from the Library panel to the Stage. 

To make changes to the name, size, colour effects, or actions of a particular instance, 

select the instance and open the Property inspector on the right side. Any change 

that you make, affects only the instance and not the symbol. 

You can also make changes directly to the symbol within the Library panel. Right 

click on the symbol's name in the Library panel and select the Edit option from the 

Context menu or double-click the symbol's icon in the Library panel or on the Stage. 

The Symbol Editing window will open. Select the front part of the train using the 

Selection Tool and change its colour to Orange. Note that the changes made directly 

to a symbol are applied to all instances of that symbol. After making the desired 

changes, exit from the symbol's Edit mode by clicking on Scene 1 or the Back button 

present on the Edit barabove the stage. 

Let's Know More 

The Control > Test Movie> 

In Animate creates a Small 

Web Format (SWF) file at 

the same location, which 

can be directly played 

using the Adobe Flash 

Player software. It works 

similar to the option 

Control > Test Movie> 

Test option. 

Notice that the Train 

symbol appears 

enclosed inside a blue 

bounding box with a 

small hollow circle in 

the middle. 

Click on the Library 

panel tab to view the 

symbol and its name. 



Figure 7.6: Creating Motion Tween 

USING ANIMATION 

When a series of images is displayed in a rapid sequence at a fixed interval of time, an illusion of movement is 

created. This illusion of movement created by quick transition of images is termed as animation. The animations can 

be created in Animate with the help of tweening, which means 'in between'. The movement from one keyframe to 

the other becomes convenient with the use of the tweening. Animate provides three types of tweened animation. 

Motion Tween Shape Tween Classic Tween 

The main difference between these types of tweenings is that the Motion and Classic tweening works on symbols, 

whereas, Shape tweening is used with the objects that are not symbols and are ungrouped. 

CREATE A MOTION TWEEN 

We create a motion tween by specifying the starting and ending position of an object in keyframes and Animate 

automatically fills the in between frames for creating an animation. To apply motion tween, it is important to 

convert an object into a symbol. This 

tween is best suited for creating 

movement, size, and rotation changes. 

To create a motion tween, drag the 

graphic symbol 'G-Train' from the 

Library panel to the Stage to apply an 

animation effect on it. 

In the Timeline, double-click the 

Layer 1 title and type the Layer Name 

'Moving-Train' and press the Enter key. 

Now, the symbol is in the Frame 1 of 

the 'Moving-Train' layer.
Figure 7.5: Changing Layer Name 

Right-click on Frame 1 and select the Create Motion Tween option from the Context menu. 

A blue coloured span of 24 frames 

appears on the Timeline and the 

layer gets converted to a tween 

layer. 

Bring the mouse pointer to the right 

end of the blue coloured bar. A 

double headed arrow +-~ appears. 

Drag the arrow to move the 

playhead to Frame 40. Move the 

train to the left side of the stage. A 

new keyframe will be created 

automatically at Frame 40. You will 

observe that a green coloured 
1 

'p  
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'motion path' is created and the 

Train symbol will follow this path. 

> Press Ctrl + Enter or select Control 

> Test Movie> In Animate to view 

the effects of motion tween. 

2 SHAPE TWEEN 

Shape tweening is used to transform 

the shape of an object into another. It 

does not work if the object is 

converted into a symbol or is grouped. 

You can create a wonderful morphing 

effect by using the shape tween. 

Suppose, you have a circle and want to 

make it appear to be changing into a 

star. In this case, you need two shapes, 

namely a circle and star, to be drawn in 

different frames at different points on 

the Timeline. Let us try this by 

following the given steps: 

Select the Stroke Color blue and 

Fill Color yellow. Draw a circle in 

the first keyframe of the Timeline. 

Do not convert it into a Symbol. 

Learning Kips Computers with 
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Figure 7.7:  Previewing the Motion Tween Animation 

Figure 7.8:  Drawing a Circle and Inserting Keyframe 

Figure 7.10: Selecting Shape Tween 

a 

Figure 7.9:  Drawing a Star in Keyframe 45 



Figure 7.11: 
Playing the Shape tween Animation 

Let's Know More 

A tween layer is a layer 

that contains one or more 

motion tween spans, static 

frames, and blank 

keyframes. 

Let's Know More 

You can view all the 

frames created between 

the starting and ending 

keyframe of the Tweened 

animation by using the 

Onion Skin feature. 

There are two types of 

Onion skins. 

The Onion Skin option 

displays frames in full 

colour, whereas with the 

Onion Skin Outlines 

option, you can view the 

outline of the object in 

the frames. 

Know the Fact 

Morphing refers to the 

special effects in 

animation that tranforms 

one shape into another 

shape through a 

seamless transition. 

Quick View 

You can also group 

multiple objects. To do 

so, select the object and 

click on Modify > Group 

or press Ctrl + G key 

combination. 

Let's Know More 

Motion tween animates 

3D objects, whereas 

Classic tween cannot 

animate 3D objects. 

Learning 
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> Select Frame 45 and insert keyframe by selecting the Insert > Timeline > 

Keyframe option. 

> While keeping playhead on Frame 45, delete 

the circle object from your working area and 

draw a star shape as shown in Figure 10.9. 

> Select Frame 1 and choose the Insert> Create 

Shape Tween option. A green shaded area 

with a solid arrow will appear between these 

two keyframes. 

> Press (tn + Enter or select Control > Test 

Movie> In Animate to play the movie and view the shape tween effect. 

2 CLASSIC TWEEN 

Classic tween is an alternative way of creating an animation in Animate. While Motion 

tween Animate automatically fills the frames between the specified starting and ending 

points, in Classic Tween we have to manually create all the keyframes and connect all of 

them to create an animation. 

) To create a Classic Tween, open a file that contains 'G-Train' symbol. 

) Copy the G-Train symbol and paste it in a new file. 

> You will notice the symbol is in the Frame 1 of the Layer_i. 

> Move the train to the right-side of the stage. 

) Select the Frame 40 and insert a keyframe by selecting the Insert > Timeline > 

Keyframe option. 

)' On Frame 40, move the train to the left-side of the Stage. 

> Select Frame 1 and choose the Insert > Create Classic Tween. A purple-shaded area 

with a solid arrow will appear between these two keyframes. 

> Press Ctrl + Enter or select Control > Test Movie > In Animate to view the Classic 

Tween effect. 

Figure 7.12: Creating Classic Tween 



Figure 7.13 Drawing an Airplane 
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Figure 7.1: Creating Motion Tween in 
the L-Airplane Layer 
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MOTION GUIDE 

When you visit an unknown place, you do not know which path 

to follow to reach your destination. So, it is better to take the 

help of a guide who knows the route. He will take you to your 

destination. Similarly, Animate provides you with the ability to 

create a motion guide that defines the path of the movement 

for an object. Instead of having an object move from one point 

to another in a straight path, you can make it follow an arbitrary 

path that you draw, i.e., a motion guide. 

Let us see how a motion guide is used: 

Select the Pencil Tool and set the Pencil Mode to 

'Smooth' from the bottom of the Tools panel. Draw an 

airplane as shown in Figure 7.13 and fill colour in its various parts using the Paint Bucket Tool . 

Convert it into a symbol, by selecting the Modify > Convert to 

Symbol option. 

In the Convert to Symbol dialog box, enter the name 'Airplane' in 

the Name text box and select the Graphic option from the Type 

drop-down list. 

Fcnjrn : Drawing a Path in a New Layer 

> Choose the Selection Tool and double click on the path to select 

it. Now, select Edit > Cut to remove the path from the Stage 

temporarily. 

Click on the layer L-Airplane. Right-click on Frame 1 and choose 

Create Motion Tween option from the Context menu. A blue 

coloured span of frames appears. 

Figure 7.14: Converting the Airplane into Symbol 

> Now, double-click on Layer_i and rename it as 

'L-Airplane'. 

Select Insert > Timeline> Layer to create a new 

layer on the Timeline. Rename this layer as 

'Motion-Airplane'. 

Select the Pencil Tool from the Tools panel and 

select a Stroke colour from the Properties panel 

on the right. Draw a path on the Stage, that the 

object will follow while in motion. 



> Drag the playhead to Frame 40. 
Playhead is represented 

by a red vertical line in the 

Timeline window. 

> Press Ctrl + Enter or select Control > Test Movie> In Animate from the Menu bar to  's. - 

test the Animation. The Airplane follows the path that you have created. 

Figure 7.18: Playing the Animation Figure 7.17:  Converting to Motion Path 

> Choose Edit> Paste in Place to paste the path in this layer. The path automatically gets 

converted to a 'motion path' and the Airplane symbol itself snaps to the path. 
Let's Know More 

CLASSIC MOTION GUIDE 

Classic Motion Guide is yet another way to create a motion guide that defines a random 

path, which the object should follow, while in motion. To make use of this option: 

> Select the Rectangle Tool  El and draw a rounded rectangle shaped track as shown 

in Figure 7.19. Rename the Layer_i to 'Racing Track'. 

) Insert another layer by selecting the Insert> Timeline> Layer. Rename the Layer_2 as 

'Racing Car'. 

> Draw a car as shown in Figure 7.19, by using various tools from the Tools panel. 

> Convert the car to a graphic 

symbol and place it on the 

track using the Selection 

TooI. 

> Insert another layer by 

selecting the Insert > 

Timeline> Layer and rename 

itto 'Path'. 

> Select Frame 80 in all the 

layers together, right-click 

and choose the Insert Frame 

option. 

The Property inspector in 

Animate displays all the 

information regarding the 

object that is selected, i.e., 

setting of the current 

document, symbol, text, 

shape, bitmap, group, 

frame, video, or tool. 

Know the Fact 
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Figure 7.19:  Drawing Racing Car and Track 

Let's Know More 

Motion path is a line that 

represents the movement 

of the instance. The dots 

on the motion path 

represent the different 

positions of the object 

along the path in different 

frames on the Timeline. 

Let's Know More 

While using motion guide, 

if you want to rotate the 

symbol to match the 

direction of the path, 

select Frame 1 and click on 

the Orient to path check 

box under the Rotation 

section in the Property 

inspector. 

Let's Know More 

You can remove a 

keyframe by right-clicking 

on the frame and selecting 

the Clear Keyframe 

option. 
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Figure 7.20:  Creating Path of Racing Car 

Select the car and the Track layer and insert a 

keyframe at Frame 80 by right-clicking and 

selecting the Insert Keyframe option. 

Now, select the Path layer. Choose Pencil Tool 

from the Tools panel and draw a path on 

the track. 

Select Frame 1 of the 'Racing Car' layer. 

Choose Selection Tool and position the car at 

the beginning of the circular path. 

Select Frame 80 of the same layer and drag the 

carto the end point of the path. 

Right-click on a frame between Frame 1 and 

Frame 80 and select the Create Classic Tween 

option from the Context menu. 

Right click on the 'Path'layer and selectthe Guide option. 

Drag the 'Racing Car' layer onto the 'Path' layer and vice versa. You will see that the Path layer changes to a Guide 

Layerindicatedwitha symbol. 

Select a Frame on the Racing Car layer, go to Properties panel and select the Orient to path checkbox to rotate 

the car on the path. 

Press Ctrl + Enter or select the Control > Test Movie> In Animate to play the animation. 
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Figure 7.21: Properties panel Figure 7.22:  Playing Animation 

HOW TO PAINT STYLISH STROKES ON THE STAGE 

Animate CC provides you a new tool that enables you to get creative. This tool has symmetry brushesç which allows 

'.you to draw cool symmetrical interesting textures, patterns, and drawings. 
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Figure 7.24:  Creating a Brush Stroke 

'PAINT BRUSH TOOL 

This tool is used to draw stylish brush strokes. These brush strokes can be applied on the existing objects, or you can 

use it to draw any path on the stage. 

> ClickonthePaintBrushTool . 

> In the Property inspector, type in the 

Stroke size '10'. 

> Click on the Brush Library icon N. 

)' The Brush Library appears on the Animate 

window. 

) Select any brush from the displayed 

options and double-click on it. 

) The selected brush will appear in the Style option. Figure 7.23: Paint Brush Tool 

> Now, click and drag the mouse in the direction where you want to draw it. 

> Release the mouse button and observe. 

HOW TO MAKE YOUR OWN BRUSH STROKE 

Animate CC allows you to save any shape as 

stroke. To do so,followthe given steps: 

) Select the Pencil Tool from the Tools 

panel and set Pencil Mode to 'Smooth'. 

Draw a flower as shown in Figure 7.24 and 

fill colour in it using the Paint Bucket 

Tool . 

) Choose the Selection Tool and drag the 

mouse pointer to select the flower. 

) Click on the Create New Paint brush from 

selection icon present next to the pencil symbol in the Style option on the 

Property inspector. 

> The Paint Brush Options dialog box appears as shown in Figure 7.25. 

) Select the type of brush from the Type drop-down list. Enter the name 'Flower' 

in the Name text box. 

) Select Scale proportionately radio button and customise the other settings as 

peryour need. Click on Add button. 

> Select the Line Tool from the Tools panel. You will notice the saved brush stroke 

in the Style option list. 

> Now, click and drag the line on the stage. Automatically, the flower will be 

drawn. 
Figure 7.25: Paint Brush Dialog Box 
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RECAP 
) A symbol isa reusable object for static images oranimation. 

> In Animate, the movement from one keyframe to the other becomes convenient with the use of the Tweening 

method. 

> Shape tweening is used to change the shape of one object into another. 

> Motion Guide defines the path forthe movement of an object. 

) Classic Motion Guide is a way to create a motion guide that defines a random path that should be followed by the 

object, while in motion. 

) Morphing refers to the special effects in animation that transform one shape into another through a seamless 

transition. 

) Paint Brush Tool is used to draw stylish brush strokes. 

BRAIN   

SECTION  - A 

A. Fill in the blanks. 

1. A isa reusable object for static images or animation. 

2. Thereare typesof symbols. 

3. refers to special effects in animation that transforms one shape into another shape. 

4. The shortcut to convert any object into symbol is  

5. In Animate, a set of Paint Brushes called  are available by default. 

HINTS Brush Library Morphing . Symbol Three F8 

B. State True or False. 

1. We can create only one instance of a symbol. 

2. Motion Tweening works on symbols. 

3. Shape Tween works if the object is converted into symbol. 

4. The Property Inspector in Animate displays all the attributes regarding the object that is selected. 

5. We cannot editthe Properties of graphic symbol. 

Computers with  KIPS  13 Learning 
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pplication-based questions. 

Feroz wants to create an animation in which he would show a smiling face change into a crying face. Which 

tweened animation should he use to get the desired result? 

2. Bhoomi has learnt Animate in school. While practising at home she has drawn a beautiful scene of a cloudy 

day. She wants to show the movement of clouds in the sky, but does not remember the option that can 

perform this action. Help her select the correct option to accomplish the task. 

SECTION  -  B 

A. Multiple-choice questions. 

1. is the shortcut key to open the Library dialog box. 

a.Ctrl+M b.Ctrl+L c.Ctrl+D 

2. To preview the animation effect, press key combination. 

a. Ctrl+Shift b. Ctrl~ Enter c. Ctrl+Alt 

3. defines the path of the movementforan object. 

a. Motion Tween b. Shape Tween c. Motion Guide 

4. is represented by a red vertical line in the Timeline window. 

a. Frame b. Playhead c. Keyframe 

5. option displays only the outline of the object in the frames. 

a. Onion skin b. Onion Skin Outlines c. Edit 

B. Answer the following questions. 

1. What are symbols? Name the duff erent types of symbols. 
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2. Def me the term instance. 

3. What do you understand by the term Animation? 

4. What is the utility of Motion Guide? 

5. How do you convert an object into a symbol? Explain briefly. 

6. What is Tweening? List the types of Tweening. 

7. Explain the use of Paint Brush Tool. 



A. Draw a polygon shape and a star with 5 sides. Fill the 

polygon with red colour and the star with yellow colour. 

Animate these objects using Shape Tweening. 

B. Draw a few flowers, a butterfly, and the sun using the Oval and 

Pen tool. Animate the sun using Motion Tween, and the 

butterfly using Motion Guide Tween. 

LAB SESSION Perfection Through Practice 

a 

Looking For More ONLINE LINK 

To know more about Animate, visit the website: 

https://helpx.adobe.com/animate/using/documents.html  
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INTRODUCING PYTHON 

LEARNING IN THIS CHAPTER 

r Introduction to Python 

' Installing Python 

r Components of Python Window 

   

   

 

r  Variables in Python 

r  Working in Script Mode 

' Data types 

Basic data types in Python 

r  lnput() Function 

    

    

Have you ever tried making pasta on your own? Figure 8.1 shows a recipe to make Tomato Pasta. It solves the 

problem of "how to make Tomato Pasta?" The recipe is a set of instructions on what to do, how to do, and when to 

do it. The set of instructions uses ingredients (inputs) to make Tomato Pasta (output). 

RECIPE FOR TOMATO PASTA 

List of required ingredients: 

500 ml water 

150 gram pasta 

1 spoon olive oil 

1 large chopped onion 

300 gram chopped tomatoes 

100 gram hummus 

Instructions to make Tomato Pasta: 

1. Boil water in a large pan. 

2. Add pasta to the boiling water. 

3. Simmerfor 10 minutes. 

4. Strainandcool. 

5. Add olive oil in a pan. 

6. Addtheonionsandfrygently. 

7. Stirin the tomatoes and the hummus. 

8. Leavetosimmerfor5 minutes. 

9. Add the pasta and mix. Serve hot. 

Figure 8.1:  Making Tomato Pasta 

Adding all the required ingredients to the recipe is input. Simmering the ingredients is processing, and the product 

that you get after processing is output, which in our case is pasta. 

Likewise, a computer also works in three stages. To get the work done on a computer, you enter the raw data 

(input), a computer operates on this data (processing), and the desired result is obtained (output). 

Input Process * Output 

To get the desired output from the computer, you key in instructions to the computer using different programming 

languages. There are some specific computer languages, which are used to write programs. Some of the popular 

examples of Programming languages are Python, C, C++, LISP, Pascal, Java, PH P, etc. 

Modern computers follow the set of operations called programs. In simple words, a program is a sequence of 

instructions that specifies how to perform a computation. These programs help a computer to perform wide range 

of tasks. 

In this chapter, you will learn the basics of Python programming language, which is one of the most powerful, 

high-level programming languages. 

Learning
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Figure 8.2: Downloading Python 
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INTRODUCTION TO PYTHON 

Python is a simple Programming language that is used to write codes for the computer 

programs. Python was created by Guido Van Rossum when he was working at Centrum 

Wiskunde & Informatica (CWI), which is a National Research Institute for Mathematics and 

Computer Science in Netherlands. The language was released in 1991. 

Python is a high-level programming language. 

Some of the features that make Python so popularare as follows: 

> It is an easyto learn general-purpose programming language. 

> It is a platform independent programming language, which means it can be used on any machine and in any 

operating system. 

> Ithasasimplesyntax. 

> Python is a case-sensitive language. 

> It is an interpreted language. 

> It is free to use and even free for commercial products. 

APPLICATIONS! PYTHON PROGRAMMING 

Python isa popularand easy to learn language. It can be used to: 

> Buildawebsite 

> Develop games 

) Program robots 

> Perform scientific computations 

) Develop artificial intelligence applications 

INSTALLING PYTHON 

Python can be easily installed on your computer by following the given steps: 

1. Obtain a Python Distribution:  You can download Python distributes from: 

www.python.org/download. Forthis chapter, we have used Python 3.7.4. 

P33ron 3; ,Iccu,pujnnnlm,nheceumantuwaassu.ospyrbo.;37 flw3tho.. 3 7rt3tbenVMIe4e. D:UJ1cOctc3t5t4wk3bca 



2. Python Installation Process 

After downloading the Python distribution, all you need to do is, to execute it. Double-click the downloaded installer 

software. Click on Run in the Dialog box, and the installation process starts. Keep following the instructions and 

clicking on the Next button until you see the highlighted Finish button. 

After you have installed Python, the IDLE screen looks like this: 

Ede 94 Qd,ug  9p6cn; .,dQw $dp  

Python 3.7.4 (tags/v3.7.4:e09359112e, Jul 8 2019, 19:29 
:22) [MSC v.1916 32 bit (Intel)] on win32 
Type "help", "copyright", "credits" or "licenseQ" for m 
ore information.I 
>>> 
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Figure 8.3:  Python 3.7.4 Shell Window 

On Windows machines, the Python installation is usually placed in C:\Python  3.7.4 folder, though you can change this 

when you are runningthe installer. 

COMPONENTS OF PYTHON WINDOW 

Just like any other application window, Python window has the following components: 

Ba  
Menu Bar 

Python 3.7.4 (tags/v3.7.4:e09359112e, Jul 8 2019, 19:29 
:22) [MSC v.1916 32 bit (Intel)] on w1n32 
Type "help", "copyright", "credits" or "licenseO" for m 
ore inforrnation.I 

Scipt Area)> 

L2 (c72 

Figure 8.4:  Components of Python Window 

Title Bar 

This is the area that displays the name of the application and the document. It also contains 

command buttons like minimize, maximize, restore, and close. 

Menu Bar 

The menu bar consists of various menus with different options. The common menus you 

working with in this chapter are File, Edit, Shell, Debug, Options, Window, and Help. 

Working with File Menu 

This menu is used to work with the options related to the currently used file. It 

includes sub-options like opening a new file, opening an existing file, viewing 

recently used files, saving the files, closing the files, and exiting the application. 

Working with Edit Menu 

This menu is generally used to edit the file in use. You can cut, copy, or paste the 

selected text. You can also search for a particulartext or phrase, and even replace it Figure 8.6: Edit Menu 

with some other text. 
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will be 

Figure 8.5: FIle Menu 
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A high-level language is a 

computer language that 

uses letters, numbers, and 

special symbols for 

coding. It is a user-friendly 

and interactive type of 

language. For example, 

c++, Python, Java, etc. 

Let's Know More 
 J, 

Syntax refers to the 
grammatical rules to be 

followed while writing a 

program in any language. 

Let's Recall 

Let's Know More 

PySoy is a 3D game engine 
that supports Python- 

based games. 

Working with Help Menu 

To get help related to any topic of Python, press Fl key or click on 

the Help menu. 

Script Area: This is the area where you type your code. 

Status Bar: The Status Bar tells you the current status of your 

control/cursor on the window. 

After installing Python, you are readyto work on it. You can work in Python in two ways: 

> In Interactive mode 

> In Script Mode 

Python Programming in Interactive Mode 

In the Interactive mode of Python, the instructions are executed, line by line, giving the 

output. 

In this mode, the commands are typed next to the Python Command prompt (>>>). For 

example, if you type 3 + 6 next to the Python Prompt, it will give you the result as 9. 

To work in the Interactive mode, follow the process given: 

)' Click on the Start button> scroll down to Python 3.7> IDLE(Python 3.7). It will open 

the Python Shell window where you will see the Python prompt (>>>). 

P 
Lilt Ldit Shell ebug ptions window hetp 

Python 3.7.4 (tags/v3.7.4:e09359112e, Jul 8 2019, 19:29 
:22) [MSC v.1916 32 bit (Intel)] on win32 
Type "help", "copyright", "credits" or fhicenseOtt  for m 
ore information.I 
>>> 

Lnl CoL72 

Figure 8.8: Python Shell Window 

> Type the following commands next to Python prompt and Python will immediately 

give the output as shown in Figure 8.9. 

to python world' 

'a i. o '- "* 
Python 3.7.4 (tags/v3.7.4:e09359112e, Jul 8 2019, 
v.1916 32 bit (Intel)) on uin32 
Type "help", "copyright", "credits" or "licenseU" 
ation. 
>>> 'welcome to python world' 
'welcome to python world' 
>>> 10 
10 
>>> 12.79 
12.78 
>>> 'A' 
'A' 
>>> 10<5 
False 
>>> 10+20 
30 

19:29:22) tMSC 

for more inform 

 

 

 

    

    

FIgure 8.9: Interactive Mode 

Help )"Help MenuL 

About IDLE 

IDLE Help 

Python Docs Fl 

Turtle Demo 

Figure 8.7: Help Menu 

>>> 'welcome 

>>>10 

>>>12 .78 

>>> 'A' 

>>>10<5 

>>>10+20 
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Use of Interpreter 

In the interactive mode of Python, the commands are executed line by line. When you 

type a command next to the python prompt (>>>) and press the Enter key, the 

interpreter converts the command into machine language. After processing, the 

interpreteragain converts the machine code into human readable form (output). 

Using print() function 

The print() function is used to display the output of any command on the screen. It can 

also be used to print the specified messages. 

For example: 

>>>print ("Hello World")willdisplay Hello World 

F, I : D* Op. 4,6e.. K,p
- - 

Python 3.7.4 (tags/v3.7.4:e09359112e, Jul 8 2019, 19:29:22) [MSC v.1916 32 bit 
(Intel)] on win32 
T •e "hel.", "co. ri.ht", "credits" or "license()" for more information. 
>>> print ("He lii W rid") 
Hello World 
>>> I 

LnS CoI-4 

Figure 8.10: Using print() function 

Python is a case-sensitive programing language. It means that Python differentiates 

between capital and small letters. For example, Print (P capital) and print (p small) 

are two different things for Python, where print is a valid command in Python, while 

Print is just a word and not a command. 

You can also pass more than one argument to the print Qfunction. In such a case, the 

arguments are separated by commas as shown in Figure 8.11. 

Figure 8.11: Separated Arguments by Commas 

Let's Know More 

The Python Integrated 
Development and 

Learning Environment 

(IDLE) executes 

instructions, one line at a 

time. 

. O..g Optio.. W.d.., H, 

Python 3.7.4 (tags/v3.7.4:e09359112e, Jul 8 2019, 19:29:22) EMSC v.1916 32 bit 
(Intel)) on win32 
Type "help", "copyriqht", "credits" or "licenseQ" for more information. 
>>> print (' Python i.s a high level language', It has easy syntax') 
Python is a high level language It has easy syntax 
>>> print('10+56=', 10+56) 
10+56= 66 
>>> print(10850+30*2/10=, 10*8_50+30*2/10) 
10*8_50~30*2/10= 36.0 
>>> print('5 plus 5 ',5+5, 'and 5 into 5 ', 5*5) 
5 plus 5 = 10 and 5 into 5 = 25 
>>> I 

C.4 

Let's Know More 

python 

Python 3.5 or advanced 
version cannot be used on 

Windows XP or earlier 
versions of Windows. 

NOTE  

Interactive mode is beneficial for testing code where you type the commands, one at a 

time, and get the result or error immediately. 

Let's Recall 

You can press Fl key to 

use Python Help. 
I 



Using IDLE as a calculator 

To evaluate an arithmetic expression, it is not necessary to use the print() function. If you type an arithmetic 

expression at the Python prompt and press the Enter key, the interpreter automatically evaluates it and shows the 

result. In this case, the interpreter acts as a simple calculator. The expressions are evaluated using operators like +, —, 

,/, etc. The basic BODMAS rules are followed forperformingcalculations. Forexample: 

p 
File Edit Shell Debug Options Window 14e1p  

Python 3.7.4 (tags/v3.7.4:e09359112e, Jul 8 2019, 19:29:22) [MSC v.1916 32 bit 
(Intel)) on w1n32 
Type "help", "copyright", "credits" or "license 0"  for more information. 
>>> 10+20 
30 
>>> 45/6 
7.5 
>>> 67//8 
8 
>>> 45*77 

3541.5 

I>>> I 

Lstl1 Cobi 

Figure 8.12: IDLE as a calculator 

In IDLE, you can press Alt+P to repeat the previous command. 

tPRACTICE TIME 

  

   

i. Type the following expressions, one by one, next to the Python prompt and note down the output in the table 

given below: 

SNo. Expression Result 

1.  23*98 

2.  (100+58)/3 

ii. Write the statement next to the Python prompt using print ( ) function to get the following output: 

a. Python works in two modes: Interactive mode and Script mode. 

b. Interpreter is a language processor. 

VARIABLES IN PYTHON 

If you need to store some food for future use, what will you require? Well, you will need a container to store the food. 

Similarly, when you are working with the values in Python, you require some storage to hold values for later use. 

Such storage locations are known as variables. A variable can store only one data value at a time. When a new value is 

stored in a variable, its previous value gets overwritten. 

Learning 
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The Assignment Operator (=) 

Values are assigned to variables using assignment operator (=). For example, the statement x=25 assigns the value 

25 to the variable x. 

Observe the following codes to understand the use of assignment operators: 

a=10 #Value lOis assigned to the variable a 

b=20 #Value 20 is assigned to the variable b 

c=a+b #The numbers are added and the value is assigned to the variable c, i.e., 30 is assigned to the variable c. 

a=c-10 #Value 20(30-10) is assigned to the variable a. So, nowthe value of the variable a is 20, and not 10. 

Rules to write the variable names 

There are certain rules in Python which have to be followed to form valid variable names. The rules for valid 

identifier(variable name) are: 

A variable name must start with an alphabet (capital or small) oran underscore(_). 

> Avariable name can consist of alphabets, digits, and underscore. No othercharacteris allowed. 

)' APythonkeywordcannotbeusedasavariablename. 

) Avariablenamecanbeofanylength. 

> Variable names are case-sensitive (e.g., Age and age are differentvariable names). 

Examples of some valid variable names are: 

Class, emp code, totsalary, minvalue, bal fee, age1980, a45r 

Following are examples of some invalid variable names: 

Variable Name Reason 

Employee code Space is not allowed in a variable name. 

lOcode Variable name cannot start with a digit. 

A. B. C. Ltd . is not allowed in a variable name. 

ABC@ltd Special characters are not allowed in a variable name. 

else 'else' is a keyword in Python, so it cannot be used as a 
variable name. 

j\j 1JTi 

If a variable is being used without assigning a value, i.e., if the variable is not defined, it gives an error. 
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'  
a-100 
b-200 
crint Cx) 

file fdet Frmel fun 

a1O 
b=20 
c=a+b 

Options window beip 

  

print('the sum of the nunsberz is:", C) 

F;  Python 374 The1' 

Pde (do The1I 

____________________ 

Dibog Q$ionoWindow 

.7.4 
Help 

:e09359112e 
Open.. CS't.O w1n32 
Op,nMndol. I.b.M right", "credits" 
Ro(e'el Floe 
Modol, 8.oww AleC 
Pat, 5noww 

S.., CbleS 
Cb4.Sh.leS 

S..nCopyA,... Si,dt.S 

Pont W,n4o-w Ct,l.P 

r piegI.py C:/U  et he oesktopiloolo 7 Python/87/pogl.py c37.4)" — D 

Figure  8.14: Creating New File Figure 8.15: New Window 

Let's Know More 

A keyword is a word that 

conveys a special meaning 
to the compiler. 

I 

Let's Know More 

A script is a program that 
you type in python. 

I 

P 
1e Ide Sled Qtheeg  Qpl.o.n Wdn" be'p 
Python 3.7.4 (tagz/v3.7.4:e09359112e, Jul 8 2019, 19:29:22) (MSC v.1916 32 bi 
t (Intel)) on win32 
Type "help", "copyright", "credits" or "license C)" for more information. 
>>> 

RESTART: C:/Users/Dinesh/Dezktop/tools  7 Python/B7/py7.py  
Traceback (most recent call last) 

File "C:/)Jsers/Dinesh/Desktop/Tooms 7 Python/Sl7/py7.py", tine 3, in <module> 
print Cx) 

)4ame5rr0r: name 'x is not defined 

Figure 8.13:  Undefined Variable Error 

The above code gives an error because the variable x is used in the print() function 

without being defined. 

WORKING IN SCRIPT MODE 

Interactive mode is preferred for small programs, where only a few commands are to be 

executed. This is because the output in interactive mode is compressed between the 

statements and may create confusion while writing long programs. 

For writing lengthy programs in Python, Script mode is used. Using this mode, we can 

create and edit Python programs. In this mode, we can save ourfile so that it can be used 

later. The complete script is written in an editor, such as a Notepad in Windows. 

1. Create Module/Script/Program File: 

i. Open IDLE Python. 

ii. Click on the File> New File in IDLE Python Shell as shown in Figure 8.14. 

iii. In the new window that opens, type the commands you want to save as a 

program as shown in Figure 8.1S. 

Let's Know More 

A variable is a named 
memory location that 

stores the data and whose 
value may change during 

program execution. 

Let's Know More 

A compiler is a language 

processor that converts a 
program written in high- 

level language into 

machine language, and 
vice versa, just like an 
interpreter but in one 

single step. 
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Python a Python3732 

Organ:e • Newfolder 

Hams 
5r Quick access 

ra Search Python37-32 

Date modified 

.9 

0 
Type 

OLls 7/31!2019 2:49 PM File folder 
• Desktop 

Doc 7/31/2019 2:49 PM File folder 
, Downloads 

include 7/31/2019 2:48 PM File folder 
Documents Lib 7131/203.92:49 PM File folder 

Pictures Lbs V31/2019 2:49 PM File folder 

87 Scripts 1;31/2O19 2:49 PM File folder 

Book 3 tcl 7/31/2019 2:49 PM File folder 

Book 7 

mafln 

Tools 7/31/2019 2:49 PM File folder 

File flame: 

Save aslype 

progi.pyi 

Python files 

Hide Folders save 

 

r  progl.py - C:/UserstDinesh/Desktop/Tools  7 Python/Blfprogl.py 

File Edit Format Run Options Window Help 

Python Shell 

Check Module Alt+X 

Run Module F5 

Run... Customized Shift+F5 

iv. Cflckon the File> Save, and save the file with the name 'progi .py' where .pyis the extension for Python files. 

Figure 8.16: Saving a FUe 

2. Run Module/Script/Program File: 

After the Python program file is created, you can run the program 

byfollowingthe given steps: 

)> Open IDLE Python Shell. 

> Click on the File > Open. (If the file is already opened, you 

can directly follow the next step). 

Click on the Run> Run Module or press F5 key. 

a=10 
b=20 
c=a+b 
print ("the 

Figure 8.17:  Run Module 

It will execute all the commands you have stored in a separate Python Shell window. 

Observe the difference between the Script mode and the Interactive mode as shown in Figure 8.18. 

I:  progl.py - C:/Users/Dinesh/Desktop/Tools  7 Python... Python 3.7.4 Shell 

file edit FQrmat Eun Qptions window jeIp 

a=lO 
b=20 
c=a+b 
print("the sum of the numbers is:",  C) 

N 
Script Mode 

file £dit Shell Qebug Qptions 3indow jeIp 

Python 3.7.4 (tags/v3.7.4:e0935 
19:29:22) [MSC v.1916 32 bit (II 
Type "help", "copyright", "cred 
for more information. 
>>> 

   RESTART: C:/Users/Dine.  
PythonIB7/progi .py  
the sum of the numbers is: 30 
I>>> 

Interactive Mode 
p 
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PRACTICE TIME 

1. Write a program to print the general details about your school in five lines. 

2. Write a program to calculate the sum of two given numbers. 

DATA TYPES 

Suppose, you have planned a holiday trip during vacations, and you have to book tickets for your family members. 

The first action that you need to take is to fill a form to get the reservation done, where you need to give your 

required details like train number, date of journey, name, age, etc. Here, every piece of data that you enter is of a 

specific type; As your name is a String type, age is a numeric type, and date of journey is of date type. Similarly, in 

Python, one must specify in a program, what kind of values will be stored in a specific variable. 

BASIC DATA TYPES IN PYTHON 

In Python, a data type represents the type of data stored in a variable. The data stored in memory can be of many 

types. Python has various standard data types based on the type of value. For example, a student's marks are stored 

as a numeric value, whereas, his or her address is stored as alphanumeric characters. 

The basic data types used in Python are mentioned here: 

mt (Integer): Represents integral numbers (numbers without any fractional part). There are three types of integers 

in Python: 

Integer type 

 

Description 

  

Integer (int) Stores values in the range of - 2147483648 to 2147483647. 

L ong Integers (long int) Support the values that lie beyond the range of Integers. 

Boolean (bool) 
It represents logical values in the form of True and False. In Boolean, 

0 represents False and 1 represents True. 

float: Represents floating point values (numbers with fractional part). The fractional part of a floating point number 

may be 0 as well. Examples offloating point numbers are, 3.14, -48.6, 18.0, etc. 

str (String): A String data type represents strings of characters enclosed within single or double quotation marks('' 

Or"). 

Examples of strings are, 'Hello', "Myname", '218', 'Peace', etc. 

Some examples of data types in Python are: 

S.NO. Value Data Type 

1.  15 mt 

2.  7.9 float 

3.  Computer Application str 

4.  7>3 bool 
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>>> a=input("enter the first value:") 
enter the first value: 200 
>>> b=input("enter the second value:") 
enter the second value: 300 

>>)I 

F Pyiho 3.7.4 Shnr 0 X 

Lit, Ldit Sheji Qebug Qptiom window help 

Python 3,7.4 (tags/v3.7.4:e09359112e, Jul 8 2019, 19:29:22) [MSC v.1916 
32 bit (Inte1)3 on w1n32 
Type "help", "copyright", "credits" or "license C)" for more information. 
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Input() FUNCTION 

lnput() function is used to accept the value for a variable from the user. To input integer and float values, we can use 

intQ or float() along with inputO. 

Program 1: 

Figure  8.19: Using Input() function 

In Python, input() function takes one string argument. This means that whatever value is being entered by the user, 

it will be taken as a string argument. 

Program 2: 

F  Python 3.7.4 SheB 

.,Ie d,t S5e!l Qebug Qptions indow help 

Python 3.7.4 (tags/v3.7.4:e09359112e, Jul 8 2019, 19:29:22) [MSC v.1916 
32 bit (Intel)] on w1n32 
Type "help", "copyriqht", "credits" or 'license C)" for more information, 
>>> a=input("enter the first value:") 
enter the first value: 200 
>>> b=input("enter the second value:") 
enter the second value: 300 
>>> c=a+b 
>>> print (C) 
200 300 

>>> I 
Figure 8.20: String Operator 

Observe in the above program, when you add the two numbers, you do not get the sum. Rather the numbers are 

joined together and are printed as a string. 

Program 3: 
r / 4 0 X 

Lie Ldit S1efl Qebug Qpeions (,ndow help 

Python 3.7.4 (tags/v3.7.4:e09359112e, Jul 8 2019, 19:29:22) (MSC v.1916 
32 bit (Intel)] on win32 
Type "help", "copyright", "credits" or "license C)" for more information. 
>>> ainput("enter the first value:") 
enter the first value: 200 
>>> b=input("enter the second value:") 
enter the second value: 300 
>>> print (a*b) 
Traceback (most recent call last) 

File "<pyshellt2>", line 1, in <module> 
print (a'b) 

TypeError: can't multiply sequence by non-mt ot type 'str' 
>>> I 

Figure 8.21: Type Value Error 

Here, in this program, when you try to multiply these two values, you get an error in the program. This is because the 

strings values cannot be multiplied together. 



t 0 

Ee feb Fm,t f,.'  Qpioas dow dp 

a=int(input("Enter the value of a:")) 
b=lnt(input("Enter the value of b:)) 
a, b=b, a 
print("Value of a after zwaping:",a) 
print("value of b after zwaping:",b) 

To work with the values provided by the user, Python provides a method as discussed in the given example: 

Program 4: r  Python 3.7.4 Shor! 

fje edit Shell Qebug Qptiono indo* help  

Python 3.7.4 (tags/v3.7.4:e09359112e, Jul 8 2019, 19:29:22) [MSC v.191 
32 bit (Intel)) on win32 
Type "help", "copyright", "credits" or "license  0" for more information 

>>> a=int(input("Enter the firrt number:")) 
Enter the first number: 100 
>>> b=int(input("Enter the second number:")) 
Enter the second number: 300 
>>> print("The sum of the numbers is:', a+b) 
The sum of the numbers is: 400 
>>> 

Figure 8.22: Sum of Numbers 

Observe, when you use into function, the values are converted to integers and are added. 

Program 5: 

Figure 8.23: Swapping Two Numbers 

Program 6: 

r  P,thnn3.7Afb,Q 

I,,  Ore Qe.q 4n.. Ode 
Python 3.7.4 tag3/v3.7.4:e09359112e, Jul 3 2019, 19 
(Intel)) on v1n32 
type "help", copyright, "credits or license() fc 
>0> 

REStART: C:IUzersI  inezh/Desktep/Tools 7 9 
Ester the value of a: 45 
Enter the value of b: 25 
Value of a after svaping: 25 
Value of b after suaping: 45 
0>> 

Output 

r .4' 0 

34k fda P2oea 3,,,  Qphon, kdow 

5=int (input(Enter the tide of the oquare:")) 
arsms 
pm4* 
print("The parameter of the square is:", p) 
print("The area of the ,quare Ia:", ar) 

ore Or.., Or. a am 
Python 3.7.4 (taqn/03.7.4:005359112a, Jul 8 2010, 29:20:22) 
32 bit (Intel)) on v1n32 
rype "help", "cepyright, redit" or •licenoeo)" for more 

RESTaRT: c:/Un.ra/olnauh/D.uktup/TOOlJ  7 Pythonfn 

Enter the aide of the nquare: 30 
he parameter of the Square in: 2o 
he area of the Square In: 900 

Figure 8.24: Area and Perimeter of a Square Output 

 

PRACTICE TIME 

  

1. Create a program to calculate 5% discount on total purchase of stationery. 

2. Create a program in Python to convert miles into kilometers. 

1 Mile=1.6 Kilometers 

3. Create a program to convert temperature from Fahrenheit to Celsius. 

Celsius= (Fahrenheit-32)x5/9 

  

Features of print() function 

)° The print() function in Python is used to print a message or value on the output device. 

> It converts the message or an object into a string before writing it on the screen. 

> It can have multiple parameters. 

> It supports multiple escape sequences to format the output, e.g., '\n'  (new line), t' (tab space), and 

'\r' (carriage return). 

Using separators with print() function 

Using ',' operator:  When you use ',' operator as the separator among the values, the values are displayed with a 

space between them. 
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3py - — 

file edit Fmat 8un Qptions window H  
a=1O 
b=20 
c=1O 0 
print (a,b, C) 

 

r  4.py - C!UThnlfOeklop/TQo. 

 

file fdit FQrm.t gun Qptions window Help 

a=l 0 
b=20 
c=100 
print(a,"\t",b,"\t",c)I 

f.k Edit She'l Q.bug Qptiu-u .duw Help  

Python 3.7.4 (tags/v3.7.4:e0935911 
(Intel)] on win32 
Type "help", "copyright", "credits 
>>> 

 RESTART: C:/Users/Dines  
10 

20 
100 

>>> I  

£4' Edit SI pho.n 5ndw dp 

Python 3.7.4 (tags/v3.7.4:e09359112e 
32 bit (Intel)] on win32 
Type "help", "copyright", "crp-- 

Input 
on the same line 

enter your name: Ainit 
enter your age: 17 
enter your class: 

>>> 
RESTART: c:/usersl  

file fdit Fgnnel un Qptions ndew belt  

nameinput("enter your name:") 
age-input("enter your age:") 
Class=input ('enter your class:") 
print("your name is:", name) 
print("your age is:", age) 
rint("your class:", Class) 

Figure 8.28:  Program without Escape Sequence 
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Output 

Program 7: 

Figure 8.25:  Using Comma Operator 

file fdit Thell Qebug Qptions window Help 

Python 3.7.4 (tags/v3.7.4:e093 
(Intel)) on win32 
Type "help", "copyright", "cre 
>>> 

  

RESTART: C:/Users/D  
10 20 100 
>>> 

L 

   

   

Output 

Using ,\t'  (tab space):  When you use '\t'  escape sequence as the separator among the values, the values are displayed 

with a tab space between them. 

Program 8: 

f.le Edit Sheji Qebug Qptron jindow eIp 

Python 3.7.4 (tagslv3.7.4:e0935 
32 bit (Intel)) on win32 
Type "help", "copyright", "cre 
>>> 

RESTART: C: /Users/Di 

20 100 

Figure 8.26: Using 'It' Escape Sequence Output 

Using '\n'  (Newline character): 

A newline character in Python is used to end a line and start a new line. In Python, the new line character can be used 

with the input function and with the print function. '\n'  is a newline character used in Python. 

Program 9: 

F  5 py  -  CUev/0ine5h/De5ktop1Too...  —  

file  edit Fimat Bun Qptions window Help 

a=10 
b=20 
c=100 
print (a, "\n",b, "\n",c) 

Figure 8.27: Using In Escape Sequence 

74 S,ea 

Output 

Let us consider another example. Suppose you want to make a program to accept the name, age, and marks of a 

student. For this, add the following code in the Python script file: 

Program 10: 



RECAP,  

refers to the grammatical rules to be followed while writing a program in any language. 

A. 

1.  

2. Python was created by  

3. ... menu is generally used to edit the file in use. 

giving the output. 4. In the Interactive mode of Python, the instructions are executed  

5. A is a named memory location that stores the data. 

6. Python cannot be used as a variable name. 

- Edit Line by line 
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Now in the Python scriptfile, add '\n'  with the input and printfunction: 

r - 
Lu.' Qpie.n ndow 

name=input("enter your n.ame:\n") 
ageinput("enter your age:\n") 
C1assinput("enter your c1as:\n) 
print("your name is:\n", nanie) 
print("your age is:\n", age) 
rint("your class:\n", Class) 

. tdm Su. Q.u9 d. • 
Python 3.7.4 (tagslvl.7.4:e05359112e, Jul 
32 bit (Intel)) on win32 
Type "help". "copyright,---------"P""  

>>> 

RESTART; C:/  

Program 11: 

I enter your name: 
Amit Sharma 
enter your age: 
17 
enter your class: 

Input 
on the next line 

Figure 8.29: Program with Escape Sequence Output 

In the above output window, in order to give a better understanding, the text and the values are placed one after 

another. 

> Python was created by Guido Van Rossum when he was working at Centrum Wiskunde & Informatica (CWI). 

) Python is a high-level language used to write codes forthe computer programs. 

> Interactive mode is beneficial for testing code where you type the commands one at a time and get the result or 

error immediately. 

> Script mode is used for writing lengthy programs in Python. 

> The print() function is used to display the output of any command on the screen. 

) Python has various standard data types based on the types of values stored in variables. 

> lnput() function is used to accept the value for a variable from the user. 

SECTION - A 

F ill in the blanks. 



B. State True or False. 

1. To evaluate an arithmetic expression, it is not necessary to use print() function. 

2. A variable name can consist of alphabets, digits, and underscore. 

3. A script is a program that you type in Python. 

4. In Python, only one type of data can be stored in memory. 

5. Print() function is used to accept the value of a variable from the user. 

6. The string values cannot be multiplied together. 

7. When we use ',' operator as the separator among the values, the values are displayed with a space 

between them. 

C. Application-based questions. 

1. Kritika's computerteacher has given her an assignment to display the names of the fruits separated with a tab 

space in Python. Which separator should she use with the print() function? 

2. Aman is working on his mathematics project work. He has to perform some quick calculations. Which mode of 

Python programming should he use for doingthem? 

SECTION  -  B 

A. Multiple-choice questions. 

1. Which of the following data types is not supported in Python? 

a. Numbers b. String c. List 

2. When a new value is stored in a variable, its previous value gets  

a. Accepted b. Overwritten c. Overlapped 

3. Values to variables are assigned using the operator. 

a. String b. print() c. Assignment 

4. The data type for 12.4 should be  

a. mt b. float c. str 

5. To give a tab space while printing the statement, you use  

a. b./t c.Tabkey 

6. The area where you type the code is called  

a. Work area b. Worksheet c. Script area 

7. >>> print('1O+20) will give the output  

a.30 b.1020 c.2010 
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Computers with  KIPS 



B. Answer the following questions. 

1. Write any fourfeatures of Python language. 

2. What is a variable? Discuss the rules for naming the variables. 

3. Explain the duff erent working modes of Python. 

4. What are data types? Explain any two data types in Python. 

5. What is the use of print() function? Discuss all the separators used with the print() function. 

6. What is an Interpreter? How is it different from a compiler? 
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MY ACTIVITY Learning While Playing 

A. Write the output for the following code of statements. 

a. > > >print(India', 'Deihi') 

b. > > > print(India', \t, 'Delhi') 

c. >> > print(India', \n', 'Delhi) 

d. >>>a=1O 

>>>b=20 

>> >c=(a+b)4 

>>>print(c) 

e. >>>a=1O 

>>> b=20' 

>>> print(a+b) 

1. >>>a=1O 

>>> b=20 

>>> print(a+b) 

B. Rewrite the following statements after correcting them. 

a. >>>1O=c 

b. >>>Print('India') 

c. >>>Print(age) 

d. >>>a=1O 

>>>b=20 

>>>a+b=c 

>>>print(c) 

C. Write the following code in the Script mode of Python and write the output in the given box. 

one = 1 

two =2 

three = one + two 

pri nt(three) 

hello = "hello" 

world = "world" 

helloworld = hello world 

print(hel lowo rid) 

Learning 
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Divide the class into two groups and conduct a group discussion on the following topic: 

Interactive mode  vs Script mode 

For Concept Clarity GROUP DISCUSSI 

ONLINE LINKS 

LAB SESSION. Perfection Through Practice 

Give the output of the following commands in the Interactive mode of Python: 

1. 2*314*5 

2. 4 + 5/3*8_5 

Write the code forthe following programs usingthe Script Mode: 

1. Write a program to find the product of two numbers x andy, where x=1 50 and y=200. 

2. It takes 3 hours to drive a distance of 192km on a motor way. Create a program to calculate the average 

speed in km/h? 

3. To calculate and printthe circumference and area ofa circle. 

4. To input the roll number, name, and marks in five subjects of a student. Calculate the total and 

percentage marks of the student. 

A.  

B.  

Looking For More 

To know more about programming in Python, visit the following links: 

https://www.tutorialspoint.com/python/  

https://www.w3schools.com/python/  
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INTERNET SERVICES 

LEARNING IN THIS CHAPTER 

r  Brief History of the Internet and WWW 
r  Video Conferencing 
r  Chatting  

r  Instant messaging 
r  Internet free calls 
r  E-learning 

' E-banking 
E-commerce 
Internet T.V and radio 

Internet is defined as a network of millions of computers connected to each other 

worldwide. You can relate the term Internet to the telephone network or the 

interstate highway system, which is spread across and interconnected to each 

other. It is the largest information database and has become a vital part of our lives. 

It enables the users to share ideas and search for information on any topic. 

The internet has transformed the entire world into a global village. 

HISTORY 

In 1969, when man walked on the moon, the US Defence Department set an Advanced Research Project Agency 

(ARPA) for further research. They designed a network of four computers to exchange and share their data. This 

network was called ARPANET (Advanced Research Project Agency Network). Later, many Universities were 

allowed to join this network and share their information. This was the beginning of 'Networking of computers', 

which grew bigger day by day and gave birth to the INTERNET, the technology which has radically changed our lives. 

Earlier, Internet was used by engineers, scientists, and computer experts for research purpose but gradually the 

network was made accessible to private agencies and general public. People started using it for sending messages 

and files between any two computers. 

In India, the internet services started on 15th August 1995, through a government owned company, VSN L. Some of 

the popular Internet Service Providers (ISP) in India are BSN L, Tata, Airtel, Reliance, Idea, etc. 

POPULAR SERVICES ON THE INTERNET 

There are many facilities available on the Internet, which make our lives better. Some of the widely used internet 

services are as follows: 

WORLD WIDE WEB (WWW) 

The World Wide Web (WWW) or simple web is a means of accessing and sharing information over the internet. It 

contains millions of documents, called Web Pages. Each page contains text, graphics, video, audio, and links to other 

web pages called Hyperlinks. To access and traverse through these web pages, one requires a software program 

called Web Browser. The most popular browsers are Google Chrome, Mozilla Firefox, and Internet Explorer. 

In 1990, while working at European Council for Nuclear Research (CERN), Sir Tim Berners-Lee, along with Robert 

Cailliau, invented the World Wide Web. Today the World Wide Web is the greatest database of human knowledge 

available online. 
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www.bing.com  is the 
latest Search Engine 

from 'Microsoft. 
-- 

VDEO CONFERENCING 

A Video Conference is a mode of communication 

that involves exchanging audio and video at the 

same time between people sitting at 

geographically different locations. The 

participants can view each other on their 

monitors, as well as hear voice over speakers of 

their laptops or desktop computers. 

It involves the use of camera known as Webcam 

as well as a microphone. The participants can also capture video and audio data in real 

time. Images and sounds are transmitted through the Internet and delivered to other 

participants. 

This technology is mainly used for virtual meetings among a group of people to discuss 

political, business, medical, or social affairs. On television, many times we see that a 

programme host is conducting an interview among several participants sitting in 

different cities and countries. This is done through video conferencing. Popular Video 

Conferencing applications include: Skype, Adobe Connect, Oovoo, Vugma, Ekiga, etc. 

 

Fact File 

 

In 1936, 
Dr. GeorgSchubert, an 

engineer working for the 
German post office, 

developed the world's first 
public video telephone 

service that connected the 
two cities Berlin and 
Leipzig and covered a 

distance of approximately 
100 miles. 

 

E  CHA1TING 

A chat is a text-based communication between one or more users 

in which messages are exchanged back and forth in real time 

through a chat software. Chat messages are generally short in 

order to enable other participants to respond quickly. 

Chat is also known as Online chat, or Internet chat. Chat not only 

allows you to exchange text messages, but it also allows you to 

interact with the other users through voice and video chats. 

There are various types of chats available on the internet. One can 

chat through instant messenger, a chat room, a chat website etc. 

However, most of them require the user to get registered first. 
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Know the Fact 

  

The first online chat 
system was called 

Talkomatic. It was created 
by Doug Brown and David 

R. Woolley in 1973 on 
the PLATO System at the 

University of Illinois. 

  

The Chat room is a designated area orforum on the World Wide Web that allows people 

with a common interest, friends, relatives or corporates to communicate with each other 

through instant messaging. Typically chat rooms are dedicated to various activities, such 

as sports, politics, health issues, television shows etc. 

INSTANT MESSAGING 

Instant messaging is like a private chat room where both the users must be online at the 

same time. It is a communication service over the internet that allows transmission of 

text-based messages from sender to receiver instantly. Like Online chat, instant 

messaging offers two-way message exchange in real time. The only difference between 

Instant messaging and Online chat is that in Instant messaging (IM), the communication 
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Figure 9.3: Starting a Conversation 

takes place between known users, and includes only those people whom the user has invited, whereas, Online chat 

could happen between unknown users too. Some popular IM services in use these days are Google Hangouts, 

Windows Live Messenger, AOL Messenger, Yahoo Messenger, Skype IM etc. 

HANGOUTS 

Google Hangouts is a free chat service that allows its members to participate in text, voice, or video chats. The chat 

can be in the form of one-to-one conversation or group chat involving ten people at the most. It can be easily 

installed and used on laptops, desktops, and mobile devices. This application is available for different operating 

systems including Windows, Android, and iOS. 

In addition to chatting, Google Hangouts users can also use it to share documents, images, and YouTube videos 

with the other users. To access Google Hangouts, a user is required to have a gmail account. 

How to add a contact to Hangouts 

> Open the link hangouts.google.com  and sign-in with 

yourgmailid. Or 

Open your gmail account and click on the Google apps 

launcher button . Click on Hangouts under the More 

section. 

) At the top of your Hangouts list, click the Search 

button c 

) Type a name, phone number, or email address. When 

you find the person you want in the search results, click 

his/her name to send him/her an invite. 

The next time you open Hangouts, the contact will appear in your Hangouts 

Start a Hangouts Conversation 

Searching Contact on Hangout 

list. 

> Click on the Message button P . In the Search box, enter the name or email address of the person you want to 

communicate with. 

> When you find the person you were looking for, click on his/her name. 

> A separate window appears. Type your message where the cursor blinks and press the Enter key. 

C ii 

0  M 

Hi, Madhu! 
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Figure 9.4: Making a caH via Hangouts 

Fact File 

Flipkart is a popular 

e-commerce company 

headquartered in Banglore. 

It was founded in 2007 by 

5achin Bansal and 

Binny Bansal. 

INTERNET FREE CALLS 

Another feather in the cap of the internet is that it lets you make free voice calls and video 

calls to anyone across the world. You can make free calls at much lower rates to 

anywhere in the world. Some software even allows you to send free messages and 

videos along with the free internet calls. The only condition is that the particular software 

or application should be installed in the devices at both the ends. After installing the 

software on a mobile or computer system, you need to create an account on it. Examples 

of such software or applications are: 

Let's Know More  I 

Pa yPa I 
PayPal is one of the most 

popular payment 

gateways, founded in 

December 1998 that 

authorises debit card and 

credit card payments. 

( Viber) 

FREE CALLING VIA HANGOUTS 

The Google Hangouts appUcation provides you with voice and video call capabilities with 

which you can have a face-to-face conversation with anyone. To make use of these 

features, 

> Make sure that your computer is equipped 

with a camera, microphone and speakers 

before makinga video call. 

> At the top of the hangouts !ist, click on the 

Search button °' 

> Type the name or the email address of the 

person you want to call. When you find that 

person, click his/her name. 

A separate window opens. Click on the Video 

call button L to start the video call. 

> Click on the End call button at the bottom of the window, once you are done with 

the call. 

Google 
Hangouts 

RETEL 

For Reference 

IRCTC 
Visit the site 

www.irctc.co.in. to reserve 

and print 

railway tickets. 

T 

Likewise, you can make a Video call with upto ten persons at the same time by selecting 

the check boxes adjacent to their names. 

E-LEARNING 

E-learning means 'Electronic Learning'. It refers to learning with the use of technology 

that enables the people to learn anytime or anywhere. E-learning can be implemented by 

using an internet connection, a network, an intranet, ora storage disk. It is less expensive 

Let's Know More 

Learning apps, like BYJUs, 

Vidyanext help the students 

learn intricate 
mathematical 

theorems and complex 

chemical reactions in an 

easy and understandable 

manner. 
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i'r  

than traditional learning and can be used to impart training 

to a large group of students at the same time, in an 

interactive and interesting manner. Thus, it saves time and 

reduces the need for costly classroom-based training. The 

quality of the electronic-based training depends primarily on 

the content and its delivery. 

We have the facility to download study materials from 

universities, which may incorporate various types of media, 

like audio, text, virtual environments, video, and animation. 

There are various websites that are used for E-learning like 

Coursera, edx, National Programme on Technology 

Enhanced Leaming(NPTEL), etc. 

Various universities worldwide like Harvard, MIT and even liTs have launched courses, focused on offering classes 

online forfree. 

Besides Distance learning, Mobile learning, E-learning, Open Education Resource (OER), Massive Open Online 

Courses (MOOC) etc., are being well accepted as alternative approaches for imparting knowledge to the users. 

E-BANKING 

E-banking stands for Electronic Banking. It is the way of performing bank transactions using the internet. It enables 

the customers to perform all routine transactions such as account transfers, balance enquiries, bill payments and 

stop payment requests, and some even offer online loan and credit applications. These transactions can be done 

from anywhere, irrespective of time, if one has an internet 

connection on his computer. As all the services are web 

enabled; the customer needs to log in to the website of a 

bank and access the centralised database by specifying the 

desired bank service. This saves more time than going to the 

bank physically. 

The steps to perform E.banking are: 

) Open the website of the bank 

) Enter user name and password 

) Do the desired transaction 

Some of the sites that provide e-banking are: 

www.statebankofindia.com, www.pnbindia.com, www.hdfcbank.com, etc. 

E-COMMERCE 

E-commerce stands for Electronic Commerce, which means online commercial activities. It involves buying and 

selling of goods and services, orthe transmitting of funds or data over the internet. 

Lots of internet services are available to promote business electi onically. The Internet offers us convenient ways to 

shop from our homes or offices for almost everything, such as movies, games, stationery, apparels, health care and 
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personal products, home appliances, and electronic items, etc. We can buy or sell new as well as second-hand goods. 

This process of selling and buying products over the internet is called Online shopping or E-shopping. Some of the 

popular portals for seing and buying goods are amazon.com, ebay.com, craiglist.com, bonanza.com, and 

ft ipkart.com. 

AMAZON 

Amazon is one of the largest online shopping websites in the world. It is an American electronic commerce and 

Cloud computing company, founded on 5 July 1994 with headquarters in Seattle, Washington. This site is popularly 

known for its wide collection of books, although it has expanded its domain to sell electronic appliances, clothing, 

furniture, hooks, and many more. It allows its users to avail payment through credit or debit card transactions, net 

banking, e-gift voucher, card swipe on delivery, or cash on delivery. To make use of this amazing e-shopping tool: 

> Logon to the official website of Amazon, i.e. amazon.in. 

using your username, password. 

> Type the name of the item you want to search, in the 

Search box at the top or you can search the item by 

selecting the appropriate category from the drop-

down list of the 'Shop by Category' option present just 

below the Amazon logo. 

> Select the desired product and check the details, that 

is, the key features and specifications of that item. BIbNIMIa 

> Once you are satisfied with the product specification, I 

click on the Buy Now button. FIgure 9.7: E-Shopping 

> After clicking on Buy Now, you need to create an amazon account. Enter your valid name, mobile number or 

email id and password. Click on Create your Amazon account. 

> Fill in your address details underthe Delivery Address section and click on Continue. 

Select the Payment Method and enter the required detaik. Click on Continue. 

> Review your order details and click on Place Your Order and Pay. Enter the 3-D secure code received from bank in 

orderto authorise your payment. 

) You will get a 'Thank You' page once the order is successfully placed. 

Amazon has created different retail websites for different countries to facilitate faster and easier delivery of the 

products e.g., for India it is www.arnazon.in, for Canada-www.amazon.ca, for America-www.amazon.com  and 

soon. 

INTERNET TV 

Internet TV can be defined as a medium of delivering television content over an internet connection. To use the 

internet TV you must have a broadband connection. The Internet TV is also known as web television. It is similar to 

cable TV. 



) Internet is defined as a network of millions of computers connected to each other worldwide. 

)' In India, the internet services started on 15 August 1995 through a government owned company, VSNL. 

> The software program used to access and traverse through the web pages is known as Web Browser. 

> A Video Conference is a mode of communication that involves exchanging audio and video at the same time 

between people sitting at geographically different locations. 

> A chat is a text-based communication between one or more users in which messages are exchanged back and 

forth in realtime, through a chat software. 

)' Google Hangouts is a free chat service that allows its members to participate in text, voice, or video chats. 

> E-learning refers to learningwith the use of technology that enables people to learn anytime oranywhere. 

) E-banking is the way of performing bank transactions usingthe internet. 

> E-commerce involves buying and selling of goods and services, or the transmitting of funds or data over the 

internet. 

) The internet TV can be defined as a medium of delivering television content overan internet connection. 

The internet Radio, is an online radio service that is braodcasted over the internet on dedicated radio servers. 

Learning 
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You can even find more variety on the internet TV as many websites offer independently produced programs and 

unlimited number of channels keeping the specific interests of people in mind. 

The internet TV options include web-based shows, video on demand (VOD), and regular television shows hosted on 

the channel's website. 

You can watch the Internet TV on a computer screen, a television screen (through a set-top box) or a mobile device 

like a cell phone or an iPod. Rather than having a fixed time schedule designed by the channels, consumers can 

actively search and retrieve programs of theirchoice, anytime. 

Some of the popular independent service providers of internet TV are Netflix, Hotstar, Sony LIV, etc. 

INTERNET RADIO 

Internet Radio, as the name suggests, is an online radio service that is broadcasted over the internet on dedicated 

radio servers. It is broadcasted in much the same way as traditional radio with regard to its presentation and format. 

Here, audio stream is digitised and split into small pieces for transmission across the internet. It provides the 

listeners with a continuous stream of audio, which cannot be paused or replayed. The internet radio has been in 

existence since the late 1 990s. Unlike the traditional radio station, that has its broadcasting limitation (typically up to 

100 miles), the internet radio has no limitation. It is capable of broadcasting graphics, text, and links along with 

audio, thus serving all the senses of the listeners. The internet radio is evolving and expanding its reach from desktop 

computer to devices that enable accessing broadcasts anywhere, anytime. Some of the popular Internet radio 

services are Tunein, Pandora, Soma.fm, Vividh Bharti, Radio Mirchi, etc. 

JRECAP 

    

    

     



                                 

         

BRAIN 

                      

                               

                               

                                 

                                 

                                 

                                 

                                 

                                  

SECTION - A 

A. Fill in the blanks. 

1. is defined as a network of millions of computers connected with each other. 

2. The software program, used to access and traverse through web pages is known as  

3. is one of the popular video conferencing applications. 

4. enables people to learn anytime and anywhere. 

5. In  audio stream is digitised and split into small pieces for transmission across 

the Internet. 

 

HINTS E-Learning 

 

Skype Internet Radio Web browser Internet 

B. State True or False. 

 

1. Bill Gates is the founder of World Wide Web. 

2. Hangouts is one of the popular IM service. 

3. In Online shopping, you can only sell the products. 

4. E-learning is less expensive than traditional learning. 

5. Flipkart is a popular e-commerce company based in ndia. 

C. Application-based questions. 

1. Shruti's children live in the USA. She wants to talk to them, face to face. Which internet service should she use 

for communication? 

2. Anuj is a sales representative. He hardly gets time to visit the bank for transactions. Which internet service 

should he use to do all his banking activities? 

SECTION- B 

A. Multiple-choice questions. 

1. In India, internet services started on  

a. 15th August 1995 b. 15th August1985 c. 15th August2005 

Computrs 
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2. GoogleHangoutsisafree  

a. E-learning b. Web browser c. Chat Service software 

3. MOOCisoneofthe tool. 

a. E-banking b. E-learning c. E-shopping 

4. Sachin Bansal and Binny Bansal are the founders of  

a.Flipkart b.Skype c.Amazom.com  

5. is one of the popular payment gateways. 

a. Paypal b. Bing c. Ekiga 

B. Answer in one word. 

1. Which communication service involves exchanging audio and video at the same time between people sitting 

at geographically different locations? 

2. Name the internet service that allows the the transmission of text-based messages from the sender to the 

receiver instantly. 

3. What does ARPA stand for? 

4. Name the service that helps us to perform bank transactions using the internet. 

5. Name any two websites used for e-learning. 

C. Answer the following questions. 

1. What is the internet? Write a short note on the history of the internet. 

2. Describe the term Video Conferencing. 
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3. What is Instant Messaging? How is it different from Online Chat? 

4. Explain the concept of E-learning. 

5. What is Internet Radio? How it is different from the traditional radio? 

6. Write short notes on the following: 

a. E-banking  

b. E-shopping  

c. lnternetfree calls  

d. Internet TV  



  

LAB SESSION Perfection Through Practice 

 

> Visit the site - www.bing.com. Search and download information and pictures on the topic - Water Cycle. 

Create an informative presentation by collecting information from the net. 

> To increase your knowledge and for further learning, visit the site: 

www.wikipedia.conL (The biggest online encyclopedia). 

GROUP DISCUSSION For Concept Clarity 

  

Divide the class into four groups and discuss the topic: 

Learning with the help of Technology 

PROJECT WORK Using Creativity 

Make a presentation on the topic: Popular Services on the Internet. 

 

ONLINE LINKS Looking For More 

 

To know more about Internet, visit the following sites: 

> http://www.gcflearnfree.org/internetbasics/  

> http://fcit.usf.edu/internet/chap1/chap1.htm  
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WORKSHEET 
Chapters 6-9 

A. Fill in the blanks. 

1. The is a copy of the original symbol. 

2. The is the store house of symbols from where these are used throughout the movie. 

3. refers to the grammatical rules to be followed while writing a program in any language. 

4. The function is used to display the output of any command on the screen. 

5. is a communication that involves exchanging audio and video at the same time, 

between people sitting at geographically different locations. 

HINTS Print Video Conference Instance Library Panel Syntax 

B. State True or False. 

1. Avariable name must start with an alphabet (capital orsmall)or an underscore (_). 

2. In Animate CC we can create only one instance of a symbol. 

3. To access the Convert to Symbol option press F9 Key. 

4. InputOfunction is used to print the value of a variable. 

5. Internet TV can be defined as a medium of delivering television content over an Internet connection. 

C. Write the shortcut keys for the following activities in Animate CC. 

1. To enable the Properties panel 

2. To preview the animation 

3. Breakapartthetext 

4. Toimportanimage 

D. Write the name of the Python window component. 

1. This is the area that displays the name of the application and the document 

2. Theareawhereyoutypeyourcode. 

3. Shows the current status of your control/cursor on the window. 

4. This menu is used to work with the options related to the currentlyused file. 

Learning 
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WORKSHEET 

Chapters 6-9 

A. Choose the best answer. 

1. Animate provides types of tweened animation. 

a. One b. Two c. Three 

2. is one of the popular payment gateways. 

a. Line path b. Bing c. Ekiga 

3. >>> print('SO'~' Fifty') will give the output  

a. 5OFifty b. 50 c. Fifty 

4. Python is a  language used to write codes for the computer programs. 

a. Low-Level b. High-Level c. Assembly 

B. Answer in one word. 

1. Which tool is used to draw stylish brush strokes? 

2. Name the tool used to create a motion guide that defines a random path. 

3. Name the option used to remove a Keyframe. 

4. Which Python function is used to accept the value for a variable from the user? 

C. Answer the following questions. 

1. What is the utility of Motion Guide? 

2. What is Tweening? 

3. What is the use of print() function? 

4. Explain the concept of E-learning. 



PYTHON 

Project 1: A Computer manufacturing company announcing special offer for their 

customers on purchasing Laptops and Des ktops. 

On Laptops Discount = 10 % 

On Desktop Discount = 5 % 

Write a program in Python to calculate total discount on purchase of desktops and laptops. 

Project 2: Write a program in Python to enter employee name and basic salary. Find the 

gross pay of an employee for the following allowances and deductions. 

Dearness Allowance 20 % of Basic Salary 

House Rent Allowance 15 % of Basic Salary 

Provident Fund 9.20% of Basic Salary 

Net Pay Basic Salary + House Rent Allowance 

Gross Pay Net Pay — Provident Fund 

Display the output in the following format: 

iriter Employee Name:Abhinandan 
nter Basic Salary:67000 
*************************************************t** 

Employee Salary Details 
Employee Name is: Abhinandan 
Total Gross Pay=Rs: 90450.0 
Total Net Pay=Rs: 84286.0 

*** ************************** *** **** **************** ** * *********** 

>>> I 
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E EXCEL 2016 

Project 1: Dear students, apart from your regular schoolfees, your parents are investing a lot of their 

hard earned money on your education. To be aware of this investment, visit your school 

uniform shop and school book shop. Enquire about the price of the following items and 

calculate the total amount. 

FIRSTDAYATSCHOOL' 

S.No. Particulars Items Quantity Price Amount 

1 

School Uniform 

Shirts 2 

2 Trousers/Skirts 2 

3 Neck Tie 1 

4 Shoes 1 

5 Socks 2 

6 School Belt 1 

7 

Stationery and 
Books 

Text Books One Set 

8 Note Books 15 

9 Stationery One Set 

10 

Accessories 

School Bag 1 

11 Lunch Box 1 

12 Water Bottle 1 

Now type the cost of each item in 'Price' column and calculate the amount as per quantity, in the 'Amount' column. 

Find the total of the calculated amount of all the items. 



Project 2:  Create an Excel sheet to calculate the Total and Percentage of the students of class 6. Also find out the 

maximum and minimum marks scored in each subject. 

H I
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2 
3 
4 
5 
6 
7 
8 
9 

10 
11 
12 
13 
14 
15 
16 
17 
18 
19 
20 
21 
22 
23 

Roll No. 

PROGRESS REPORT 
First Name. Last Name  

Rana 

English 

18 

Hindi 

17 

Maths 

20 

,Science 

19 

S.Science 

18 20 

Total Percenta e 

101 Ariu 

102 Vijay Sharma 5 5 9 3 5 7 

103 Preeti Sahni 5 5 6 3 6 6 

104 Neeti Verma 7 6 6 5 5 7 

105 Ajay Goyal 8 5 7 6 5 8 

106 Soha Au 6 4 8 7 7 8 

107 Rohan Gupta 6 6 5 6 5 7 

108 Bindu Kurnari 4 7 8 8 4 6 

109 Sheetal Mahajan 4 4 6 5 6 5 

110 Mohit Jam 7 3 5 5 5 5 

     

Subject Max. Mm. 

     

 

English  

Hindi  

Science 

   

 

Maths  

S.Science 

IT 

   

     

Sheeti 

Ready + LC): 

> Format the spreadsheet and design it as shown in the figure. 

> Calculatethe 'Total' byadding up the marks in each subject. (Use QuickAnalysisTool) 

> Fill up the data in the 'Roll no.' column with the help of Auto Fill. 

> Calculate Percentage by dividing 'Total' with 'Maximum Marks' and multiplying the result with 100. (Use 

Absolute Referencingto include the cell reference of 'Maximum Marks') 

> Find the maximum and minimum marks scored in each subject by using Max and Mm function respectively. 

> Insert one more column in the above sheet, between 'Last Name' and 'English', and name it 'Full name'. Fill this 

column by joining 'First Name' and 'Last name' enteries. Use Flash Fillforthis activity. 

Learning 
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ANIMATE CC 

Project 1: Create an animation in Animate by using the given hints: 

 

) Draw the objects like sun, clouds, beehive, and tree by using the Oval, Pencil, and Paint Bucket Tools from the 

Tools Panel. 

> Draw some flowers in the scenery and create multiple copies of it. 

> Draw 4 bees in separate layers and convert them into Graphic symbols. 

> Draw path for each one of them in separate layers and create Classic Motion Guide for all. 

Project 2:  Create an animation in  Animate by using the given hints: 

> Create a two lane road scene as shown in the figure. 

> Create a layer and draw a traffic signal flashing green light in one direction. 

> Create another layer and draw cars facing the traffic signal. 

) Define Motion Tween forthe cars facing the green light. 

> Create another layer and draw another set of cars in it. Make the cars stop when signalflashes red light. 

Learning 
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GOOGLE SLIDES d 
Google Slides is an online application for creating dynamic presentations. With Google Slides, you can create 

presentations right in your web browser and no special software is required. It is a presentation editor in Google 

Docs and Google Drive productivity suite. The only prerequisite to use it is to have a Google account. It works similar 

to PowerPoint and Keynote. Presentations created with Google Slides are automatically saved to the Google Drive 

and accessible anywhere in the world, provided there is an Internet connection. Various features of Google slides are 

as follows: 

> Easy to create and edit presentations in the web browser. 

> Formatting can be done easily by adjusting spacing, fonts, and colors. 

> Sharing is simple. It allows multiple users to collaborate on a document in real time, giving permission to edit, 

view, or add comments. 

> Uploading of .pptx and .pps files can be done with ease and further they can be converted into a Google 

presentation. 

> Google presentation can be downloaded as a .pdf, .ppt, .svg, .jpg, or .txt file on the desktop. 

> Images and videos can be inserted to beautify your presentation. 

> Presentations can be published and embedded in a website. 

CREATING A NEW PRESENTATION 

To create a new presentation in Google Slide: 

> Open the webpage www.google.com  and login with your e-mail id and password. 

> Click on the Google apps 

Launcher drop-down 

menu appears. 

) Choose the Drive icon 

L fromthemenu. 

> Click on the New tab and 

select Google Slides option 

from the drop-down list. 

> A new blank presentation 

named-Untitled presentation 

w II appear on the screen. 
CI.0j to 40 'Gte, 

'ou can also open GoogleSlidesfrom the Google Docs window by clicking on the Main menu icon. 
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CHOOSING A THEME 

When you first create a new presentation, Google Slides will prompt you to select a theme. You can configure the 

looks of your presentation by selecting any theme from the displayed list. Each theme has a unique combination of 

colours, fonts, and slide layouts. You can also select the desired theme from the Theme command on the shortcut 

toolbar or Change Theme option from the Slide menu. 

Untitled presentation 

CHANGING THE SLIDE LAYOUT Fde Eda View insert Side Formal Arrange Tools Tab 

Whenever you start a new presentation, it will contain one slide with the 

Title Slide layout. You can change the layout of the slide according to the 

content. The layout can be changed in a variety of ways. 

) Click on the drop-down arrow next to the New Slide + - command. 

) Choose the desired layout from the displayed list that appears. Or 

Select the Layout tab and choose the desired layout. Or 

Click on the Slide> Apply Layout option and select the desired layout. 

CREATING A PRESENTATION FROM THE TEMPLATES 

Google Slides offers a wide variety of pre-designed templates that 

can be used to beautify your presentation. You can also customise  'H 
these templates according to your requirement. 

> Click on File> New and select the From template option from the 

displayed list of options. 

' This will take you to the Start a new presentation window, which 

contains various templates. 

> Navigate through the templates and select the one that suits your 

need. 

> A new file will be created with the selected 

template. Customise the file with your own 

information. 

You can also browse for more templates 

available in the Google Docs Template Gallery. 
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IOR(ING WITH SLIDES 

Google Slides works similar to other presentation software. The left side of the presentation window displays the 

slides that you have created and the centre of the window displays the current slide in which you are working. 

While creating a presentation, you may need to add more slides, delete or duplicate the existing ones or change the 

position of the slide. Google slides helps you to carry out allthese tasks. 

ADDING, MOVING, DUPLICATING, AND DELETING SLIDES 

> Click on the Slide menu and choose New slide to add a new 

slide in the presentation. You can also click on the New slide 

button + - present on the shortcut toolbar just below the 

Menu bar. or 

Press the Ctrl + M shortcut key combination from the keyboard. 

> To move a slide to a new location, choose any option amongst 

Move slide up, Move slide down, Move slide to beginning, or 

Move slide to end from the Slide menu according to your 

requirement or simply click and drag the slide thumbnail to the 

desired location in the Slides Navigation Pane. 

> Choose the Slide> Duplicate slide command to make a duplicate 

copy of the currently selected slide. The new slide will be placed 

below the original slide. 

> Choose the Slide > Delete slide command to remove the 

currently selected slide. 

The above-mentioned functions can also be performed by right-clicking on a slide thumbnail and selecting the desired 

option from the shortcut menu. 

ADDING TEXT IN SLIDE 

> Click on the Click to add title placeholder, insertion point appears. Enter any text to define the title of the slide. 

> Similarly, define the subtitle by selecting the Click to add subtitle placeholder. 

) As you type in the document, it gets automatically saved in Google Drive. 

) You can also edit your presentation whenever required. 

INSERTING AN IMAGE INTO A SLIDE 

> Click on the Insert menu and choose the Image option from the drop-down menu. 

) The Insert image dialog box will pop-up; displaying several ways to add images in a slide. 

You can also upload an image from your hard drive, your Google + account, or Google Drive. You can take a picture 

using a webcam, or you can search Google, LI FE magazine photo archives, or stock photos in the Image panel. Here 

'earning 
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you can use Search source: 

> Click the Search source and type your search item in the 

Search box to find images using Google Search. Press either 

EnterortheSearch 0  tool. 

> Choose the desired image and click on the Select button to 

insert it into your slide. 

INSERTING A VIDEO INTO A SLIDE 

Inse1 m ge 

.*CtI tTLC I 

 

   

IL 

      

You can also insert online videos in Google slides through 

YouTube. 

> Click on the Insert menu and choose the Video option. The Insert video dialog box will appear. 

> Find the desired video by typing in the Search 

box. The list of options will appear. 

nsertvideo 

> Scroll through the video list and select the video You Tube 4 

you would like to insert. ..d t.,* 

j I o.g...pe-.... dr,.0, ...e.ddçd.,.....h.ar. ....r T4  .'Otl..O n.J .• 
.'— 1'J 

> 

) 

Click on the Select button. 

The video will be inserted in your slide. You can 

also resize the video by dragging its handles. 

....n J,a. 
n.,  

C.- 

NOTE 

You can also add videos in your slides by copying their URLs in the Paste YouTube URL here textbox under the URL 

option in the Insert video dialog box. 

The Insert menu contains various other options that enable you to insert textbox, different shapes, wordart, 

lips chart, tables, comments, and much more in your presentation. 

ADDING TRANSITIONS AND ANIMATIONS 

Animations are a great way to give a dynamic look to your presentation. They can also be used to show objects or 

text on a slide, step-by-step. To add animation effects to your presentation: 

> Select a slide and go to View menu. Select Animations from the sub-menu. 

>	 Select an object on the slide and then click on + Select an object to animate button in the Animations pane. Or 

click on the Insert> Animation option. 

)	 Click on the drop-down arrow of the Fade in list box and choose the desired Animation type in which you want 

the selected object to appear. 

> Open the On click drop-down menu and set the Start condition for the animation. 

Computers wfth  tSIPS  <®> 
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> Adjust the speed of animation by moving the Duration slider. Check the applied effects 

by clicking the Play button. 

> To place animation on more objects, select another object and click on + Add animation 

button in the Animations pane or right-click on the object and select Animate from the 

context menu. 

> A list of animations is displayed in the pane. It specifies the order in which animations will 

take place on the slide. You can change the order by dragging the desired animation up or 

down. 

> To test the animation effects, once again click the Play button at the bottom of the 

pane. 

Anirnotions x 

Slide: No flarrnldon 

Fly in from left oorIi 0 

ki hen, hit 

On cbck 

By paragraph 

Sn Mndem Fast 
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Fade in 0ne* 

Fade in 

+ Select en objeci to animate 

Animations pane can also be used to apply the transition effects. These effects appear when 

a slide moves to another slide. Let us apply the transition effect: 

) Click on Slide: No transition in the Animations pane. Choose the Transition type for the 

currently selected slide from the No transition drop-down arrow. Set the speed from the Duration slider. 

) Click on Apply to all slides button to apply this transition to all slides in the presentation. Click the Play button to 

view the effects. 

NOTE 

You can also add or modify slide transitions from the menu bar by clicking on Slide> Change transition. 

ADDING COMMENTS 

Adding comments in a presentation is a great way to leave 

feedback and suggestions on the slide when collaborating 

your work with the other team members. Comments can 

be added to slides, text, images and shapes as well. To add 

comments in a slide: 

Untit!ed presentation 
File Ett \/iew Insert Slide Formal Arrange Tocls Table Help All c 

0. kl-\ Background... 

) Select a section of the slide. 

> Click on the Insert menu and select the Comment option. Or Click the Add comment tooI' on the toolbar. 

> The pop-up window will appear. Add your notes in it and click on the Comment tab. 

)' If the comment is important for a specific collaborator to see, enter '+' symbol in the comment text box followed 

by his address. You can also select the address from the drop-down list that appears when you type '+' symbol. 

> The '+' symbol will add people to this discussion and send an email when you press the Commenttab. 

> The receiver will get an email along with a link to the presentation. Thus, he can then reply to your comments to 

start a discussion. 

PESENTING YOUR SLIDES 

Once you finish editing your presentation, you can preview or present your slides by following the given steps: 

> Click on the View menu and selectthe Present option from the drop-down list. Or 

Learning 
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Select the Present button at the top-right side of the page to start the presentation. 

> The presentation will open in a new window with a menu at the bottom left corner of the window. 

> You can move between the slides either by clicking the mouse or clicking the arrows from the bottom menu. 

> You can also jump to a specific slide by clicking on the Slide 1 option and choosing the desired slide from the displayed 

list. To see the Speaker notes, click on the Presenter View. 

E PRINTING PRESENTATION 

To print a presentation from the editor: 

> Click on the File > Print option. 

> In the preview that appears, you can either scroll through your document on the right or choose Print options on 

the left. 

SHARING DOCUMENT AS A LINK 

With Google Slides, multiple persons can work together on 

the same presentation in real time as it allows you to share 

your documents with others at the same time. You can 

share with specific people or with anyone just by sharing a 

link. To collaborate: 

) Click on the Share button present at the extreme right 

corner of the window. 

) The Share with others dialog box appears. 

) Enterthe name or email address of the persons you want 

to share your document with or click on the Get 

shareable link button on the extreme-right corner. 

> The link of the document will be displayed under the Link 

sharing on section. Click on the Copy Link button. The 

link gets copied to the clipboard. You can paste and share 

the linkwith anyone. 

) Choose the desired authorisation from the list of options 

by clicking the drop-down arrow under the Link sharing on section. Click on the Send button. 

E-MAIL A COPY AS AN A1TACHMENT 

If you need to collaborate with someone on your presentation, you can email it as an attachment. 

) Click on File> Email as attachment option. 

) Selectaformat. 

) Enter the email addresses or Groups you want to send copies to. 

) Enter a message and click on the Send button. 
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)' Office Mobile Apps to get the things 

done on any device-PCs, Macs, tablets 

(including iPad and Android tablet). 

EY FEATURES OF OFFICE 365 

Wor s smarter with the built-in Word Researcher and Editor 

Researcher feature helps you to find and use the content, related to your topic, right within your Word document. It 

uses the Bing Knowledge Graph to extract the relevant content from the web and provides safe and credible 

information. 

Office 2016 suite contains applications, such as Word, Excel, PowerPoint, and Outlook that are available as a one-

time purchase for use on a single PC. 

Office 365 is a suite of services offered by Microsoft. It is a web-based subscription service, where you have to pay a 

monthly or yearly fee to make use of the various services it provides. Office 365 subscription plans include, Office 365 

Home, Office 365 Personal, Office 365 University, Office 365 for Mac, Office 365 for Business, etc. With each plan, you 

can install the 2016 versions of Word, Excel, PowerPoint, Outlook, and OneNote (Access and Publisher are also 

included for PC users). 

With the subscription of Office 365, you get: 

> The latest version of Office applications that are updated regularly, as and when a new version is released. Office 

365 can be installed on up to five devices. 

> One Drive cloud storage (free up to 1 TB) enables you to store all the documents in one place and allows you to 

access these documents at any time and anywhere. Therefore, it is easier than ever to create, edit, and share the 

documents at one go. 

The Editor feature on the other hand provides intelligent suggestions for proof-reading and editing as you type in a 

document. 

Finds the right command in seconds with Tell Me 

It is easier than ever to find the feature you need. Just type what you want to do in the intelligent "Tell me what you 

want to do" search box and go directly to the command you need. 

Put your best foot forward with PowerPoint Designer and Morph 

PowerPoint Designer is an intelligent, built-in tool that helps you to create high-quality slides in seconds. The new 

Morph transition effect creates cinematic motion in one click, seamlessly animating between the slides. 

Learninn .s. 
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Keyboard, touch, or pen - it works the way you do 

Touch and inking capabilities give flexible options for reviewing, editing, and presenting the views. 

OneNote 

Organise and Share Your Work 

OneNote is a digital notebook that helps you in 
making quick notes either handwritten or typed. It 
provides you with the flexibility to assemble and 
organise your notes, images, audio, and video 
clippings together in one location on your computer. 
You can share your notebook with anyone ydu desire 
and work on your projects also at the same time. 

Connect and Stay in Touch 

It is the most popular application used for making 
voice and video calls on the internet. Skype to Skype 
calls are always free but you can also use Skype to 
call mobile phones and landlines at affordable rates. 
You can also use it for instant messaging or chatting. 

Sway 

Turn your Ideas into Stories 

It helps in creating and sharing dynamic and 
interactive reports, presentations, newsletters, and 
personal stories. The built-in design templates help 
to enhance its look. It also provides you with a safe 
browsing tool to search relevant images, audio 
clips, videos, and other contents that you can drag 
and drop right into your creation. It is extremely 
easy to share a Sway with your family and friends 
without signing in or downloading additional 
software. Sway for Windows 10 is available for 
download in the Windows Store. 

Learning 
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SharePoint 

Keep Projects Together 

It is a platform; offering different services. You can 
use SharePoint to store and organise documents and 
collaborate with anyone in real time. You can sign-in 
to SharePoint from any device, like desktop or mobile 
phones and use it to have access to any information. 

Cy 
 yammer 

Connect across your Company 

It is a private social network within a company or an 
organisation that allows the team members to share 
information, to have group discussions, and build a 
body of knowledge that is instantly accessible by any 
co-worker at anytime and anywhere. 

Delve 

Discover Exactly What you Need 

Microsoft Delve, previously code-named "Oslo", 
helps you in searching your emails, meetings, 
contacts, social networks, and corporate documents 

stored across Office 365. It uses "machine learning" 
artificial intelligence to provide you with the stuff you 
need to see. You do not have to remember the title of 
a document and its location. Delve brings the right 
information to you proactively based on what you 
are working with. It shows you the documents, no 
matter where they are stored, in the cloud but you 
can only see the content that has been shared with 
you. 
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2. The given equations are solved on the basis of 
a certain system. On the same basis, find out 
the correct answer from amongst the options. 
If 12-5=84,10-5=50, 8-5=24,then 
6-5=? 
(A) 11 
(C) 6 
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NATIONAL CYBER OLYMPIAD 

Visit www.sofworld.org  for more details. 

1 Select a figure from thaptions 
in which the figure (X) is exactly 
embedded as one of its part. 

Fig. (X) 

(C)  (D)  

A '2 

(i) (ii) (iii) (iv) 

4. The given question consists of figures (i), (ii), 
(iii) and (iv). There is a definite relationship 
between figures (i) and (ii). Establish a similar 
relationship between figures (iii) and (iv) by 
selecting a figure from the options which will 
replace the question mark in fig. (iv). 

5. If 'Cloud' is coded as 'Rain', 'Rain' is coded as 
'Tree', 'Tree' is coded as 'Axe', 'Axe' is coded 
as 'House' and 'House' is coded as 'Mason', 
then from which of the following 'Wood' is 
obtained? 
(A) Tree (B) Rain 
(C) Axe (D) Mason 

(B) (A) 

(C) (D) 

A 

V 

SAND N 0 - MA  I.' 

6. What can be used with a PRINT statement 7. Windows 7 can run on 
for printing multiple values in a single line in (A) 32-bit processors 
QBASIC? (B) 64- bit processors 
(A) Comma (B) Semicolon (C) 128 bit processors 
(C) Tab (n) (D) All of these (0) Both (A) and (B) 
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:3. Select a figure from the 
options which will complete 
the Fig. (X). 

(A) 
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PATTERN & MARKING SCHEME 

SOF NATIONAL CYBER OLYMPIAD 

SYLLABUS 
Section 1: Verbal and Non-Verbal Reasoning. 
Section 2: History and Generation of Computers, Types of Computers, MS-Windows 7, MS-Word(Working with Charts and Tables, Using Page Layout tab, Arranging 
multiple windows of a document), MS-PowerPoint(Creating presentation using Animation, Custom Animation and Transitions, Creating new slides using Slides pane, 
Outline pane and Slides from Outline, Working with Handouts and Notes Master, Arranging multiple windows of a presentations, Working with Charts and Tables), 
Internet & E-mail, Introduction to QBasic, Hardware, Software, Input & Output Devices, Memory & Storage Devices, Latest Developments in the field of IT. 
Section 3 : Higher Order Thinking Questions - Syllabus as per Section 2. 
Questions are based on Windows 7 and MS-Office 2010. 



(A) SUM= 6 
Average= 3 

(C)A= 1 
B=5 
SUM = 6 
Average = 3 

(B) A = 1 
B=5 
SUM = 7 
Average = 3 

(D) SUM = 6 
Avg = 3 

In MS-Word 2010, to insert the header and 
footer in a document, which tab should you go 
to? 
(A) View (B) Page Layout 
(C) Home (D) Insert 

To switch between the running applications, 
in Windows 7. 

(A) Press Fl (B) Press ALT + F4 
(C) Press TAB 
(D) Press and hold down ALT and press TAB 

9. The software program that acts as an interface 
between the user and the www is  
(A) E-mail (B) Internet 
(C) Protocol (0) Web browser 

10. Which of the folTowing is a volatile memory ? 
(A) ROM (B) RAM 
(C) EPROM (0) PROM 

11. By clicking which button one can return the 
window to its original size in Windows 7 ? 
(A) Maximize button (B) Minimize button 
(C) Restore button (D) Close button 

What is the dierence between Volatile and 
Non-Volatile Memory? 
(A) They are both same types of memory. 
(B) Volatile memory loses its contents when 

there is no electricity while non-volatile 
memory retains its content with or 
without electricity. 

(C) Non-volatile memory loses its contents when 
there is no electricity while volatile memory 
retains its content with or without electricity. 

(D) None of these 

Aero shake feature of Windows 7 
requires  shakes only in order 
to perform the task. 
(A)3 (B)2 
(0)10 (D)7 

15.  Identify the following. 
— It is a Windows 7 utility program. 
— It is used to create new characters that 

can be inserted into documents using 
character maps. 

— It can be accessed by typing 
eudcedit.exe in the run box. 

Transition effect deals with the entrance and exit 
of a slide in a slide show. Which of the following 
categories of Transitions is depicted in the given 
image of MS-PowerPoint 2010? 

         

1* 

 

-3 

Clock 

(A) (B) (C) (D) 

      

          

         

Dissolve checkerboard Blinds 

         

What would be the output of given OBASIC code 
if user enters the value of A = 1 and B = 5? 
CLS 
INPUT A 
INPUT B 
SUM = A + B 
Avg = SUM/2 
PRINT "SUM="; SUM 
PRINT "Average="; Avg 

(A) Subtle 

(B) Exciting 

(C) Dynamic Content 

(D) Static Content 

ANSWERS 

1, (A) 2. (C) 3(C) 4. (C) 5. (C) 6. (D) 7. (D) 8. (D) 9. (D) 10. (B) 11. (A) 12. (D) 13. (B) 14. (A) 15. (D) 16. (A) 17.(B) 
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