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ELECTRONIC SPREADSHEET (ADVANCED)

• SESSION 1: ANALYSE DATA USING SCENARIOS AND GOAL SEEK

• SESSION 2: LINK DATA AND SPREADSHEETS

• SESSION 3: SHARE AND REVIEW A SPREADSHEET 

• SESSION 4: CREATE AND USE MACROS IN SPREADSHEET



Learning Outcome of this session

The students will be able to:

• Explain setting up multiple sheets

• Demonstrate creating reference to other sheets

• Identify hyperlinks to the sheet

• Explain creating hyperlinks

• Describe linking to external data, registered data sources



Introduction 

In this chapter, we will learn how to create multiple sheets, and also to link the data
in multiple sheets. It can be done in two ways, one is creating reference to other
sheets/ documents by using keyboard and mouse, and other is by linking external
data.



Setting up multiple sheets

Identifying sheets

When you open a new spreadsheet it has, by default, three sheets named Sheet1, Sheet2, 
and Sheet3. Sheets in Calc are managed using tabs at the bottom of the spreadsheet, as 
shown in Figure 1.

Inserting new sheets



Inserting new sheets
There are several ways to insert a new sheet. The first step, in all cases, is to select the sheet that will be next 
to the new sheet. Then do any of the following:

• Select Insert > Sheet from the menu bar, or

• Right-click on the tab and select Insert Sheet, or

• Click in an empty space at the end of the line of sheet tabs (see Figure 2).



Inserting new sheets

Each method opens the Insert Sheet dialog (Figure 3). Here you can choose to put
the new sheet before or after the selected sheet and how many sheets to insert.



Inserting new sheets
We need 6 sheets, one for each of the 5 accounts and one as a summary sheet so we will add 3 more. We also want
to name each of these sheets for the account they represent: Summary, Checking Account, Savings Account, Credit
Card 1, Credit Card 2, and Car Loan. We have two choices: insert 3 new sheets and rename all 6 sheets afterwards; or
rename the existing sheets, then insert the 3 new sheets one at a time, renaming each new sheet during the insert
step.

To insert sheets and rename afterwards:

1. In the Insert Sheet dialog, choose the position for the new sheets (in this example, we use After current sheet).

2. Choose New sheet and 3 as the No. of sheets. (Three sheets are already provided by default.) Because you are 
inserting more than one sheet, the Name box is not available.

3. Click OK to insert the sheets.

4. For the next steps, go to “Renaming sheets” below.

To insert sheets and name them at the same time:

1. Rename the existing sheets Summary, Checking Account, and Savings Account, as described in “Renaming 
sheets” below.

2. In the Insert Sheet dialog, choose the position for the first new sheet.

3. Choose New sheet and 1 as the No. of sheets. The Name box is now available.

4. In the Name box, type a name for this new sheet, for example Credit Card 1.

5. Click OK to insert the sheet.

6. Repeat steps 1–4 for each new sheet, giving them the names Credit Card 2 and Car Loan.

On the Insert Sheet dialog, you can also add a sheet from a different spreadsheet file (for example, another Calc or 
Excel spreadsheet), by choosing the From file option. Click Browse and select the file; a list of the available sheets 
appears in the box. Select the sheet to import. If, after you select the file, no sheets appear you probably selected an

invalid file type (not a spreadsheet, for example).



Inserting sheets from a different 
spreadsheet 

If you prefer, select the Link option to insert the external sheet as a link instead as a
copy. This is one of several ways to include “live” data from another spreadsheet.
The links can be updated manually to show the current contents of the external file;
or, depending on the options you have selected in Tools > Options > OpenOffice.org
Calc > General > Updating, whenever the file is opened.



Renaming Worksheets 

Sheets can be renamed at any time. To give a sheet a more meaningful name:

• Enter the name in the name box when you create the sheet, or

• Double click on the sheet tab, or

• Right-click on a sheet tab, select Rename Sheet from the pop-up menu and 
replace the existing name.



Referencing other sheets

Creating The Reference With The Mouse

On the Summary sheet, set up a place for all five account balances, so we know
where to put the cell reference. Figure 6 shows a summary sheet with a blank
Balance column. We want to place the reference for the checking account balance in
cell B3.



Referencing other sheets
To make the cell reference in cell B3, select the cell and follow these steps.

1. Click on the = icon next to the input line. The icons change and an equals sign appears in the input line as 
in Figure 7.

2. Now, click on the sheet tab for the sheet containing the cell to be referenced. In this case, that is the 
Checking Account sheet as shown in Figure 8.



Referencing other sheets

3. Click on cell F3 (where the balance is) in the Checking Account sheet. The phrase ‘Checking Account’.F3 
should appear in the input line as in Figure 9.

4. Click the green checkmark in the input line to finish.

5. The Summary sheet should now look like Figure 10.



Creating the reference with the 
keyboard

Typing the reference is simple once you know the format the reference takes. The reference has three parts 
to it:

• Path and file name

• Sheet name

• Cell

Looking at Error: Reference source not found you can see the general format for the reference is

=’file:///Path & File Name’#$SheetName.CellName.

CREATING REFERENCE TO OTHER SHEETS BY KEYBOARD :-

• Type =(Sheet Name).(Cell Reference) 

• e.g. =Sheet3.B2 

• Click on Tick Icon 

• Press Enter. 



Relative and absolute hyperlinks
Hyperlinks can be stored within your file as either relative or absolute.

A relative hyperlink says, “Here is how to get there starting from where you are now” (meaning from the
folder in which your current document is saved) while an absolute hyperlink says, “Here is how to get there
no matter where you start from”.

An absolute link will stop working only if the target is moved. A relative link will stop working only if the start
and target locations change relative to each other. For instance, if you have two spreadsheets in the same
folder linked to each other and you move the entire folder to a new location, a relative hyperlink will not
break.

To change the way that OOo stores the hyperlinks in your file, select Tools > Options > Load/Save > General
and choose if you want URLs saved relatively when referencing the File System, or the Internet, or both.

Calc will always display an absolute hyperlink. Don’t be alarmed when it does this even when you have saved
a relative hyperlink—this ‘absolute’ target address will be updated if you move the file.



Creating hyperlinks



Creating hyperlinks

The top right part of the dialog changes according to the choice made for the hyperlink category from the left panel.
A full description of all the choices, and their interactions, is beyond the scope of this chapter. Here is a summary of
the most common choices used in presentations.
For an Internet hyperlink, choose the type of hyperlink (choose between Web, FTP or Telnet), and enter the required
web address (URL).
For a Mail and News hyperlink, specify whether it is a mail or news link, the receiver address and for email, also the
subject.

On the left side, select one of the four categories of hyperlinks:
• Internet: the hyperlink points to a web address, normally starting with http://
• Mail & News: the hyperlink opens an email message that the pre-addressed to a particular recipient
• Document: the hyperlink points to a place in either the current document or another existing document
• New document: the hyperlink creates a new document.

For a Document hyperlink, specify the document path (the Open File button opens a file browser); leave this blank if you
want to link to a target in the same spreadsheet. Optionally specify the target in the document (for example a specific
sheet). Click on the Target in document icon to open the Navigator where you can select the target, or if you know the
name of the target, you can type it into the box.
For a New Document hyperlink, specify whether to edit the newly created document immediately (Edit now) or just
create it (Edit later), and enter the file name and the type of document to create (text, spreadsheet, etc.). The Select
path button opens a directory picker dialog.
The Further settings section in the bottom right of the dialog is common to all the hyperlink categories, although some
choices are more relevant to some types of links.
• Set the value of Frame to determine how the hyperlink will open. This applies to documents that open in a Web
browser.
• Form specifies if the link is to be presented as text or as a button. Figure 15 shows a link formatted as a button.



Creating hyperlinks

Editing hyperlinks
To edit an existing link, place the cursor anywhere in the link and click the Hyperlink icon on the Standard toolbar or
select Insert > Hyperlink from the menu bar. The Hyperlink dialog (Figure 14) opens. If the Hyperlink is in button form, the
spreadsheet must have Design Mode on in order to edit the Hyperlink. Make your changes and click Apply. If you need to
edit several hyperlinks, you can leave the Hyperlink dialog open until you have edited all of them. Be sure to click Apply
after each one. When you are finished, click Close.

• Text specifies the text that will be visible to the user. If you do not enter anything here, Calc will use the full
URL or path as the link text. Note that if the link is relative and you move the file, this text will not change,
though the target will.

• Name is applicable to HTML documents. It specifies text that will be added as a NAME attribute in the HTML 
code behind the hyperlink.

• Events button: this button will be activated to allow Calc to react to events for which the user has written some 
code (macro). This function is not covered in this chapter.



Creating hyperlinks

Removing hyperlinks
You can remove the clickable link from hyperlink text—leaving just the text—by right-clicking on the link and
selecting Default Formatting. This option is also available from the Format menu. You may then need to re-
apply some formatting in order to match the rest of your document. To erase the link text or button from the
document completely, select it and press the backspace key.



Linking to external data
You can do this in two ways: using the External Data dialog or using the Navigator.

Using the External Data dialog
1) Open the Calc document where the external data is to be inserted. This is the target document.

2) Select the cell where the upper left-hand cell of the external data is to be inserted.

3) Choose Insert > Link to External Data.

4) On the External Data dialog (Figure 16), type the URL of the source document or click the [...] button to 
open a file selection dialog. Press Enter to get Calc to load the list of available tables.

5) In the Available tables/range list, select the named ranges or tables you want to insert. You can also 
specify that the ranges or tables are updated every n seconds.

6) Click OK to close the dialog and insert the linked data.



Linking to external data

Linking To Registered Data Sources 
You can access a variety of databases and other data sources and link them into Calc worksheets. First you 
need to register the data source with OpenOffice.org. (To register means to tell OOo what type of data 
source it is and where the file is located.) The way to do this depends on whether or not the data source is a 
database in *.odb format. 

To register a data source that is in *.odb format: 

1. Choose Tools -> Options -> OpenOffice.org Base -> Databases. 

2. Click the New button (below the list of registered databases) to open the Create Database Link dialog. 



Linking to external data

3) Enter the location of the database file, or click Browse to open a file browser and select the database 
file.

4) Type a name to use as the registered name for the database and click OK. The database is added to the 
list of registered databases. The OK button is enabled only when both fields are filled in.



Home Assignment

•PRACTICAL ACTIVITY

1. Create a set of worksheets for storing records of marks of differnet classes and 
compare all these on a separate worksheet.

QUESTIONS: 

1. How can we rename a worksheet? 

2. What are the two ways of referencing cells in other worksheets? 

3. Differentiate between relative and absolute hyperlinks. 

4. List the procedure involved in Linking HTML Tables to Calc Worksheet 

5. Fill up the blanks 

a) At the bottom of each worksheet window is a small tab that indicates the 
____________ of the worksheets in the workbook. 

b) A ___________ refers to a cell or a range of cells on a worksheet and can be 
used to find the values or data that you want formula to calculate. 



Home Assignment

2. A business owner wants to decide if he should try to increase the sales a product or price of 
an existing product in order to increase the profit by 10%.

The owner believes that he can either increase sales by 5 units without incurring additional 
costs while the price can be increased by Rs 8 without affecting the sales.
3. The current profit situation of a business owner is as follows.

Using the scenario manager, find the effect of in the new profit in case of the following situations.

a) Sales = 70 and cost = 80

b) Sales = 90 and cost = 72

c) Sales = 85 and cost = 80

d) Sales = 65 and cost = 80

Current Sales 82

Cost per Unit 75

Profit per unit 12

Current Sales 82

Cost per Unit 75

Profit per unit 12
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