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Learning Outcome of this session

• Student will able to Insert and use images in document 



SESSION 2: INSERT AND USE IMAGES 
Inserting An Image File 

When the image is in a file stored on the computer, you can insert it into an Open Office 
document using either of the following methods: 

Drag and Drop 

1. Open a file browser window and locate the image you want to insert. 

2. Drag the image into the Writer document and drop it where you want it to appear. A 
faint vertical line marks where the image will be dropped. 

This method embeds (saves a copy of) the image file in the Writer document. To link the 
file instead of embedding it, hold down the Control+Shift keys while dragging the image. 

Insert Picture Dialog 

1. Click in the Open Office document where you want the image to appear. 

2. Choose Insert > Picture > From File from the menu bar. 

3. On the Insert Picture dialog (see Figure 1.5), navigate to the file to be inserted, select 
it, and click Open. 

At the bottom of the dialog are two options, Preview and Link. Select Preview to view a 
thumbnail of the selected image on the right, so you can verify that you have the correct 
file. See below for the use of Link. 
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Figure 1.5. Insert picture dialog
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Inserting An Image From The Clipboard

Using the clipboard, you can copy images into an Open Office document from another  
Open Office document and from other programs. To do this:

1. Open both the source document and the target document.

2. In the source document, select the image to be copied.

3. Move the mouse pointer over the selected image and press Control+C to copy the  

image to the clipboard.

4. Switch to the target document.

5. Click to place the cursor where the graphic is to be inserted.

6. Press Control+V to insert the image.

If the application from which the graphic was copied is closed before the graphic is  
pasted into the target, the image stored on the clipboard could be lost.



SESSION 2: INSERT AND USE IMAGES
Inserting An Image Using A Scanner 

If a scanner is connected to your computer, Open Office can call the scanning 

application and inserted the scanned item into the Open Office document as an image. 

To start this procedure, click where you want the graphic to be inserted and select 

Insert > Picture > Scan > Select Source. 

Although this practice is quick and easy, it is unlikely to result in a high-quality image 

of the correct size. You may get better results by scanned material into a graphics 

program and cleaning it up there before inserting the resulting image into Open Office. 

Inserting An Image From The Gallery 

The Gallery provides a convenient way to group reusable objects such as graphics and 

sounds that you can insert into your documents. The Gallery is available in all 

components of Open Office. It does not come with many graphics, but you can add 

your own pictures or find extensions containing more graphics. To insert a Gallery 

image into a Writer document:
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1. To open the Gallery, click on the Gallery icon      (located in the right side of the 

Standard toolbar) or choose Tools > Gallery from the menu bar. 

2. Navigate through the Gallery to find the desired picture. 

3. To insert the picture, click and drag it from the Gallery into the Writer document. 

You can also right-click on the picture and choose Insert>Copy. 

Figure 1.6 shows an example of an image dragged from the Gallery.

Figure 1.6. Inserting an image from the Gallery
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By default, the Gallery is docked above the Writer workspace. To expand the Gallery,
position the pointer over the line that divides it from the top of the workspace. When
the pointer changes to parallel lines with arrows, click and drag downward. The
workspace resizes in response.

To expand the Gallery without affecting the workspace, undock it so it floats over the 
workspace. To do so, hold down the Control key and double-click on the upper part of 
the Gallery next to the View icons. Double-click in the same area while holding down 
the Control key to dock it again (restore it to its position over the workspace). 

When the Gallery is docked, to hide it and view the full Writer workspace, click the in 
the middle of the thin bar separating the Gallery from the workspace. 

To close the Gallery, choose Tools > Gallery to uncheck the Gallery entry, or click on 
the Gallery icon again.

Modifying An Image 

When you insert a new image, you may need to modify it to suit the document. Here 
we will discuss the use of the Picture toolbar, resizing, cropping, and a workaround to 
rotate a picture. 



SESSION 2: INSERT AND USE IMAGES
Using The Picture Toolbar 

When you insert an image or select one already present in the document, the Picture 
toolbar appears. You can set it to always be present (View > Toolbars > Picture). 
Picture control buttons from the Picture toolbar can also be added to the Standard 
Toolbar. 

Two other toolbars can be opened from this one: the Graphic Filter toolbar, which can 
be torn off and placed elsewhere on the window, and the Color toolbar, which opens 
as a separate floating toolbar. 

From these three toolbars, you can apply small corrections to the graphic or obtain 
special effects.

Graphics mode 

You can change color images to grayscale by selecting the image and then selecting

Grayscale from the Graphics mode list.

Flip vertically or horizontally

To flip an image vertically or horizontally, select the image, and then click the relevant

icon.
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Filters

Table 1 provides a short description of the available filters, however the best way to
understand them is to see them in action. Feel free to experiment with the different
filters and filters settings, remembering that you can undo all the changes by pressing
Ctrl+Zor Alt+Backspaceor by selecting Edit > Undo.

Colour

Use this toolbar to modify the individual RGB color components of the image (red,
green, blue) as well as the brightness, contrast, and gamma of the image. If the result
is not satisfactory, you can press Ctrl+Z to restore the default values.

Table 1: Graphic filters and their effects
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Icon Name Effect

Invert
Inverts the color values of a color image or the brightness values of a grayscale

image.

Smooth Softens the contrast of an image.

Sharpen Increases the contrast of an image.

Remove noise Removes single pixels from an image.

Solarization
Mimics the effects of too much light in a picture. A  further dialog box opens to 

adjust the parameters.

Aging

Simulates the effects of time on a picture. Can be applied several times. A 

further dialog box opens to  adjust the aging level.

Posterize
Makes a picture appear like a painting by reducing  the number of colors used.

Pop Art Modifies the picture dramatically.

Charcoal Displays the image as a charcoal sketch.

Relief

A dialog box is displayed to adjust the light source that will create the shadow

and, hence, the relief effect.

Mosaic Joins groups of pixels into a single area of one color.

Table 1: Graphic filters and their effects
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Transparency

Modify the percentage value in the Transparency box on the Picture toolbar to make

the image more transparent. This is particularly useful when creating a watermark or

when wrapping the image in the background.

Using The Formatting Toolbar And Picture Dialog

When an image is selected, you can customize some aspects of its appearance using
the tools available on the Formatting toolbar as well as in the dialog that is shown by
right-clicking on the image and selecting Picture. You can, for example, create a
border around the image, selecting style and color; or you can (in the Borders page of
the Picture dialog) add a shadow to the image.

Cropping Images

When you are only interested in a section of the image for the purpose of your

document, you may wish to crop (cut off) parts of it. To start cropping the image, right

click on it and select Picture from the pop-up menu. In the Picture dialog box, select

the Crop page (see Figure 1.7).
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Figure 1.7: The options available when cropping a picture
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In the Crop page, you can control the following parameters:

Keep scale / Keep image size

When Keep scale is selected (default), cropping the image does not change the scale
of the picture.

When Keep image size is selected, cropping produces enlargement (for positive
cropping values), shrinking (for negative cropping values), or distortion of the image
so that the image size remains constant.

Left, Right, Top, and Bottom

The image is cropped by the amount entered in these boxes. For example, a value of
3cm in the Left box cuts 3 cm from the left side of the picture.

When Keep scale is selected, the size of the image also changes, so in this example the
width will be reduced by 3 cm.

When Keep image size is selected, the remaining part of the image is enlarged (when
you enter positive values for cropping) or shrunk (when you enter negative values for
cropping) so that the width and height of the image remains unchanged.
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Width and Height
The Width and Height fields under either Scale or Image size change as you enter values in
the Left, Right, Top, and Bottom fields. Use the thumbnail next to these fields to determine
the correct amount by which to crop.
Resizing an Image
The inserted image might not fit perfectly into the document if it is too big or too small. In
these cases, you can use Writer to resize the image.
1. Click the picture, if necessary, to show the green resizing handles.
2. Position the pointer over one of the green resizing handles. The pointer changes shape

giving a graphical representation of the direction of the resizing.

3. Click and drag to resize the picture.

4. Release the mouse button when satisfied with the new size.

The corner handles resize both the width and the height of the graphic object  simultaneously, 
while the other four handles only resize one dimension at a time.

To retain the original proportions of the graphic, Shift+click one of the corner handles,  then 
drag. Be sure to release the mouse button before releasing the Shift key.

Be aware that re-sizing a bit-mapped (raster) image will adversely affect the resolution,
causing some degree of blurring. It is better to externally size your picture correctly before
insertion into your presentation, if possible.
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Figure 1.8 shows three examples of an image inserted into a document and resized.

Figure 1.8. Three examples of resized images, plus the original image
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For more accurate resizing, use either the Crop page of the Picture dialog box (Figure 
1.7) or, for images, the Type page of the Picture dialog box. On the Crop page you can 
adjust the following settings: 

• Scale Width and Height: specify in percentages the scaling of the picture. The size 
of the image changes accordingly. For a scaled resizing, both values should be 
identical. 

• Image size: specify the size of the image in your preferred unit of measurement. 
The image enlarges or shrinks accordingly. 

• Original size button: when clicked, restores the image to its original size. 

In the Type page of the Picture dialog box, select the Relative option to toggle 
between percentage and actual dimension. For a scaled resizing, select the Keep ratio 
option. As for the Crop page, clicking on the Original Size button restores the original 
image size. 

Figure 1.8. Three examples of resized images, plus the original image
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Rotating a Picture 

Writer does not provide a tool for rotating a picture; however, there is a simple workaround: 

1. Open a new Draw or Impress document (File > New > Drawing or File > New > Presentation). 

2. Insert the image you want to rotate. You can use any of the mechanisms described in “Error! 
Reference source not found.” on page Error! Bookmark not defined., although there are some 
slight variations in the position of the menu entries and icons. 

3. Select the image, then in the Drawing toolbar (shown by default at the bottom of the window 
in Impress and Draw), select the Rotate icon           from the Effects tear-off toolbar. 

4. Rotate the image as desired. Use the red handles at the corners of the picture and move the 
mouse in the direction you wish to rotate. By default the picture rotates around its center 
(indicated by a black crosshair), but you can change the pivot point by moving the black crosshair 
to the desired rotation center. 

To restrict the rotation angle to multiples of 15 degrees keep the Shift key pressed while rotating 
the image. 

5. Select the rotated picture by pressing Ctrl+A, then copy the image to the clipboard with Ctrl+C. 

6. Finish by going back to the location of the Writer document where the image is to be inserted 
and pressing Ctrl+V. 
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Creating Drawing Objects 

To begin using the drawing tools, display the Drawing toolbar (Figure 1.9), by clicking 
View > Toolbars > Drawing. 
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To use a drawing tool: 

1. Click in the document where you want the drawing to be anchored. You can 
change the anchor later, if necessary. 

2. Select the tool from the Drawing toolbar (Figure 7). The mouse pointer changes to 
a drawing-functions pointer. 

3. Move the cross-hair pointer to the place in the document where you want the 
graphic to appear and then click-and-drag to create the drawing object. Release 
the mouse button. The selected drawing function remains active, so you can draw 
another object of the same type. 

4. To cancel the selected drawing function, press the Esc key or click on the Select 
icon (the arrow) on the Drawing toolbar. 

5. You can now change the properties (fill color, line type and weight, anchoring, and 
others) of the drawing object using either the Drawing Object Properties toolbar 
or the choices and dialog boxes reached by right-clicking on the drawing object. 



SESSION 2: INSERT AND USE IMAGES
Set or Change Properties For Drawing Objects 

To set the properties for a drawing object before you draw it: 

1. On the Drawing toolbar (Figure 9), click the Select tool. 

2. On the Drawing Object Properties toolbar (Figure 1.10), click on the icon for each property and select the 
value you want for that property. 

3. For more control, or to define new attributes, you can click on the Area or Line icons on the toolbar to 
display detailed dialog boxes. 

The default you set applies to the current document and session. It is not retained when you close the 
document or close Writer, and it does not apply to any other document you open. The defaults apply to all the 
drawing objects except text objects.
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To change the properties for an existing drawing object: 

1. Select the object. 

2. Continue as described above. 

You can also specify the position and size, rotation, and slant and corner radius properties 
of the drawing object: 

1. Right-click on the drawing object and then click Position and Size from the pop-up 
menu. The Position and Size dialog box is displayed. 

2. Choose any properties, as required. 

Resizing a Drawing Object 

The same considerations for resizing an image apply also to resizing an object. Select the 
object, click on one of the eight handles around it and drag it to its new position. For a 
scaled resizing, select one of the corner handles and keep the Shift key pressed while 
dragging the handle to its new position. 

For more sophisticated control of the size of the object, 

• Select Format > Object > Position and Size from the menu bar. 

• Use the Position and Size dialog box to set the width and height independently. 

• If the Keep ratio option is selected, then the two dimensions change so that the 
proportion is maintained, allowing for a scaled resizing. 
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Grouping Drawing Objects
To group drawing objects:
1. Select one object, then hold down the Shift key and select the others you want to include in the
group. The bounding box expands to include all the selected objects.
2. With the objects selected, hover the mouse pointer over one of the objects and choose Format >
Group > Group from the menu bar or right-click and choose Group > Group from the pop-up menu.
You cannot include an embedded or linked graphic in a group with drawing objects.
Positioning Image/Graphics Within The Text
When you add a graphic to a text document, you need to choose how to position it with respect to the
text and other graphics. The positioning of graphics is often rather time consuming and may be very
frustrating for both inexperienced and experienced users. As Writer is a word processor rather than a
desktop publishing program, there are some limitations to the flexibility in positioning images and it
takes time to get things exactly as you would like them.
Positioning of a graphic is controlled by four settings:
1. Arrangement refers to the placement of a graphic on an imaginary vertical axis. Arrangement

controls how graphics are stacked upon each other or relative to the text.
2. Alignment refers to the vertical or horizontal placement of a graphic in relation to the chosen

anchor point.
3. Anchoring refers to the reference point for the graphics. This point could be the page, or frame

where the object is, a paragraph, or even a character. An image always has an anchor point.
4. Text wrapping refers to the relation of graphics to the surrounding text, which may wrap around the

graphic on one or both sides, be overprinted behind or in front of the graphic, or treat the graphic
as a separate paragraph or character.
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The settings can be accessed in a number of ways, depending on the nature of the 
graphics: 

1. From the Format menu, where you can find Alignment, Arrange, Wrap, and Anchor 
(both for images and drawing objects). 

2. From the pop-up menu displayed when you right-click on the graphic. 

3. From the Object toolbar shown in Figure 1.11. 

4. For images, from the Type and Wrapping pages of the Picture dialog box. Note that 
you cannot control the arrangement using the dialog box. To open the Picture 
dialog box, click on the image to select it and then choose Format > Picture or 
right-click on the graphic and choose Picture on the pop-up menu. 

5. For drawing objects, from the Position and Size page of the Position and Size dialog 
box. To open the Position and Size dialog box, click on the drawing object to select 
it and then choose Format > Object > Position and Size or right-
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click on the graphic and choose Position and Size on the pop-up menu. Note that you 
can only control the alignment and anchoring. 



Home Assignment

PRACTICAL ACTIVITY 

1. Create a New Year card using images 

2. Create a Poster on Health and Hygiene 

QUESTIONS 

1. Explain any four Graphic filters. 

2. Explain Image Cropping 

3. List any three methods of inserting images in a text document. 

4. What do you understand by the terms: 

a. Text Wrapping 

b. Anchoring 



THANKING YOU

ODM EDUCATIONAL GROUP


