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Learning Outcome of this session

• Student will able to IMPLEMENT MAIL MERGE

▪ Demonstrate to print the label using mail merge, do the following to achieve 

▪ Create a main document, 

▪ Create the data source, 

▪ Enter data in the fields, 

▪ Merge the data source with main document, 

▪ Edit individual document, 

▪ Print the letter and address label 



What is mail merge?
OpenOffice.org (OOo) Writer provides very useful features to create and print:

• Multiple copies of a document to send to a list of different recipients (form letters)

• Mailing labels

• Envelopes

All these facilities, though different in application, are based around the concept of a
registered “data source”, from which is derived the variable address information
necessary to their function. This chapter describes the entire process. The steps include:

1. How to create and register a data source.

2. How to create and print form letters, mailing labels, and envelopes.

3. Optionally, how to save the output in an editable file instead of printing it directly



Creating the data source
A data source is a database containing the name and address records (and optionally
other information) from which a mailing list may be derived. Although you can create
and print mailing labels and envelopes without using a data source, in most cases
using one is the best approach. This chapter assumes that you are using a data source.
OOo can access a wide variety of data sources, including spreadsheets, text files and
databases such as MySQL, Adabas, and ODBC. If the information to be used in the mail
merge is currently in a format that OOo cannot access directly, you need to convert it,
for example by exporting it to a comma-separated values (CSV) file. For the following
example we use a spreadsheet with the following column (field) headers: Title, First
name, Last name, Address, State/County, Country, Post Code, Sex, Points. A sample
data source is shown in Figure 1.



Creating the data source

Figure 1: Spreadsheet data source



Registering a data source

For a data source to be directly accessible from within a Writer document, it must first 
be registered as described below. You only need to do this once; after that, the data 
source is available to all documents in OpenOffice.org. 

1. From within any Openoffice.org document, or from the OpenOffice.org Welcome 
screen, choose File > Wizards > Address Data Source.

Figure 2: Starting the Address Data
Source wizard



Registering a data source
2. The choices on the first page of the wizard vary with your operating system. Select 

the appropriate type of external address book. In this example, it is Other external 
data source. Click Next.

Figure 3: Select type of external address book



Registering a data source

3. On the next page of the Wizard, click the Settings button.

Figure 4: Starting the Settings part of the Wizard
4. In the Data Source Properties page, select the Database type. In our example, it is 

Spreadsheet. Click Next.

Figure 5: Selecting the 
database type



Registering a data source

5. In the next dialog box, click Browse and navigate to the spreadsheet that contains
the address information. Select the spreadsheet and click Open to return to this
dialog box. At this time you may wish to test that the connection has been
correctly established by clicking on the Test Connection button (not shown in
illustration).

Figure 6: Selecting the spreadsheet document



Registering a data source
6. Click Finish. 

7. On the following page, click Next. Because this is a spreadsheet, do not click Field 
Assignment.

Figure 7: Because 
this is a 

spreadsheet, do 
not click Field
Assignment.



Registering a data source

8. Name the file in the Location field. The default is ...\Addresses.odb; but you may 
replace Addresses with another name if you wish. You may also change the name 
in the “Address book name” field. In our example, the name “Points” was used for 
both.

Figure 8: Name the 
.odb file and the 

address book.

9) Click Finish. The data source is now registered.



Creating a form letter

You can create a form letter manually, which is the simplest and most comprehensive
method and is described here, or you can use the Mail Merge wizard as described in “Using
the Mail Merge Wizard to create a form letter”. If you select to use the wizard, pay close
attention to its current limitations, as identified within its description.
1. Create a new text document: File > New > Text Document, or open a pre-existing form

letter with File > Open.
2. Display the registered data sources: View > Data sources (or press F4).
3. Find the data source that you wish to use for the form letter, in this case Points. Expand

the Points and Tables folders, and select Sheet1. The address data file is displayed.



Creating a form letter

Figure 9: Selecting the data source.



Creating a form letter
4. Now create or modify the form letter by typing in the text, punctuation, line

breaks, and so on that will be present in all of the letters. To add the mail-merge
fields where needed (such as names and addresses), click in the field heading and
drag it to the appropriate point in the letter. (See Figure 10). Note that address
lines should be in individual paragraphs, not separated by line breaks as might
seem preferable. The reason for this will be made clear in the next step.

Figure 10: Dragging fields to the body of 
the form letter



Creating a form letter
5. Continue until you have composed the entire document. (See Figure 11 for an

example.) At this time you may wish to consider suppressing any blank lines that
may appear in the resulting letters. If not, skip ahead to Step 7.

Figure 11: The completed form 
letter.



Creating a form letter

6. To suppress blank lines:

a) Click at the end of the first paragraph to be suppressed and then choose
Insert > Fields > Other.

b) Select the Functions tab and then click on Hidden Paragraph in the Type
column.

c) Now click in the Condition box and enter the details of the condition that
defines a blank address field. It has the general form of:

! [Database. Table. Database field]

where the ‘!’ (NOT) character indicates the negative case and the square
brackets indicate the condition. For example, in our Points database the
condition to test if the Company field is empty would be:
![Points.Sheet1.Company] as illustrated in Figure 12.

d) Click Insert, but do not close the dialog box until you have amended all the
lines that should be suppressed.



Creating a form letter

Figure 12: Hidden paragraph 
insertion

To test for multiple conditions use the operators AND and/or OR between the conditional 
statements, for example:
![Points.Sheet1.Title]AND![Points.Sheet1.Last Name]



Creating a form letter
The document is now ready to be printed. 

1) Choose File > Print and respond with Yes in the message box. 

2) In the Mail Merge dialog box, you can choose to print all records or selected
records. To select records to be printed, use Ctrl+click to select individual records.
To select a block of records, select the first record in the block, scroll to the last
record in the block, and Shift+click on the last record.

Figure 13: Confirmation message for merging database fields



Creating a form letter

Figure 14: The Mail Merge dialog box



Creating a form letter
3) Click OK to send the letters directly to the printer. If you prefer to save the letters

to a file, perhaps to allow proofreading or some later formatting, select File in the
output section of the Mail Merge dialog box, instead of using the default Printer
selection. This changes the dialog box to display the Save merged document
section, where Save as single document is pre-selected. You can choose to save
each letter as a single, individual document, if preferred.

In this case, clicking OK brings up the Save as dialog box. Enter a file name for the
saved letters. They will be saved consecutively in the single document, or
numbered consecutively in individual files if saved as single documents.

4) If you have not saved the original, prototype form letter document (template)
previously, then you should do so now. Having a form letter template could greatly
simplify the creation of other form letters in the future and is highly
recommended.



Printing mailing labels
To print mailing labels: 

1. Choose File > New > Labels. 

2. On the Options tab, ensure that the Synchronize contents checkbox is selected. 

3. On the Labels tab (Figure 15), select the Database and Table. Select the Brand of 
labels to be used, and then select the Type of label. 

Figure 15: Select Database, Table, 
label Brand, and label Type.



Printing mailing labels
4. Click the dropdown arrow under Database field. Select the first field to be used in 

the label (in this example, Title). Click the left arrow button to move this field to 
the Label text area, as shown in Figure 16.

Figure 16: Move fields from Database field list to Label text area.



Printing mailing labels
5. Continue adding fields and inserting desired punctuation, spaces, and line breaks 

until the label is composed. Figure 17 shows the completed label.

Figure 17: The completed label.



Printing mailing labels
6. Click New Document. You now have a new, single-page document containing a series of frames,

one for each label of the selected type and filled with the data source address fields that you
selected. Quite often some of the fields in your address data source will be unused, leading to
blank lines in your labels. If this is not important, you can skip the next few paragraphs and go
straight to Step 7, otherwise continue as described here.

a) First ensure that the label frames are showing the field contents (data source headings),
rather than their underlying field names. If this is not the case, then either press Ctrl+F9 or
choose View > Field Names to toggle the view.

b) Next, ensure that you can see non-printing characters, such as paragraph marks, line breaks
and so on. If these are not already visible, choose View > Nonprinting Characters from the
menu bar, or press Ctrl+F10, or click on the paragraph icon in the Standard toolbar.

You will now see that address field separation is created by line breaks , rather than
paragraphs . As the suppression of blank address fields depends on hiding paragraphs, not
lines, you need to replace line breaks with paragraphs as follows.

c) Click in the first label, at the end of the last data source address field in the first line of the
label. Press Delete to remove the new line character and then press Return (or the Enter
key) to insert a paragraph marker. Repeat this action for each line in the address. If the line
spacing in the first label is not satisfactory, you may wish to correct this before proceeding,
by modifying the paragraph style associated with the address. Unless you have changed it,
the address uses the Default style.



Printing mailing labels
d) Click again at the end of the first paragraph to be conditionally suppressed and 

then choose Insert > Fields > Other. Select the Functions tab and then click on 
Hidden Paragraph in the Type column. Now click in the Condition box and enter 
the details of the condition that defines a blank address field. It has the general 
form of: 

![Database. Table. Database field] where the ‘!’ (NOT) character indicates the 
negative case and the square brackets indicate the condition. For example, in our 
Points database the condition to test if the Company field is empty would be 
![Points.Sheet1.Company] as illustrated in Figure 12. To test for multiple 
conditions, use the operators AND and/or OR between the conditional 
statements, for example: 

![Points.Sheet1.Title]AND

![Points.Sheet1.Last Name]

Click Insert, but do not close the dialog box until all lines have been amended.

e) Repeat for each paragraph to be conditionally suppressed, remembering to 
advance the cursor to the end of the line in question before changing the last 
element of the condition and Inserting the result.



Printing mailing labels
f) Remembering that we selected Synchronize contents earlier, you should now be able to

see a small window containing a button labelled Synchronize Labels. Click on this
button and the hidden paragraph fields are propagated to all the labels in your
document.

You now have a template suitable for future use with the same data source and type of
label. If you wish to save it, use either File > Templates > Save as, or save it as an Open
Document Text Template (.ott) into the private template directory (folder) that you have
previously defined in

Tools > Options > OpenOffice.org > Paths > Templates.

The labels are now ready to be printed.

1. Choose File > Print. The message shown in Figure 13 appears. Click Yes.

2. In the Mail Merge dialog box (Figure 14), you can choose to print all records or selected
records. To select records to be printed, use Ctrl+click to select individual records. To
select a block of records, select the first record in the block, scroll to the last record in
the block, and Shift+click on the last record.

3. Click OK to send the labels directly to the printer. If you prefer to save the labels to a
file, perhaps to allow some later editing such as changing the typeface or paragraph
format, then you should select File in the output section of the Mail Merge dialog box,
rather than using the default Printer selection. This changes the dialog box to highlight
the Save merged document section, where Save as single document is preselected.



Printing mailing labels
In this case, clicking OK brings up the Save as dialog box, where a file name can be
entered for the saved labels. If you did not save the prototype label fields document
(template) in step 6f, then you are prompted to do so now by another Save as dialog
box.

In either case, whether printing or saving to file, despite there apparently being only
one page of labels, the printed or saved output will be expanded to include all of the
selected records from the data source.



Editing a saved file of mailing labels
To edit a saved file of mailing labels, open the saved label file in the normal way. You
will be prompted as to whether you wish to update all links. Choose No for the
following reason: The first label on the page is termed the “Master Label” and all
other labels are linked to it. If you update the links, then all labels will end up
containing the same data, which may not be what you want.

You can edit individual records in the normal way, by highlighting and changing the
font name, for example.

However, you cannot edit all labels globally (for example, to change the font name for
all records) by the technique of selecting the entire document. To achieve this result
you have to edit the paragraph style associated with the label records as follows:

1. Right-click any correctly spelled word in a label record. Select Edit Paragraph Style
from the pop-up menu. (Note: If you click on a misspelled word, a different menu
appears.)

2. Then from the Paragraph Style dialog box, you can make changes to the font
name, the font size, the indents, and other attributes.



Using the Mail Merge Wizard to create 
a form letter

Open a new document with File > New > Text Document and start the Mail Merge 
wizard using Tools > Mail Merge Wizard. The wizard opens, as shown in Figure 18.

Figure 18:Select starting document



Step 1: Select starting document

The wizard gives various options to select your starting document:

• Use the current document. 

• Create a new document.

• Use a template.

• Use an existing document. 

For the purposes of this description we assume that you opened a new text
document. This will ensure that all the steps in the wizard are fully explored, although
with experience you may find it more practical to use a draft you prepared earlier,
which will allow skipping some steps. Select Use the current document and click Next.



Step 2: Select document type
• The wizard can produce letters or, if a Java Mail connection exists, email messages.

You can see these options in Figure 19. In this example, we are producing a letter.
Select Letter and click Next.

Figure 19: Choose document type



Step 3: Insert address block
This is the most complex step in the wizard. In this step you will do three things:

1. Tell the wizard which data source to use. The data source must be an existing
file; in this example it is the “Points” spreadsheet created earlier.

2. Select the address block to use in the document. This means choosing which
fields appear (for example, whether the country is included) and how they
look.

3. Make sure that the fields all match correctly.

This is very important. For example, the wizard has a field called . If your spreadsheet
has a column called “Surname”, you need to tell the wizard that and “Surname” are
equivalent. This is described in “Matching the fields”



Step 3: Insert address block

Figure 20: Insert address block 



Selecting the data source (address list)
1. If the current address list, identified

beneath the Select Different
Address List button in section 1, is
not the one you wish to use, click
the button to open the Select
Address List dialog box for choosing
a data source.

2. If you have not already created the
address list, you may click Create to
do so now. This step will allow you
to create a CSV (Comma Separated
Values) file with a new list of
address records. If you already
have an address list, as we have in
the “Points” spreadsheet example,
but which is not the one you wish
to use, click Add and select the file
in which it resides. In each of the
above cases a new data source will
be created and registered.

3. Select the address list and click OK to
return to step 3 of the wizard. For this
example, the preceding steps are all you
need to do. The wizard can also exclude
certain records; click Filter to choose them.

Figure 21: Select address list dialog box



Selecting the address block
1. In step 3 of the wizard (shown in Figure 20), look at section 2. This is where you

select the address block to appear on the letter, and define its appearance and the
fields it contains. The main page gives two examples. If neither of those is exactly
what you want, click More to see more choices, in the Select Address Block dialog
box (shown in Figure 22).

2. The Select Address Block dialog box offers six choices for the format of the address
block (scroll down to see the last two choices). You can also optionally include or
exclude the country (for example, only include the country if it is not England). The
six formats provided are relatively common, but they might not exactly match your
preference. If this is the case, select the address block that is closest to what you
want and click Edit, which opens the New Address Block dialog box.



Selecting the address block

Figure 22: Select address block



Selecting the address block
3. In the New Address Block dialog box (Figure 23), you can add or delete address

elements using the arrow buttons on the left. To move elements around, use the
arrow buttons on the right. For example, to add an extra space between first and
last names in Figure 6, click and then click the right arrow button.

Figure 23: New address block 



Matching the fields
Finally, it is time to match the wizard’s fields with the spreadsheet fields, so that items
like and “Surname” match correctly.

1) Look at section 3 of step 3 of the wizard (shown in Figure 20). The box at the
bottom displays one record at a time, using the address block format you selected.
Use the right and left arrow buttons below that address box to step through the
addresses, checking that they display correctly. Do not assume that all the records
display correctly, just because one or two do. Check them all if you can, or at least
a good proportion.

2) If the addresses do not display correctly (and they probably will not right away),
click Match Fields.



Matching the fields
.

Figure 24: Match fields dialog box

The Match Fields dialog box has three
columns:
❖ Address Elements are the terms the wizard

uses for each field, such as <First Name>
and <Last Name>.

❖ Use the Matches to Field column to select,
for each address element, the field from
your data source that matches it.

❖ The Preview column shows what will be
shown for this field from the selected
address block, so you can double-check
that the match is correct.



Matching the fields

3. When you have matched all the fields, click OK to return to step 3 of the wizard.
Now, when you use the arrow buttons to look at all the addresses, they should all
look correct. If not, go back and change anything you’re not happy with, before
clicking Next to move to step 4. Note that you will not be able to continue until
you have correctly matched all the fields in your chosen address block. If you see
in a field position it indicates that the field in question is not correctly matched.

4. Notice the option for Suppress lines with empty fields. Using the Wizard, you do
not have to create your own conditional suppression fields.



Step 4: Create salutation

The salutation is the initial greeting, for example, Dear Mr Jones. In step 4, select the 
salutation that will appear in the letter.

Figure 25: Create a 
salutation



Step 4: Create salutation

You can use a different greeting for men and women. To do this, Writer must have
some way of knowing whether a person is male or female. In our spreadsheet we had
a column called Sex. In the section Address list field indicating a female recipient, set
the field name to Sex and the field value to F. The male salutation is then printed for
all men and the female salutation for all women.

Note You do not need to tell OOo who is a male, because it assumes that all non-
female records are males.

If you do not select Insert Personalized Salutation, you can use a more general
salutation without referring to the recipient directly, such as “To whom it may
concern”. As in step 3, step 4 of the wizard has a preview pane at the bottom. You
should check more than one record to ensure that other records look the way you
expect.



Step 5: Adjust layout
In step 5, you can adjust the position of the address block and salutation on the page.
You can place the address block anywhere on the page. The salutation is always on the
left, but you can move it up and down the page. Use the buttons shown in Figure 9 to
move the elements.

Figure 26: Adjust layout



Step 6: Edit document and insert extra 
fields

In step 6 you have another opportunity to exclude particular recipients from the mail 
merge, as shown in Figure 27.

Figure 27: Edit 
document



Step 6: Edit document and insert extra fields
You can also edit the body of the document. If you started with a blank document, you can 
write the whole letter in this step. Click Edit Document to shrink the wizard to a small 
window (Figure 27) so you can easily edit the letter.

You need to perform another important task in this step. The wizard only inserts
information from the name and address fields, but you may wish to add additional data. In
our example, we want to tell each person how many points they had accumulated during
the year; that information is in the spreadsheet.
To do this:
1) Click Edit Document in step 6 of the wizard.
2) Choose Insert > Fields > Other. The Fields dialog box opens.
3) Click the Database tab.
4) On the left hand side, select Mail merge fields.
5) Under Database selection find your data source (in this example, it is a spreadsheet).

Expand it to see the fields.
6) Click the field you want to insert, then click Insert to insert the field. You can insert any

number of fields any number of times into your mail merge document.
7) Click Close when you are done.

Figure 28: Minimized mail merge wizard



Step 6: Edit document and insert extra fields

Figure 29: Insert mail merge fields dialog box



Step 7: Personalize documents
In step 7, OOo creates all your letters, one per recipient. Clicking the Edit individual
Document button here is similar to step 6. The difference is that you now edit a long
file containing all of the letters, so you can make changes to a particular letter to one
person. In this step of the Mail Merge wizard (Figure 30), click Find to open a dialog
box that allows searches within the document, perhaps for an individual addressee.

Figure 30: Personalize document

As with step 6, when
editing the document,
the wizard shrinks to a
small window (Figure
28). Click on this
window to expand the
wizard to its full size.



Step 8: Save, print or send

You have now completed the mail merge process. The last step is to do something
with it. In step 8, you can save the original sample letter, save the merged document,
print the letters right away or, if you created email messages, send them.

You probably want to save the starting (prototype) document and the merged
document. To do this, select Save starting document to reveal the Save starting
document section containing the Save starting document button. This button will be
active only if the document has not already been saved. Clicking on this button brings
up the standard Save as dialog box. Once you have named and saved the document
you return to the Step 8 dialog box as shown in Figure 28.

The merged document can now be saved by selection of Save merged document. This
will reveal the Save merged document settings section, from which you can select to
save either as one large file containing all the individual, generated letters or as a
separate file for each letter. When you have saved the merged document, you can
print the final letters now or later; and you can still manually check and edit the letters
if necessary. If you elect to print at this stage, the dialog box shown in Figure 32
appears; it should be self-explanatory.



Step 8: Save, print or send

Figure 31: Step 8: Save, print or send



Step 8: Save, print or send

Figure 32: Saving a merged document



Step 8: Save, print or send

Figure 33: Printing the merged document



Home Assignment

PRACTICAL ACTIVITY 

1. Open the Word Processing software and prepare the following labels for 

▪ Schools to invite parents for annual function 

▪ A Tech Magazine who wants to send flyers to its clients 

QUESTIONS 

1. Explain Mail Merge. 

2. What are advantages of Mail Merge? 

3. Give examples of databases in which the Data Source can be created. 



THANKING YOU

ODM EDUCATIONAL GROUP


