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SESSION 1: CREATE AND APPLY STYLES IN THE DOCUMENT 

A style is a set of formats that you can apply to selected pages, text, frames, and other 

elements in your document to quickly change their appearance. When you apply a 

style, you apply a whole group of formats at the same time. 

Styles are logical attributes. Using styles means that you stop saying “font size 14pt, 

Times New Roman, bold, centered”, and you start saying “Title” because you have 

defined the “Title” style to have those characteristics. In other words, styles mean that 

you shift the emphasis from what the text (or page, or other element) looks like, to 

what the text is. 

Styles help improve consistency in a document. They also make major formatting 

changes easy. For example, you may decide to change the indentation of all 

paragraphs, or change the font of all titles. For a long document, this simple task can 

be prohibitive. Styles make the task easy. 

OpenOffice.org supports the following types of styles: 

• Page styles include margins, headers and footers, borders and backgrounds. In 

Calc, page styles also include the sequence for printing sheets. 

• Paragraph styles control all aspects of a paragraph’s appearance, such as text 

alignment, tab stops, line spacing, and borders, and can include character 

formatting. 

• Character styles affect selected text within a paragraph, such as the font and size 

of text, or bold and italic formats. 

• Frame styles are used to format graphic and text frames, including wrapping type, 

borders, backgrounds, and columns. 

• Numbering styles apply similar alignment, numbering or bullet characters, and 

fonts to numbered or bulleted lists. 

• Cell styles include fonts, alignment, borders, background, number formats (for 

example, currency, date, number), and cell protection. 

• Graphics styles in drawings and presentations include line, area, shadowing, 

transparency, font, connectors, dimensioning, and other attributes. 
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• Presentation styles include attributes for font, indents, spacing, alignment, and 

tabs. 

 

Applying styles 

OpenOffice.org provides several ways for you to select styles to apply. 

Using the Styles and Formatting window 

1) Click the Styles and Formatting icon located at the left-hand end of the object 

bar, or click Format > Styles and Formatting, or press F11. 

The Styles and Formatting window shows the types of styles available for the 

OpenOffice (OpenOffice.org) component you are using. 

Figure 1.1 shows the window for Writer, with Page Styles visible. 
 

 

Figure1.1: The Styles and Formatting window for Writer, showing paragraph styles 

 
You can move this window to a convenient position on the screen or dock it to an edge 

(hold down the Ctrl key and drag it by the title bar to where you want it docked). 

2) Click on one of the icons at the top left of the Styles and Formatting window to display 

a list of styles in a particular category. 

3) To apply an existing style (except for character styles), position the insertion point in 

the paragraph, frame, or page, and then double-click on the name of the style in one 

of these lists. To apply a character style, select the characters first. 



4 | P a g e 

[DIGITAL DOCUMENTATION] | IT | STUDY NOTES   

 

 

 

 

Using Fill Format mode 

Fill format mode is used to apply a style to many different areas quickly without having 

to go back to the Styles and Formatting window and double-click every time. This 

method is quite useful when you need to format many scattered paragraphs, cells, or 

other items with the same style. 

1) Open the Styles and Formatting window and select the style you want to apply. 

2) Click the Fill Format mode icon . 

3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, 

page, or frame and click. To apply a character style, hold down the mouse button 

while selecting the characters, clicking on a word applies the character style for that 

word. Repeat step 3 until you made all the changes for that style. 

4) To quit Fill Format mode, click the Fill Format mode icon again or press the Esc 

key. An important point to note here is that when this mode is active, a right-click 

anywhere in the document undoes the last Fill Format action. Be careful not to 

accidentally right click and thus undo actions you want to keep. 

 

Creating New (Custom) Styles 

You may want to add some new styles. You can do this in two ways: 

Creating a new style from a selection 

You can create a new style by copying an existing manual format. This new style 

applies only to this document; it will not be saved in the template. 

1. Open the Styles and Formatting window and choose the type of style you want to 

create. 

2. In the document, select the item you want to save as a style. 

3. In the Styles and Formatting window, click on the New Style from Selection icon 

(refer Figure 1.2). 
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Figure 1.2: Naming a new style created from a selection 

 
4. In the Create Style dialog, type a name for the new style. The list shows the names 

of existing custom styles of the selected type. Click OK to save the new style. 

 

Dragging And Dropping To Create A Style 

You can drag and drop a text selection into the Styles and Formatting window to create 

a new style. 

Select some text and drag it to the Styles and Formatting window. If Paragraph Styles 

are active, the paragraph style will be added to the list. If Character Styles are active, 

the character style will be added to the list. 

 

Modifying Styles 

OpenOffice.org provides several ways to modify styles (both the predefined styles and 

custom styles that you create): 

• Updating a style from a selection 

• Load or copy styles from another document or template 

 

Any changes you make to a style are effective only in the current document. To change 

styles in more than one document, you need to change the template or copy the styles 

into the other documents. 
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Updating A Style From A Selection 
 

To update a style from a selection: 

1. Open the Styles and Formatting window. 

2. In the document, select an item that has the format you want to adopt as a style. 

3. In the Styles and Formatting window, select the style you want to update (single- 

click, not double-click), then long-click on the arrow next to the New Style from 

Selection icon and click on Update Style(Refer Figure 1.3). 
 

Figure 1.3: Updating a style from a selection 
 

Loading Styles From A Template Or Document 

You can copy styles by loading them from a template or another document: 

1. Open the document you want to copy styles into. 

2. In the Styles and Formatting window, long-click on the arrow next to the New Style 

from Selection icon, and then click on Load Styles. 
 
 

Figure 1.4. Copying styles from a template into the open document 
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3. On the Load Styles dialog (Figure 1.4), find and select the template you want to 

copy styles from. 

4. Select the categories of styles to be copied. Select Overwrite if you want the styles 

being copied to replace any styles of the same names in the document you are 

copying them into. 

5. Click OK to copy the styles. You will not see any change on screen. 

 
To copy the styles from another document, click the From File button to open a 

window from which you can select the required document. 

 
ACTIVITY 

 

1. Write your resume/ Bio Data and apply different styles on it, 

2. Create a pamphlet on Cyber Awareness. Apply different styles on it 

 
QUESTIONS 

 

1. What are Styles ?. What are the advantages of using styles 

2. Give any four styles supported by OpenOffice.org 

3. How can we create our own styles 
 

 

 

SESSION 2. INSERT AND USE IMAGES  

Relevant Knowledge 
 

Images can be added to a document in several ways: by inserting an image file, directly 

from a graphics program or a scanner, or from the Open Office Gallery. 

Inserting An Image File 

When the image is in a file stored on the computer, you can insert it into an Open 

Office document using either of the following methods: 
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Drag and Drop 

1. Open a file browser window and locate the image you want to insert. 

2. Drag the image into the Writer document and drop it where you want it to appear. 

A faint vertical line marks where the image will be dropped. 

This method embeds (saves a copy of) the image file in the Writer document. To link 

the file instead of embedding it, hold down the Control+Shift keys while dragging the 

image. 

 
Insert Picture Dialog 

 

1. Click in the Open Office document where you want the image to appear. 

2. Choose Insert > Picture > From File from the menu bar. 

3. On the Insert Picture dialog (see Figure 1.5), navigate to the file to be inserted, 

select it, and click Open. 

At the bottom of the dialog are two options, Preview and Link. Select Preview to 

view a thumbnail of the selected image on the right, so you can verify that you have 

the correct file. See below for the use of Link. 
 

Figure 1.5. Insert picture dialog 
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Inserting An Image From The Clipboard 

Using the clipboard, you can copy images into an Open Office document from another 

Open Office document and from other programs. To do this: 

1. Open both the source document and the target document. 

2. In the source document, select the image to be copied. 

3. Move the mouse pointer over the selected image and press Control+C to copy the 

image to the clipboard. 

4. Switch to the target document. 

5. Click to place the cursor where the graphic is to be inserted. 

6. Press Control+V to insert the image. 

 

If the application from which the graphic was copied is closed before the graphic is 

pasted into the target, the image stored on the clipboard could be lost. 

 
 

Inserting An Image Using A Scanner 

If a scanner is connected to your computer, Open Office can call the scanning 

application and inserted the scanned item into the Open Office document as an image. 

To start this procedure, click where you want the graphic to be inserted and select 

Insert > Picture > Scan > Select Source. 

Although this practice is quick and easy, it is unlikely to result in a high-quality image 

of the correct size. You may get better results by scanned material into a graphics 

program and cleaning it up there before inserting the resulting image into Open Office. 

Inserting An Image From The Gallery 

The Gallery provides a convenient way to group reusable objects such as graphics and 

sounds that you can insert into your documents. The Gallery is available in all 

components of Open Office. It does not come with many graphics, but you can add 

your own pictures or find extensions containing more graphics. To insert a Gallery 

image into a Writer document: 
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1. To open the Gallery, click on the  Gallery  icon (located in the right side of the 

Standard toolbar) or choose Tools > Gallery from the menu bar. 

2. Navigate through the Gallery to find the desired picture. 

3. To insert the picture, click and drag it from the Gallery into the Writer document. You 

can also right-click on the picture and choose Insert>Copy. 

Figure 1.6 shows an example of an image dragged from the Gallery. 
 
 

Figure 1.6. Inserting an image from the Gallery 

 

By default, the Gallery is docked above the Writer workspace. To expand the Gallery, 

position the pointer over the line that divides it from the top of the workspace. When 

the pointer changes to parallel lines with arrows, click and drag downward. The 

workspace resizes in response. 
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To expand the Gallery without affecting the workspace, undock it so it floats over the 

workspace. To do so, hold down the Control key and double-click on the upper part 

of the Gallery next to the View icons. Double-click in the same area while holding 

down the Control key to dock it again (restore it to its position over the workspace). 

When the Gallery is docked, to hide it and view the full Writer workspace, click the in 

the middle of the thin bar separating the Gallery from the workspace. 

To close the Gallery, choose Tools > Gallery to uncheck the Gallery entry, or click 

on the Gallery icon again. 

 

Modifying An Image 

When you insert a new image, you may need to modify it to suit the document. Here 

we will discuss the use of the Picture toolbar, resizing, cropping, and a workaround to 

rotate a picture. 

Using The Picture Toolbar 

When you insert an image or select one already present in the document, the Picture 

toolbar appears. You can set it to always be present (View > Toolbars > Picture). 

Picture control buttons from the Picture toolbar can also be added to the Standard 

Toolbar. 

Two other toolbars can be opened from this one: the Graphic Filter toolbar, which can 

be torn off and placed elsewhere on the window, and the Color toolbar, which opens 

as a separate floating toolbar. 

From these three toolbars, you can apply small corrections to the graphic or obtain 

special effects. 

Graphics mode  

You can change color images to grayscale by selecting the image and then selecting 

Grayscale from the Graphics mode list. 

Flip vertically or horizontally  

To flip an image vertically or horizontally, select the image, and then click the relevant 

icon. 
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Filters 

Table 1 provides a short description of the available filters, however the best way to 

understand them is to see them in action. Feel free to experiment with the different 

filters and filters settings, remembering that you can undo all the changes by pressing 

Ctrl+Zor Alt+Backspaceor by selecting Edit > Undo. 

Color 

Use this toolbar to modify the individual RGB color components of the image (red, 

green, blue) as well as the brightness, contrast, and gamma of the image. If the result 

is not satisfactory, you can press Ctrl+Z to restore the default values. 

Table 1: Graphic filters and their effects 

Icon Name Effect 

 
 

 
 

 
 

 
 

 
 
 

 
 

 

 

 
 
 

 
 

 
 

 
 

 
 

 
 

 

Invert 
Inverts the color values of a color image or the 

brightness values of a grayscale image. 

Smooth Softens the contrast of an image. 

Sharpen Increases the contrast of an image. 

Remove noise Removes single pixels from an image. 

 

Solarization 
Mimics the effects of too much light in a picture. A 

further dialog box opens to adjust the parameters. 

 
Aging 

Simulates the effects of time on a picture. Can be 

applied several times. A further dialog box opens to 

adjust the aging level. 

Posterize 
Makes a picture appear like a painting by reducing 

the number of colors used. 

Pop Art Modifies the picture dramatically. 

Charcoal Displays the image as a charcoal sketch. 

 
Relief 

A dialog box is displayed to adjust the light source 

that will create the shadow and, hence, the relief 

effect. 

Mosaic Joins groups of pixels into a single area of one color. 
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Transparency 

Modify the percentage value in the Transparency box on the Picture toolbar to make 

the image more transparent. This is particularly useful when creating a watermark or 

when wrapping the image in the background. 

 

Using The Formatting Toolbar And Picture Dialog 

When an image is selected, you can customize some aspects of its appearance using 

the tools available on the Formatting toolbar as well as in the dialog that is shown by 

right-clicking on the image and selecting Picture. You can, for example, create a 

border around the image, selecting style and color; or you can (in the Borders page of 

the Picture dialog) add a shadow to the image. 

Cropping Images 

When you are only interested in a section of the image for the purpose of your 

document, you may wish to crop (cut off) parts of it. To start cropping the image, right 

click on it and select Picture from the pop-up menu. In the Picture dialog box, select 

the Crop page (see Figure 1.7). 

 

Figure 1.7: The options available when cropping a picture 
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In the Crop page, you can control the following parameters: 

Keep scale / Keep image size 

 

When Keep scale is selected (default), cropping the image does not change the scale 

of the picture. 

When Keep image size is selected, cropping produces enlargement (for positive 

cropping values), shrinking (for negative cropping values), or distortion of the image 

so that the image size remains constant. 

 

Left, Right, Top, and Bottom 
 

The image is cropped by the amount entered in these boxes. For example, a value of 

3cm in the Left box cuts 3 cm from the left side of the picture. 

• When Keep scale is selected, the size of the image also changes, so in this example 

the width will be reduced by 3 cm. 

• When Keep image size is selected, the remaining part of the image is enlarged 

(when you enter positive values for cropping) or shrunk (when you enter negative 

values for cropping) so that the width and height of the image remains unchanged. 

 
Width and Height 

The Width and Height fields under either Scale or Image size change as you enter 

values in the Left, Right, Top, and Bottom fields. Use the thumbnail next to these 

fields to determine the correct amount by which to crop. 

 
Resizing an Image 

The inserted image might not fit perfectly into the document if it is too big or too small. 

In these cases, you can use Writer to resize the image. 

1. Click the picture, if necessary, to show the green resizing handles. 

2. Position the pointer over one of the green resizing handles. The pointer changes 

shape giving a graphical representation of the direction of the resizing. 
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3. Click and drag to resize the picture. 

4. Release the mouse button when satisfied with the new size. 

The corner handles resize both the width and the height of the graphic object 

simultaneously, while the other four handles only resize one dimension at a time. 

 
To retain the original proportions of the graphic, Shift+click one of the corner handles, 

then drag. Be sure to release the mouse button before releasing the Shift key. 

 
Be aware that re-sizing a bit-mapped (raster) image will adversely affect the 

resolution, causing some degree of blurring. It is better to externally size your picture 

correctly before insertion into your presentation, if possible. 

Figure 1.8 shows three examples of an image inserted into a document and resized. 

Figure 1.8. Three examples of resized images, plus the original image 
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For more accurate resizing, use either the Crop page of the Picture dialog box (Figure 

1.7) or, for images, the Type page of the Picture dialog box. On the Crop page you 

can adjust the following settings: 

 Scale Width and Height: specify in percentages the scaling of the picture. The size 

of the image changes accordingly. For a scaled resizing, both values should be 

identical. 

 Image size: specify the size of the image in your preferred unit of measurement. 

The image enlarges or shrinks accordingly. 

 Original size button: when clicked, restores the image to its original size. 

In the Type page of the Picture dialog box, select the Relative option to toggle 

between percentage and actual dimension. For a scaled resizing, select the Keep ratio 

option. As for the Crop page, clicking on the Original Size button restores the original 

image size. 

 
 

Rotating a Picture 

Writer does not provide a tool for rotating a picture; however, there is a simple 

workaround: 

1. Open a new Draw or Impress document (File > New > Drawing or File > New > 

Presentation). 

2. Insert the image you want to rotate. You can use any of the mechanisms described 

in “Error! Reference source not found.” on page Error! Bookmark not 

defined., although there are some slight variations in the position of the menu 

entries and icons. 

3. Select the image, then in the Drawing toolbar (shown by default at the bottom of 

the window in Impress and Draw), select the Rotate icon from the Effects tear- 

off toolbar . 

4. Rotate the image as desired. Use the red handles at the corners of the picture and 

move the mouse in the direction you wish to rotate. By default the picture rotates 

around its center (indicated by a black crosshair), but you can change the pivot 

point by moving the black crosshair to the desired rotation center. 
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To restrict the rotation angle to multiples of 15 degrees keep the Shift key pressed 

while rotating the image. 

5. Select the rotated picture by pressing Ctrl+A, then copy the image to the clipboard 

with Ctrl+C. 

6. Finish by going back to the location of the Writer document where the image is to 

be inserted and pressing Ctrl+V. 

 
Creating Drawing Objects 

To begin using the drawing tools, display the Drawing toolbar (Figure 1.9), by clicking 

View > Toolbars > Drawing. 
 

Figure 1.9. The Drawing toolbar 

To use a drawing tool: 

1. Click in the document where you want the drawing to be anchored. You can change 

the anchor later, if necessary. 

2. Select the tool from the Drawing toolbar (Figure 7). The mouse pointer changes to 

a drawing-functions pointer . 

3. Move the cross-hair pointer to the place in the document where you want the 

graphic to appear and then click-and-drag to create the drawing object. Release the 

mouse button. The selected drawing function remains active, so you can draw 

another object of the same type. 
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4. To cancel the selected drawing function, press the Esc key or click on the Select 

icon (the arrow) on the Drawing toolbar. 

5. You can now change the properties (fill color, line type and weight, anchoring, and 

others) of the drawing object using either the Drawing Object Properties toolbar or 

the choices and dialog boxes reached by right-clicking on the drawing object. 

Set or Change Properties For Drawing Objects 
 

 

To set the properties for a drawing object before you draw it: 

 
1. On the Drawing toolbar (Figure 9), click the Select tool. 

2. On the Drawing Object Properties toolbar (Figure 1.10), click on the icon for each 

property and select the value you want for that property. 

3. For more control, or to define new attributes, you can click on the Area or Line 

icons on the toolbar to display detailed dialog boxes. 

The default you set applies to the current document and session. It is not retained when 

you close the document or close Writer, and it does not apply to any other document 

you open. The defaults apply to all the drawing objects except text objects. 
 

Figure 1.10. Drawing Object Properties toolbar 

 

To change the properties for an existing drawing object: 

1. Select the object. 

2. Continue as described above. 
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You can also specify the position and size, rotation, and slant and corner radius 

properties of the drawing object: 

1. Right-click on the drawing object and then click Position and Size from the pop- 

up menu. The Position and Size dialog box is displayed. 

2. Choose any properties, as required. 
 

Resizing a Drawing Object 

The same considerations for resizing an image apply also to resizing an object. Select 

the object, click on one of the eight handles around it and drag it to its new position. 

For a scaled resizing, select one of the corner handles and keep the Shift key pressed 

while dragging the handle to its new position. 

For more sophisticated control of the size of the object, 
 

 Select Format > Object > Position and Size from the menu bar. 

 Use the Position and Size dialog box to set the width and height independently. 

 If the Keep ratio option is selected, then the two dimensions change so that the 

proportion is maintained, allowing for a scaled resizing. 

 

Grouping Drawing Objects 

To group drawing objects: 
 

1. Select one object, then hold down the Shift key and select the others you want to 

include in the group. The bounding box expands to include all the selected objects. 

2. With the objects selected, hover the mouse pointer over one of the objects and 

choose Format > Group > Group from the menu bar or right-click and choose 

Group > Group from the pop-up menu. 

You cannot include an embedded or linked graphic in a group with drawing objects. 
 

Positioning Image/Graphics Within The Text 

When you add a graphic to a text document, you need to choose how to position it 

with respect to the text and other graphics. The positioning of graphics is often rather 
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time consuming and may be very frustrating for both inexperienced and experienced 

users. As Writer is a word processor rather than a desktop publishing program, there 

are some limitations to the flexibility in positioning images and it takes time to get 

things exactly as you would like them. 

Positioning of a graphic is controlled by four settings: 

1. Arrangement refers to the placement of a graphic on an imaginary vertical axis. 

Arrangement controls how graphics are stacked upon each other or relative to the 

text. 

2. Alignment refers to the vertical or horizontal placement of a graphic in relation to 

the chosen anchor point. 

3. Anchoring refers to the reference point for the graphics. This point could be the 

page, or frame where the object is, a paragraph, or even a character. An image 

always has an anchor point. 

4. Text wrapping refers to the relation of graphics to the surrounding text, which may 

wrap around the graphic on one or both sides, be overprinted behind or in front of 

the graphic, or treat the graphic as a separate paragraph or character. 

The settings can be accessed in a number of ways, depending on the nature of the 

graphics: 

1. From the Format menu, where you can find Alignment, Arrange, Wrap, and 

Anchor (both for images and drawing objects). 

2. From the pop-up menu displayed when you right-click on the graphic. 

3. From the Object toolbar shown in Figure 1.11. 

4. For images, from the Type and Wrapping pages of the Picture dialog box. Note 

that you cannot control the arrangement using the dialog box. To open the 

Picture dialog box, click on the image to select it and then choose Format > 

Picture or right-click on the graphic and choose Picture on the pop-up menu. 

5. For drawing objects, from the Position and Size page of the Position and Size 

dialog box. To open the Position and Size dialog box, click on the drawing 

object to select it and then choose Format > Object > Position and Size or right- 
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click on the graphic and choose Position and Size on the pop-up menu. Note 

that you can only control the alignment and anchoring. 

Figure 1.11. Object toolbar (graphical control of positioning for images) 

ACTIVITY 

1. Create a New Year card using images 

2. Create a Poster on Health and Hygiene 

QUESTIONS 

1. Explain any four Graphic filters. 

2. Explain Image Cropping 

3. List any three methods of inserting images in a text document. 

4. What do you understand by the terms: 

a. Text Wrapping 

b. Anchoring 
 

 

 
 

Relevant Knowledge 

A template is a model that you use to create other documents. For example, you can 

create a template for business reports that has your company’s logo on the first page. 

New documents created from this template will all have your company’s logo on the 

first page. 

SESSION : 3 CREATE AND USE TEMPLATE 
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Templates can contain anything that regular documents can contain, such as text, 

graphics, a set of styles, and user-specific setup information such as measurement 

units, language, the default printer, and toolbar and menu customization. 

All documents in OpenOffice.org are based on templates. You can create a specific 

template for any document type (text, spreadsheet, drawing, presentation). If you do 

not specify a template when you start a new document, then the document is based on 

the default template for that type of document. If you have not specified a default 

template, Open Office uses the blank template for that type of document that is 

installed with Open Office. 

 

Creating a Template 

You can create your own templates in two ways: from a document, and using a wizard. 

Creating A Template From A Document 

To create a template from a document: 

1. Open a new or existing document of the type you want to make into a template 

(text document, spreadsheet, drawing, presentation). 

2. Add the content and styles that you want. 

3. From the main menu, choose 

File > Templates > Save. 

Template Dialog 

Figure 1.12: Saving a new template 

The Templates dialog opens (see Figure 1.12). 
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1. In the New template field, type a name for the new template. 

2. In the Categories list, click the category to which you want to assign the template. 

The category you choose has no effect on the template itself; it is simply the 

folder in which you save the template. Choosing an appropriate category makes 

it easier to find the template when you want to use it. For example, you might 

save Impress templates under the Presentations category. 

3. Click OK to save the new template. 

Any settings that can be added to or modified in a document can be saved in a template. 

For example, below are some of the settings that can be included in a Writer document 

and then saved as a template for later use: 

1. Printer settings: which printer, single sided / double sided, and paper size, and so 

on 

2. Styles to be used, including character, page, frame, numbering and paragraph 

styles 

3. Format and settings regarding indexes, tables, bibliographies, table of contents 

Templates can also contain predefined text, saving you from having to type it every 

time you create a new document. For example, a letter template may contain your 

name, address and salutation. 
 

Creating A Template Using A Wizard 

You can use wizards to create templates for letters, faxes, agendas, presentations, and 

Web pages. For example, the Fax Wizard guides you through the following choices: 

1. Type of fax (business or personal) 

2. Document elements like the date, subject line (business fax), salutation, and 

complementary close 

3. Options for sender and recipient information (business fax) 

4. Text to include in the footer (business fax) 
 

Creating a template using a wizard: 

 
1. From the main menu, choose File > Wizards >[type of template required](see 

Figure 1.13). 
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Figure 1.13. Creating a template using a wizard 

 
1. Follow the instructions on the pages of the wizard. This process is slightly 

different for each type of template, but the format is very similar. 

2. In the last section of the wizard, you can specify the name and location for saving 

the template. The default location is your user templates directory, but you can 

choose a different location if you prefer. 

3. Finally, you have the option of creating a new document from your template 

immediately, or manually changing the template. For future documents, you can 

reuse the template created by the wizard, just as you would use any other 

template. 

 

Setting A Default Template 

If you create a document by choosing File > New > Text Document (or Spreadsheet, 

Presentation, or Drawing) from the main menu, Open Office creates the document 

from the Default template for that type of document. You can, however, set a custom 

template to be the default. You can reset the default later if you choose. 

Setting a custom template as the default 

You can set any template to be the default, as long as it is in one of the folders displayed 

in the Template Management dialog. 
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To set a custom template as the default: 

1. From the main menu, choose File > Templates > Organize. The Template 

Management dialog opens. 

2. In the box on the left, select the folder containing the template that you want to 

set as the default, then select the template. 

3. Click the Commands button and choose Set As Default Template from the drop- 

down menu. 

The next time that you create a document by choosing File > New, the document will 

be created from this template. 

Resetting the default template 

To re-enable Open Office’s Default template for a document type as the default: 

1. In the Template Management dialog, click any folder in the box on the left. 

2. Click the Commands button and choose Reset Default Template from the drop- 

down menu. 

The next time that you create a document by choosing File > New, the document will 

be created from Open Office’s Default template for that document type. 

Using The Template 

To use a particular template, choose File > New > Templates and Documents. You'll 

see the templates window and your templates; if you don't, select the Templates icon 

at the left. 

Figure 1.14. Opening templates 
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Select the template you want. Any information about the template will be displayed. 

Figure 1.15.  Using a template 

 
Double-click the template or click on open to open it. Now you can use the template 

according to your choice. 

 
Changing To A Different Template 

To change to a different template, choose File > New > Templates and Documents. 

You'll  see  the  templates  window  and  your   templates;  if   you   don't,  select   

the Templates icon at the left. 

Figure 1.16.  Opening templates 
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Select the template you want. Any information about the template will be displayed. 

Figure 1.17. Changing to a different template 

Double-click the template or click on open to open it. Now you can use the template 

according to your choice. 

 

Updating a Document 

To update a document simply goto File Save As and all changes made to the 

document will be saved. 

 

 
ACTIVITY 

 

Create your own template for any topic of your subject. 

 

 

QUESTIONS: 

1. What are templates? What are the advantages of using templates? 

2. What is the difference between styles and templates? 

3. Explain different ways of creating a template. 
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SESSION 4. CREATE AND CUSTOMIZE TABLE OF CONTENTS 
 

 

Creating a Table of Contents 
 

Writer’s table of contents feature lets you build an automated table of contents from 

the headings in your document. Before you start, make sure that the headings are styled 

consistently. For example, you can use the Heading 1 style for chapter titles and    

the Heading 2 and Heading 3 styles for chapter subheadings. 

 

Opening Writer's Table Of Contents Feature 

Although tables of contents can be customized extensively in Writer, often the default 

settings are all you need. Creating a quick table of contents is simple: 

1. When you create your document, use the following paragraph styles for different 

heading levels (such as chapter and section headings): Heading 1, Heading 2,  

and Heading 3. These are what will appear in your table of contents. You can use 

more levels of headings, but the default setting is to use only the first three levels 

in the table of contents. 

2. Place the cursor where you want the table of contents to be inserted. 

3. Select Insert > Indexes and Tables > Indexes and Tables. 

4. Change nothing in the Insert Index/Table dialog. Click OK. 

 
 

If you add or delete text (so that headings move to different pages) or you add, delete, 

or change headings, you need to update the table of contents. To do this: 

 

1. Place the cursor within the table of contents. 

2. Right-click and select Update Index/Table from the pop-up menu. 
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Figure 1.14. The Index/Table tab. 

 

Using the Index/Table tab 
 

Use the Index/Table tab, pictured in Illustration 1 on page 1, to set the table's 

attributes. 

 

Setting Basic Attributes 
 

To set the table's basic attributes: 

 

1. From the Type drop-down list in the Type and title area of the tab, select Table of 

Contents if it isn't already selected. 

2. From the drop-down list in the Create index/table area, select Entire document. 

3. In the Create from area, check the Outline check box. 

4. In the Create from area, clear the Index marks check box. 
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Adding A Title 
 

If you'd like the table of contents to have a title, enter it in the Title field. (If Writer 

entered a title in this field automatically, you can change it by simply typing over the 

value.) To delete the title, clear the Title field. 

 

Protecting Against Manual Changes 
 

To protect the table of contents from being changed accidentally, check the Protected 

against manual changes check box. 

 

If this box is checked, the table of contents can only be changed using the context menu 

or the Insert Table/Index window. 

 

If the box isn't checked, the table of contents can be changed directly on the document 

page, just like other text. 

 

Changing The Number Of Levels 
 

By default, Writer evaluates 10 levels of headings when it builds the table of contents. 

 

To change the number of levels evaluated, enter the desired number in the Evaluate up 

to level spin box. 

 

Assigning Custom Styles 
 

Writer automatically assigns to the table of contents all paragraphs formatted with the 

default heading styles (Heading 1, Heading 2, and so on). To assign paragraphs 

formatted with custom styles, follow these steps: 

 

1. In the Create from area, check the Additional Styles check box. 

2. Click the (...) button to the right of the check box. The Assign Styles window opens. 
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Figure 1.15. Assign Styles window 

 

3. In the Not applied column, click the style that you want to assign to the table of 

contents. 

 

4. Use the >> button to move the selected style to the desired outline level. For 

example, if you want paragraphs formatted with the selected style to appear as top- 

level entries in the table of contents, click the >> button once to move the style into 

the 1 column. To move the style in the opposite direction, use the << button. 

 

5. Click OK to save your changes and return to the Index/Table tab. Or, click Cancel 

to return without saving your changes. 

 

Using The Entries Tab 
 

Use the Entries tab, pictured in Illustration 3 on page 4, to format the entries in the 

table of contents. For each outline level, you can add and delete elements, such as 

chapter numbers, and you can also apply character styles to individual elements. 
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Figure 1.16.  Entries tab 

 

To begin, click a level number in the Level column to select the outline level whose 

elements you want to format. (You'll be able to apply your changes to all outline levels 

later.) The Structure line displays the elements for entries in that level. Each button on 

the Structure line represents one element: 

 

 The E# button represents the chapter number. 

 The E button represents the entry text. 
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 The T button represents a tab stop. 

 The # button represents the page number. 

 The LS button represents the start of a hyperlink. (This button doesn't appear on the 

default Structure line.) 

 The LE button represents the end of a hyperlink. (This button doesn't appear on the 

default Structure line.) 

 

Each white field on the Structure line represents a blank space. 

 

Deleting Elements 
 

To delete an element from the Structure line, click the button that represents that element 

and then press the Delete key on your keyboard. For example, to delete a tab stop, click 

the T button and then press the Delete key. 

 

Adding Elements 
 

To add an element to the Structure line, follow these steps: 

 

1. Place your cursor in the white field to the left of where you want to insert the element. 

2. Click one of the five buttons that are just below the Structure line. (For example, to 

add a tab stop, click the Tab stop button.) A button representing the new element 

appears on the Structure line. 

Note that if you insert a hyperlink, you must indicate both the beginning and end of the 

link. For example, to change the default Structure line so that the chapter number and the 

entry text form a hyperlink, follow these steps: 

 

1. On the Structure line, place your cursor in the white field to the left of theE# button. 

(Recall that the E# button represents the chapter number.) 

2. Click the Hyperlink button. An LS button, representing the start of the hyperlink, 

appears on the Structure line. 

3. On the Structure line, place your cursor in the white field to the right of theE button. 

(Recall that the E button represents the entry text.) 

4. Click the Hyperlink button again. An LE button, representing the end of the hyperlink, 

appears on the Structure line. 



35 

[DIGITAL DOCUMENTATION] | IT | STUDY NOTES   

 

 

 

Applying Character Styles 
 

To apply a character style to an element on the Structure line: 

 

1. On the Structure line, click the button that represents the element to which you want 

to apply a style. 

 

2. From the Character Style drop-down list, select the desired style. Writer applies the 

selected style to the selected element. 

 

To view or edit the attributes of a character style, select the style from the Character 

Style drop-down list and then click the Edit button. 

 

Applying Changes To All Outline Levels 
 

To apply the displayed structure and formatting to all outline levels, click the All button. 

 

Using The Styles Tab 
 

Use the Styles tab, pictured in Illustration 4 on page 6, to apply paragraph styles to the 

table of contents. You can apply a different paragraph style to each outline level of the 

table. 
 

 

Figure 1.17.  Styles tab 
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To apply a paragraph style to an outline level, follow these steps: 

 

1. In the Levels list box, select the desired outline level by clicking it. 

2. In the Paragraph Styles list box, click the paragraph style that you want to apply. 

3. Click the < button to apply the selected paragraph style to the selected outline level. 

 
To remove paragraph styling from an outline level: 

 

1) In the Levels list box, select the desired outline level by clicking it. 

2) Click the Default button. 

To view or edit the attributes of a paragraph style, click the style in the Paragraph Styles 

list box and then click the Edit button. 

 

Using The Background Tab 
 

Use the Background tab, pictured in Illustration 5 on page 7, to add color or a graphic to 

the table background. 

 

Adding Color 
 

To add color to the background of th 

 

e table of contents, simply click the desired color in the color grid. 
 

 

Figure 1.18.  Background tab 
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Adding A Graphic 
 

To add a graphic to the background of the table of contents, follow these steps: 

 

1. From the As drop-down list, select Graphic. The Background tab displays the graphics 

options. 
 

 

Figure 1.19. Graphics options on the Background tab 

 

1. Click the Browse button. The Find Graphics window opens. 

 

2. Find the graphic file that you want to use and then click the Open button. The Find 

Graphics window closes and the selected graphic appears in the graphic preview box 

on the right-hand side of the Background tab. (If you don't see the graphic, check the 

Preview check box underneath the graphic preview box.) 

 

3. In the Type area of the Background tab, choose how you want the background graphic 

to appear: 

 

● To position the graphic in a specific location in the background, select Position and 

then click the desired location in the position grid. 

 

● To stretch the graphic so that it fills the entire background area, select Area. 

 

● To repeat the graphic across the entire background area, select Tile. 
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Deleting Color Or Graphics 
 

To delete color or graphics from the table background, follow these steps: 

 

1. From the As drop-down list, select Color. 

2. Click No Fill on the color grid. 

 
 

Saving The Table Of Contents 

To save the table of contents so that the table appears in your document, click OK. The 

Insert Index/Table window closes and the table of contents appears in your document. 

 
 

Maintaining A Table Of Contents Editing A Table Of Contents 

To edit an existing table of contents: 

1. Click anywhere in the table of contents and then right click. The context menu 

appears. 

2. From the context menu, choose Edit Index/Table. The Insert Index/Table window 

opens and you can edit and save the table using the four tabs described in the previous 

chapter. 

 
Updating A Table Of Contents 

To update a document's table of contents when changes are made to the document: 

1. Click anywhere in the table of contents and then right click. The context menu 

appears. 

2. From the context menu, choose Update Index/Table. Writer updates the table of 

contents to reflect the changes in the document. 

 

Deleting A Table Of Contents 

To delete the table of contents from a document: 

1. Click anywhere in the table of contents and then right click. The context menu 

appears. 

2. From the context menu, choose Delete Index/Table. Writer deletes the table of 

contents. 
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Note: Writer won't prompt you to confirm the delete! Use caution when deleting a table 

of contents. 

ACTIVITY 

Create a table of contents for topics of any subject of your choice. 

QUESTIONS: 

1. Create table of contents for your project. 

2. Create a document in Word on a topic of your choice of minimum 10 pages. 

Format the document with various fonts (minimum 12, maximum 15) and margins 

(minimum 2, maximum 4). 

The document should include a) A bulleted or numbered list 

b) A table containing relevant details 

c) A picture of lion using clip art gallery 

d) An example of word art 

e) A header with student name & date 

f) A footer with pagination Create a table of contents for this document. 
 

 

 
 

SESSION 5. IMPLEMENT MAIL MERGE  
 

 

Advance concept of mail merge in word processing 

A mail merge is a way to take a letter you’ve written and send it to a whole bunch of 

people, personalizing it with information about them so they might think that you typed 

that letter personally for them. A mail merge can also be a quick way to take a list of 

people’s mailing addresses and generate labels or envelopes with the address for a 

different person on each label or envelope. In short, it’s a way to be personal, yet efficient. 

It’s essential for any person or organization that has a lot of clients, partners, parents and 

children, or other people to communicate with. 

Create a Mail Merge Document: Letter 

1. Open a template, if you have one you want to use, or create a new Writer document. 
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2. Save the document with the appropriate name, like mailmerge_openenrollment.ods or 

mailmerge_parents.odt. 

Note: Don’t save it in Word format. You must save it in OpenOffice.org Writer format or 

the mail merge won’t work. 

3. Write out the text that will be going to everyone, and plan where you want the fields. 

For instance, you might know that you are going to have an address block at the top of 

the letter, so you’ll leave a few blank lines for that. Then you’d write something like this, 

know that you’d add the fields firstname and years_of_service later: 

 
 

If you’re doing anything complex and this is your first mail merge letter, write out the 

letter completely as you want it to read including sample data. Use all the text, including 

samples for firstname, lastname, etc. This will help you determine which fields you need 

to use, where you need spaces before and after fields, etc. 

In the following example, for instance, if you want to communicate this, you’ll need to 

use fields from the database for title, lastname, childs_name, study_area, and test_score. 
 

 

 
Dear , 

Remember that next month is open enrollment for benefits. Employees with over five 

years of experience are also eligible for sabbatical; you have been with us for years so 

please get your application in early if you plan to apply. 

Regards, 

Human Resources 

 
Dear Ms. Smithson, 

Your child Jenny is such a joy to have in the classroom. Her score on her Social Studies 

test score last Friday was A-. 

Regards, 

Mr. Thomson 
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4. Once you have the letter written out and you know what fields you need, you can delete 

the specific data like “Ms. Smithson” and insert the fields from the database instead. 

 

To Make The Data Source And Entering Data 

OpenOffice.org is set up with a middle-man file in the mail merge process to make 

merging work easily. You’ll create a small file, one for each spreadsheet or other data 

source. Once you create it, you don’t have to do it again. 

1. Choose File > New > Database. You’ll see this window: 
 

Figure 1.20 : Database Wizard 
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3.  Select the type of data: spreadsheet data, text file data, your particular type of  

address book, or the type of database you’re using like Access or mySQL. It’s very 

important to select the right type. 
 
 

Figure 1.21 : Selecting the database type in Database Wizard 

 

3. Click Next. 

4. What you do here depends on what you chose as the type of data you’re working with. 

 
 

Spreadsheet 

You’ll see this window. Click the Browse button and find the spreadsheet containing your 

data. Then click Next and continue to step 5. 
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Figure 1.22 : Selecting the spreadsheet in Database Wizard 

Text File 

You’ll see this window. Click the Browse button and find the directory containing your 

text files. 

Figure 1.23: Selecting the text file in Database Wizard 
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Fill out the rest of the information: 

Specify the type of files you want to access: Specify whether the file name ends in .txt 

or .csv. 

Row format: In the Field Separator list, specify what character separates each column: a 

tab, a comma, etc. Tab and comma are common. In the other lists, if 11111you don’t 

know the characters used to indicate each type of information, just leave the defaults as 

is. 

Then click Next and continue to step 5. 

Access 

You’ll see this window. Click the Browse button and find the .mdb Access file containing 

your data. Then click Next and continue to step 5. 

Figure 1.24 : Selecting the Access database in Database Wizard 
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Address book 

You don’t have to specify anything if you choose to get your data from your email address 

book; the system automatically finds it. Continue to step 5. 

5. In this window, just be sure to keep the option for registering selected. Unmark the 

selection to open the database for editing unless you want to see the database editing 

window. (You don’t need to unless you want to make a query or other database-related 

item, which we haven’t talked about yet.) 

Figure 1.25 : Deciding how to proceed after saving the database in Database Wizard 

Click Finish. 

6. You’ll be prompted to save the database file. Name it something very descriptive; this 

is the name you’ll be looking for when you’re adding database files to your mail merge 

documents. The name can be the same as the data source that you’re basing it on, or 

entirely different. The file will end in .odb and be stored in whatever directory you 

choose. It doesn’t have to be in the same directory as the data. 
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Figure 1.26 : Saving the database 

7. You can see your databases by pressing F4 when you’re in a Writer or Calc document. 

Click the + icon next to the database you created to see the items named Queries and 

Tables. Click the + next to Tables to see the tables you created; select a table to see the 

data in it. 

Figure 1.27 :Viewing the content in selected table 

 
 

When you’re done viewing your databases, press F4 again to hide the pane. 
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You’re done creating the database file. You only need to do this once for every 

spreadsheet, database, or directory of text files. 

 

Merging The Data Source With Main Document 

1. Open the letter you want to use. 

2. Once you have the letter written out and you know what fields you need, you can 

delete the specific data like “Ms. Smithson” and insert the fields from the database 

instead. 

Press F4. Click the + next to the database you want, then click the + next to Tables and 

the + next to the table you want. 

 

Figure 1.28 :Viewing the content in selected table 

3. Now just drag the field you want into the letter, to the place you want it. 

a. Click and hold down on the name of the first field you want. Don’t click on the data, like 

Smithson; click on the name of the field, like lastname. 

 

Figure 1.29 : Selecting the field to insert in the document 
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b. Drag the field name into the letter to the place where you want it. The mouse will have 

a + attached to it as shown. 
 

c. Release the mouse. The field will appear. You won’t see the data yet; you’ll see the 

field name. 

 

 
4. If you didn’t get it exactly where you want it, just select it, and cut and paste it to 

the place where you want it. The easiest way to select a field is to click on the right side 

of it, hold down the Shift key, and press the left keyboard key once. Then it’s selected 

and you can cut or copy. 

5. Drag in all the other fields you want, the same way. If you want a field in the letter 

twice, you can drag it twice, or drag it in once, then copy and paste it to the other location. 

6. The fields should display with a gray background, as shown. It won’t print; it just 

helps you see which text is from the database and which text you typed. 

7. Format the document any way you want it. The fields respond to formatting the 

same way that normal text does. 

8. You’re done creating the mail merge document. You only need to do this once. The 

next step is to either print the letter to a printer, or “print” to a Writer file so you can see 

all the data merged, and so you can customize, before printing on paper. Continue to the 

printing step. 

Editing a saved file of mailing labels 

To edit a saved file of mailing labels, open the saved label file in the normal way. You 

will be prompted to update all links. Choose No for the following reason: The first label 

on the page is termed the “Master Label” and all other labels are linked to it. If you update 

the links, then all labels will end up containing the same data, which is probably not what 

you want. You can edit individual records in the normal way, by highlighting and 

changing the font name, for example. 
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However, you cannot edit all labels globally (for example, to change the font name for all 

records) by the technique of selecting the entire document. To achieve this result you have 

to edit the paragraph style associated with the label records as follows. 

 
● Right-click any correctly spelled word in a label record. 

- Select Edit Paragraph Style from the context menu. (Note: If you click on a misspelled 

word, a different menu appears.) 

- Then from the Paragraph Style dialog, you can make changes to the font name, the font 

size, the indents, and other attributes. 

 
Printing Mailing Labels 

Before beginning this process, note the brand and type of labels you intend to use. 

 

Preparing For Printing 

To prepare mailing labels for printing: 

● Choose File > New > Labels. 

● On the Options tab, ensure that the Synchronize contents option is selected. ● On 

the Labels tab (), select the Database and Table. Select the Brand of labels to be used, 

and then select the Type of label. 

● If you are unable to identify your label product in the list, then you can define the labels 

you have. Select the User setting in the Type selection box. Click on the Format tab of 

the Labels dialog. The default settings are shown in . Take a ruler and measure on your 

labels those dimensions illustrated in , and enter them into the respective boxes on the left 

side. 

Figure 1.30 : Required information for label set-up 



50 

[DIGITAL DOCUMENTATION] | IT | STUDY NOTES   

 

 

 

 

Figure 1.31: Select Database, Table, label Brand, and label Type 
 

 
 

Figure 1.32: User label default settings 
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● You can now save your label template if you are likely to use it again. Click Save. 

● In the Save Label Format dialog that opens (), enter names for your label Brand 

and Type. Click OK. 
 
 

Figure 1.33: Name and save the label. 

● Click the Labels tab. Click the drop-down arrow under Database field. Select the 

first field to be used in the label (in this example, Title). Click the left arrow button to 

move this field to the Label text area, as shown in Figure. 

 

Figure 1.34: Move fields from Database field list to Label text area 

● Continue adding fields and inserting desired punctuation, spaces, and line breaks 

until the label is composed. shows the completed label. 
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Figure 1.35: The completed label 

● Click New Document. You now have a new, single-page document containing a series 

of frames, one for each label of the selected type and filled with the data source address 

fields that you selected. Quite often some of the fields in your address data source will be 

unused, leading to blank lines in your labels. If this is not important, go to “” on page; 

otherwise, continue with “”. 

 
Removing Blank Lines From Labels 

● First ensure that the label frames are showing the field contents (data source 

headings), rather than their underlying field names. If this is not the case, then either press 

Ctrl+F9 or choose View > Field Names to toggle the view. 

● Next, ensure that you can see non-printing characters, such as paragraph marks, 

line breaks and so on. If these are not already visible, choose View > Nonprinting 

Characters from the Menu bar, or press Ctrl+F10, or click on the Nonprinting 

Characters icon ( ) on the Standard toolbar. 
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You will now see that address field separation is created by line breaks ( ), rather than 

paragraphs ( ). As the suppression of blank address fields depends on hiding paragraphs, 

not lines, you need to replace line breaks with paragraphs as follows. 

● Click in the first label, at the end of the last data source address field in the first 

line of the label. Press Delete to remove the new line character and then press Return (or 

the Enter key) to insert a paragraph marker. Repeat this action for each line in the address. 

If the line spacing in the first label is not satisfactory, you may wish to correct this before 

proceeding, by modifying the paragraph style associated with the address. 

Unless you have changed it, the address uses the Default style. 

 

 

● Click again at the end of the first paragraph to be conditionally suppressed and then 

choose Insert > Fields > Other. Select the Functions tab and then click on Hidden 

Paragraph in the Type column. Now click in the Condition box and enter the details of 

the condition that defines a blank address field. It has the general form of: 

![Database.Table.Database field] where the „!‟ (NOT) character indicates the negative 

case and the square brackets indicate the condition. 

For example, in our Points database the condition to test if the Last Name field is empty 

would be 

![Points.Sheet1.Last Name] as illustrated in . 

To test for multiple conditions, use the operators AND and/or OR between the conditional 

statements, for example: 

![Points.Sheet1.Title]AND![Points.Sheet1.Last Name] 

Click Insert, but do not close the dialog until all lines have been amended. 

● Repeat for each paragraph to be conditionally suppressed, remembering to advance 

the cursor to the end of the line in question before changing the last element of the 

condition and Inserting the result. 

 
Note: The last paragraph of the label address block ends with a special field, Next record: 

Database. Table (Next record: Points.Sheet1in our example), and the Hidden paragraph 

Note: The objective of step 3) is to replace all line breaks at the end of data source address 

fields with paragraphs. Sometimes the address data field may be longer than the width of 

the label and will wrap to the next physical line: make sure that you are not misled by this 

into deleting and replacing anything other than line break characters. 
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field must be inserted before this field. This can generally be accomplished by clicking at 

the end of the paragraph and then using the Left Arrowkey once to skip back over it. A 

clue that you omitted this action is the observation that some records have been skipped 

and are missing from the final output. 

 

● Remembering that we selected Synchronize contents earlier, you should now be 

able to see a small window containing a Synchronize Labels button. Click on this button 

and the hidden paragraph fields are propagated to all the labels in your document. 

You now have a template suitable for future use with the same data source and type of 

label. If you wish to save it, use File > Templates > Save as Template to save it as an 

Open Document Text Template (.ott) into the My Templates folder in the Templates 

Manager dialog. 

 

Printing 

● Choose File > Print. The message shown in appears. Click Yes to print. 

● In the Mail Merge dialog (), you can choose to print all records or selected records. 

To select records to be printed, use Ctrl+click to select individual records. To select 

a block of records, select the first record in the block, scroll to the last record in the 

block, and Shift+click on the last record. 

● Click OK to send the labels directly to the printer. 

If you prefer to save the labels to a file, perhaps to allow some later editing such as 

changing the typeface or paragraph format, then you should select File in the output 

section of the Mail Merge dialog, rather than using the default Printer selection. This 

changes the dialog to highlight the Save merged document section, where Save as single 

document is preselected. 

In this case, clicking OK brings up the Save as dialog, where a file name can be entered 

for the saved labels. 

If you did not save the prototype label fields document (template) in Step 6 of the 

Removing blank lines from documents paragraph, then you are prompted to do so now by 

another Save as dialog. 
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In either case, whether printing or saving to file, despite there apparently being only one 

page of labels, the printed or saved output will be expanded to include all of the selected 

records from the data source. 

 
Printing to a File for Previewing or Customizing Before Printing on Paper 

To print to a file – that is, to just generate a Writer document with the merged results – 

select File and Save as Single Document. Then click OK. 

 

Figure 1.36: Mail Merge Dialog box 

You’ll be asked to give a file name. This is the name of the merged document. Name it 

and click Save. 
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Figure 1.37: Saving the merged document 

You’ll see the print monitor counting through the records. 

 
Now choose File > Open and open that file you just named. 

Note: When you open the output from merged labels, don’t click yes when you see this 

message. Click No. If you click Yes accidentally, just close it without saving, and 

reopening it, clicking No this time. 

 

You’ll see the merged results. 

Here’s one example of a merged letter: 
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Figure 1.38: The merged document 

And merged labels: 

Figure 1.39: The merged labels 
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At this point you can view the document and proof it, make any changes you want, and 

save it. Then to print it, just print it like a normal document, since it’s already merged 

with the data from the database. 

 
ACTIVITY 

1. Type a letter inviting friends and/or family to a party you are hosting. For example, 

you can host a birthday party or your parents‟ anniversary party. You pick the event. 

Your letter will serve as your form letter. Save your letter as Mail Merge Letter. 

2. Format the letter as left aligned (block letter) with .5” or 1” margins depending on 

the length. 

3. Make sure your address is listed at the top of the document. Then insert two blank 

lines and put the date in the month, date, year format. Then enter four blank lines 

and leave space for your merge fields. Example: 

Title First Name Last 

Name Address 1 

Address 2 City, 

State Pin Code 

(Eventually you will be entering your merge fields to replace this information.) 

4. Create a data source with the names and addresses of at least five families in which 

you wish to mail the letters. Create fields such as: title, first name, last name, address 

1, address 2, city, state, and pin code. Or make appropriate field names of your 

choice but make sure you include the address information. Save your data source as 

Mail Merge Data. 

5. Now, return to your main document (Mail Merge Letter) and set it as the form 

document and identify your data source. 

6. Enter your merge fields into your main document. Merge fields should be used for 

the recipients address and after Dear. 

7. After your merge fields are entered merge the document and save it. Save the 

merged document as Mail Merge Merged. 

8. Create labels inserting your merge fields for the recipient’s name and address. Save 

the merged labels as Mail Merge Labels. 

9. Print your form letter, one merged letter, and one label. 
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Let's Practice 

Open the Word Processing software and prepare the following labels for 

• Schools to invite parents for annual function 

• A Tech Magazine who wants to send flyers to its clients 

 
 

QUESTIONS 

1. Explain Mail Merge. 

2. What are advantages of Mail Merge? 

3. Give examples of databases in which the Data Source can be created. 


	Using the Styles and Formatting window
	Using Fill Format mode
	Creating New (Custom) Styles
	Creating a new style from a selection
	Dragging And Dropping To Create A Style
	Modifying Styles

	Updating A Style From A Selection
	Loading Styles From A Template Or Document
	ACTIVITY
	QUESTIONS
	SESSION 2. INSERT AND USE IMAGES
	Inserting An Image File
	Drag and Drop

	Insert Picture Dialog
	2. Choose Insert > Picture > From File from the menu bar.

	Inserting An Image From The Clipboard
	Inserting An Image Using A Scanner
	Inserting An Image From The Gallery
	Modifying An Image
	Using The Picture Toolbar
	Graphics mode
	Flip vertically or horizontally
	Filters
	Color
	Table 1: Graphic filters and their effects

	Using The Formatting Toolbar And Picture Dialog
	Cropping Images
	Keep scale / Keep image size

	Left, Right, Top, and Bottom
	Width and Height
	Resizing an Image
	Rotating a Picture
	Creating Drawing Objects
	View > Toolbars > Drawing.
	Figure 1.9. The Drawing toolbar


	Set or Change Properties For Drawing Objects
	Resizing a Drawing Object
	Grouping Drawing Objects
	Positioning Image/Graphics Within The Text
	ACTIVITY
	QUESTIONS

	Relevant Knowledge
	Creating a Template
	Creating A Template From A Document
	File > Templates > Save.

	Creating A Template Using A Wizard
	Creating a template using a wizard:

	Setting A Default Template
	Setting a custom template as the default
	Resetting the default template
	Using The Template
	Changing To A Different Template
	Updating a Document
	ACTIVITY


	SESSION 4. CREATE AND CUSTOMIZE TABLE OF CONTENTS
	Creating a Table of Contents
	Opening Writer's Table Of Contents Feature
	3. Select Insert > Indexes and Tables > Indexes and Tables.

	Using the Index/Table tab
	Setting Basic Attributes
	Adding A Title
	Protecting Against Manual Changes

	Changing The Number Of Levels
	Assigning Custom Styles
	Using The Entries Tab
	Deleting Elements
	Adding Elements
	Applying Character Styles
	Applying Changes To All Outline Levels
	Using The Styles Tab
	Using The Background Tab
	Adding Color
	Adding A Graphic
	Deleting Color Or Graphics
	Saving The Table Of Contents
	Maintaining A Table Of Contents Editing A Table Of Contents
	Updating A Table Of Contents
	Deleting A Table Of Contents
	ACTIVITY
	QUESTIONS:
	SESSION 5. IMPLEMENT MAIL MERGE
	Create a Mail Merge Document: Letter

	To Make The Data Source And Entering Data
	Spreadsheet
	Text File
	Access
	Address book
	Figure 1.27 :Viewing the content in selected table


	Merging The Data Source With Main Document
	Editing a saved file of mailing labels

	Printing Mailing Labels
	Preparing For Printing
	Removing Blank Lines From Labels
	Printing
	Printing to a File for Previewing or Customizing Before Printing on Paper
	ACTIVITY
	Let's Practice
	QUESTIONS


	3. Give examples of databases in which the Data Source can be created.

